Community discussions

 
User avatar
payday
Member Candidate
Member Candidate
Topic Author
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Router reboots after MetaROUTER shutdown

Thu Jun 12, 2014 8:52 pm

I want to report a bug with MetaROUTER:
After shutting down MetaROUTER guest, router (host) hangs and after few seconds reboots itself. Log says: "router was rebooted without proper shutdown by watchdog timer".

Tested on two RB2011UAS-2HnD (first batch) with OpenWRT and RouterOS guests.
Tested also with new firmware (3.16) and newest RouterOS 6.15 but bug exist probably since v6.12.

Can anyone confirm this?
 
WonderLee
just joined
Posts: 1
Joined: Fri Jun 13, 2014 11:33 am

Re: Router reboots after MetaROUTER shutdown

Fri Jun 13, 2014 11:48 am

I got the same problem :(
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Router reboots after MetaROUTER shutdown

Fri Jun 13, 2014 4:16 pm

confirmed for MIPS as a workaround for now - do not shutdown the guest. Only reason i know you would like to shutdown - use reboot instead.
 
User avatar
payday
Member Candidate
Member Candidate
Topic Author
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: Router reboots after MetaROUTER shutdown

Fri Jun 13, 2014 7:37 pm

confirmed for MIPS as a workaround for now - do not shutdown the guest. Only reason i know you would like to shutdown - use reboot instead.
Thank you for answer.
I always shut down guests before router reboot (i.e. for system upgrade) to avoid file system corruption. I am not shure if it is safe to reboot host when guests are running. I guess RouterOS does not shutdown guests before reboot.
Is this bug on the list already or you want me to report it?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Router reboots after MetaROUTER shutdown

Mon Jun 16, 2014 9:49 am

the bug is filed anyway.
 
User avatar
payday
Member Candidate
Member Candidate
Topic Author
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: Router reboots after MetaROUTER shutdown

Mon Jun 16, 2014 7:35 pm

the bug is filed anyway.
Thank You :)
 
sergioag
just joined
Posts: 1
Joined: Thu Jan 23, 2014 12:03 am

Re: Router reboots after MetaROUTER shutdown

Wed Aug 13, 2014 4:02 pm

I got the same problem !!!

RB2011UiAS-2HnD, Firmware 3.10, ROS 6.15
 
ab130kd
newbie
Posts: 32
Joined: Thu Mar 02, 2006 8:11 pm
Location: Italy

Re: Router reboots after MetaROUTER shutdown

Tue Aug 26, 2014 11:34 am

I have the same problem on RB493G, RB750 and Metal... Please resolve because the auto reboot means for customers disservice..
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 796
Joined: Tue Aug 03, 2004 9:01 am

Re: Router reboots after MetaROUTER shutdown

Mon Dec 01, 2014 4:06 am

This bug is still not fixed on 6.22 and can occur if you shut down or reboot the guest from the guest's console, or use the '/metarouter shut-down' and '/metarouter reboot' commands; see http://forum.mikrotik.com/viewtopic.php ... 16#p458616

-- Nathan
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: Router reboots after MetaROUTER shutdown

Wed Feb 18, 2015 8:17 am

This bug is still not fixed on 6.22 and can occur if you shut down or reboot the guest from the guest's console, or use the '/metarouter shut-down' and '/metarouter reboot' commands; see http://forum.mikrotik.com/viewtopic.php ... 16#p458616

-- Nathan
6.27 ..still there :(
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 796
Joined: Tue Aug 03, 2004 9:01 am

Re: Router reboots after MetaROUTER shutdown

Wed Feb 18, 2015 12:57 pm

6.27 ..still there :(
Trust me: I know. :(

-- Nathan
 
rstik
just joined
Posts: 4
Joined: Thu Sep 04, 2014 12:27 am

Re: Router reboots after MetaROUTER shutdown

Tue Feb 16, 2016 12:16 am

Happened to me with 6.34 :(

Who is online

Users browsing this forum: No registered users and 1 guest