Community discussions

MikroTik App
 
viumden
just joined
Topic Author
Posts: 3
Joined: Mon Aug 24, 2015 6:26 am

Router OS is constantly crashed when Openwrt is running in Metarouter with network connections for a while

Mon Aug 24, 2015 7:00 am

What I did:

1. Compile Barrier Breaker with patch fixed rxbuf_size issue:
https://gist.github.com/leleobhz/61cd38 ... 76c07dd4f4

The final image I used:
http://oli.denq.us/content/images/2015/ ... tfs.tar.gz

2. Create metarouter with 64M ram and 40000KB disk size for the virtualisation environment on a RB2011UiAS-2HnD .

3. Import and the image, and add 2 physical ports to the newly created virtual Openwrt:
- ether1 as wan port, which is connected to a optical broadband modem
- ether5 as lan port, which is connected to a downstream network device
- ether1 and ether5 does not belong to any bridge in host Router OS
- the configuration details for openwrt network:
config interface 'lan'
	option ifname 'eth1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option proto 'pppoe'
	option username 'xxxxx'
	option password 'xxxx'
4. The whole setup works! WAN is connected with pppoe link, and when the downstream router connected to ether5 gets IP through DHCP service on virtualized openwrt, it can connect to internet do all the things as expected.

The problem is stability, after every around 1.5 hours, the whole routerboard rebooted:
router was rebooted without proper shutdown by watchdog timer
The resource status with Router OS is some thing like below when openwrt is still running correctly:
                   uptime: 1h22m44s
                  version: 6.31
               build-time: Aug/14/2015 15:42:51
              free-memory: 27.3MiB
             total-memory: 128.0MiB
                      cpu: MIPS 74Kc V4.12
                cpu-count: 1
            cpu-frequency: 650MHz
                 cpu-load: 49%
           free-hdd-space: 61.2MiB
          total-hdd-space: 128.0MiB
  write-sect-since-reboot: 702
         write-sect-total: 702
               bad-blocks: 0%
        architecture-name: mipsbe
               board-name: RB2011UiAS-2HnD
                 platform: MikroTik
The interesting thing is if the 2 assigned ports to metarouter openwrt are disabled, the stability will improve, so far more than 3 hours are observed without reboot. But that will make the virtualized openwrt meaningless.

I think this is clearly a bug for Router OS metarouter, which was discussed a lot I believe, but so far still no solution?
 
viumden
just joined
Topic Author
Posts: 3
Joined: Mon Aug 24, 2015 6:26 am

Re: Router OS is constantly crashed when Openwrt is running in Metarouter with network connections for a while

Fri Aug 28, 2015 10:26 am

I just tried Liquidcz's rootfs: http://openwrt.wk.cz/attitude_adjustment/mr-mips/, OpenWrt 12.09 Final with Linux kernel 3.3.8, which was proven by people earlier to be stable, but it is now same crash story, RB2011 rebooted automatically after 10~20 minutes. Obviously it is a Router OS bug. The topic has been open for around one week, any response from Miktorik? Or the metarouter feature is totally abandoned for MIPSBE based routerboards?
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: Router OS is constantly crashed when Openwrt is running in Metarouter with network connections for a while

Sat Aug 29, 2015 11:51 am

In your place I would try to avoid ros 6.31.. too many reboots from watchdog have been reported (maybe metarouter doesn't matter).
I'd try 6.30.4 (or 6.27) first and see if problem on metarouter persist or not

Who is online

Users browsing this forum: No registered users and 45 guests