Community discussions

 
Godmode
just joined
Topic Author
Posts: 8
Joined: Sun Dec 17, 2017 9:39 pm

CRS317 boot issue after power failure

Wed May 23, 2018 9:16 am

Hi,

I use a CRS317 as core switch for my 10g LAN. We had two power failures in the last 2 weeks, because of thunderstorms. When the power comes back, the CRS317 isn't switching. I have to cut the power cables (1 and 2) and wait a minute. After that period, the switch works again. Is this a known problem, or should I connect the switch to a UPS?

Thanks.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23545
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CRS317 boot issue after power failure

Wed May 23, 2018 11:54 am

What kind of SFP modules are you using there? Specifically models
No answer to your question? How to write posts
 
Godmode
just joined
Topic Author
Posts: 8
Joined: Sun Dec 17, 2017 9:39 pm

Re: CRS317 boot issue after power failure

Wed May 23, 2018 12:16 pm

I use the SFP-S-85DLC03D from Mikrotik. And I forgot to mention, I run SwOs.

Image
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23545
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CRS317 boot issue after power failure

Wed May 23, 2018 12:35 pm

Is the device accessible and operational from the management ethernet port, during the problem?
No answer to your question? How to write posts
 
Godmode
just joined
Topic Author
Posts: 8
Joined: Sun Dec 17, 2017 9:39 pm

Re: CRS317 boot issue after power failure

Wed May 23, 2018 12:57 pm

I haven't tried that, because it was time critical. Only the blue power LEDs were active, the SFP+ LEDs were all inactive/dark.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23545
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: CRS317 boot issue after power failure

Wed May 23, 2018 12:59 pm

If the issue repeats itself, try the management port. This would help us to repeat the issue quicker.
No answer to your question? How to write posts
 
Godmode
just joined
Topic Author
Posts: 8
Joined: Sun Dec 17, 2017 9:39 pm

Re: CRS317 boot issue after power failure

Wed May 23, 2018 1:10 pm

Thank you, I will do that the next time.
 
User avatar
k6ccc
Member
Member
Posts: 363
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: CRS317 boot issue after power failure

Wed May 23, 2018 10:17 pm

In my opinion, regardless of this problem, you should have protected power for your network core.



Sent from a $&@#% iPhone using Tapatalk
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
artz
MikroTik Support
MikroTik Support
Posts: 85
Joined: Tue Oct 17, 2017 5:51 pm
Location: Riga
Contact:

Re: CRS317 boot issue after power failure

Wed Jun 06, 2018 10:58 am

We found a software issue that prevented SFP ports linking up properly after a power cycle in some cases. The fix will be included in the next SwOS version.
 
Godmode
just joined
Topic Author
Posts: 8
Joined: Sun Dec 17, 2017 9:39 pm

Re: CRS317 boot issue after power failure

Tue Aug 07, 2018 9:04 pm

Hi,

I have updated to SwOS 2.8 and now my CRS317 hangs up after a few minutes. Any known issues? Where can I download 2.7?
 
User avatar
z4ki
just joined
Posts: 1
Joined: Thu Dec 01, 2016 8:03 pm
Location: Bangladesh

Re: CRS317 boot issue after power failure

Wed Aug 15, 2018 3:59 pm

what steps you took? today we had same problem after upgrade to SwOS 2.8, STP was not working and it was taking so much time to boot up but downgrade to 2.6 resolved the problem.
 
Godmode
just joined
Topic Author
Posts: 8
Joined: Sun Dec 17, 2017 9:39 pm

Re: CRS317 boot issue after power failure

Thu Aug 16, 2018 10:43 am

I downloaded 2.7 and then everything was fine agin. I have bought a 2nd CRS317 and some CRS125 to test 2.8 in an isolated test environment. Updating on our live system was a bad idea.
 
kd6icz
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jun 15, 2016 11:29 pm

Re: CRS317 boot issue after power failure

Thu Aug 30, 2018 2:31 am

I was having the same issue on my 317 with 2.7. Now I’m on 2.8 and while the link issue appears to be resolved, a much worse issue has appeared.

The switch intermittently stops passing traffic. This includes accessing the GUI. I might have to revert back to 2.7 myself and just bounce the ports like I used to to restore layer 1.
 
kd6icz
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jun 15, 2016 11:29 pm

Re: CRS317 boot issue after power failure

Wed Sep 05, 2018 10:18 pm

I backed down to 2.6 and now the switch is passing traffic like it’s supposed to.
 
kd6icz
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jun 15, 2016 11:29 pm

Re: CRS317 boot issue after power failure

Fri Sep 14, 2018 6:24 am

I see SwOS 2.9 was released today. Who's gonna be brave and give it a test run?
 
User avatar
k6ccc
Member
Member
Posts: 363
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: CRS317 boot issue after power failure

Fri Sep 14, 2018 6:32 am

I see SwOS 2.9 was released today. Who's gonna be brave and give it a test run?

Where are you seeing that 2.9 was released? Not on the software download page and no announcements here on the forum.
Ah, one of my switches shows that:
Current Installed Version 2.8 (built at Fri Jul 13 2018 04:37:06 GMT-0700 (Pacific Daylight Time))
Latest Available Version 2.8 (built at Thu Sep 13 2018 19:40:15 GMT-0700 (Pacific Daylight Time))


And under Changelog:
What's new in v2.9:

*) CRS326 & CRS328 & CRS317: make sure that RSTP BPDU packets are always untagged;
*) CRS328-4C-20S-4S+: make 1G fiber SFP modules work;
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
k6ccc
Member
Member
Posts: 363
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: CRS317 boot issue after power failure

Fri Sep 14, 2018 6:33 am

2.9 does nothing for me, so I likely won't bother with this one...
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
eider
newbie
Posts: 26
Joined: Thu Nov 30, 2017 10:14 pm

Re: CRS317 boot issue after power failure

Fri Sep 14, 2018 1:10 pm

There are a lot of issues with auto-upgrade in SwOS. For example right now I see 2.7 as newest despite 2.8 being released for quite a while now. Attempting to manually fetch 2.9 via crafted links fail so most likely it was not planned to be released today or they found critical bug in last moment and decided to pull it.
 
User avatar
Splash
Member Candidate
Member Candidate
Posts: 144
Joined: Fri Oct 16, 2015 10:09 am
Location: Johannesburg, South Africa

Re: CRS317 boot issue after power failure

Fri Sep 14, 2018 3:04 pm

Hi,

I use a CRS317 as core switch for my 10g LAN. We had two power failures in the last 2 weeks, because of thunderstorms. When the power comes back, the CRS317 isn't switching. I have to cut the power cables (1 and 2) and wait a minute. After that period, the switch works again. Is this a known problem, or should I connect the switch to a UPS?

Thanks.
Thought of running RouterOS instead? Its far more powerful than SWOS and more mature in my opinion?
MTCNA, MTCRE, MTCINE, MTCTCE, MTCIPv6E, MTCUME
 
spammyduck
newbie
Posts: 36
Joined: Tue Aug 10, 2010 7:25 am

Re: CRS317 boot issue after power failure

Sun Nov 11, 2018 7:41 pm

"And under Changelog:
What's new in v2.9:

*) CRS326 & CRS328 & CRS317: make sure that RSTP BPDU packets are always untagged;
*) CRS328-4C-20S-4S+: make 1G fiber SFP modules work;"


I'm seeing the same thing on my switch currently running v2.8 . That post was from Sept of this year, I would very much like the "make 1G fiber SFP modules work;" part.

So what is the scoop on the mysterious v2.9 ?
 
User avatar
RusConSPb
newbie
Posts: 27
Joined: Thu May 03, 2012 4:17 pm
Location: Helsinki, Finland

Re: CRS317 boot issue after power failure

Sun Nov 11, 2018 11:09 pm

So what is the scoop on the mysterious v2.9 ?
Nobody knows... we all hope for more than 3 months already that Mikrotik team will give some love to SwOS. Maybe we will get it as Christmas gift :) Pray and hope!

Who is online

Users browsing this forum: No registered users and 1 guest