Community discussions

MikroTik App
 
warheat1990
just joined
Topic Author
Posts: 6
Joined: Mon Sep 04, 2017 6:20 pm

PS4 suddenly not getting IP address from DHCP after I update my Mikrotik switch firmware to SwOS v2.5

Sat Sep 16, 2017 8:57 am

Hi guys, so today I update my Mikrotik switch from v2.4 to v2.5 and notice that my PS4 no longer has internet connection (it works just fine before this update). My network diagram is something like this:

pfSense -> Mikrotik Switch (CSS326-24G-2S+) -> patch panel -> keystone jack -> TP-Link unmanaged switch (SG108)

There are PC, Raspberry Pi, laptop, and PS4 connected via ethernet cable under this TP-Link unmanaged switch. And every device seems to work just fine except PS4. So I begin to troubleshoot.

1. Use different cable -> not working
2. Use other port -> not working
3. Use static IP under PS4 setting (but still connected to unmanaged switch) -> works
4. Connect the PS4 directly to Mikrotik switch (bypassing the unmanaged switch) -> works

At this point, I'm confused if the problem is my Mikrotik switch or the unmanaged switch, in my test result, it seems like the problem is the unmanaged switch but I don't have this issue before I update my Mikrotik switch and other device (except PS4) seems to be working just fine under this unmanaged switch. How do I troubleshoot to make sure which one is the issue? I already tried to restart everything (pfSense, Mikrotik switch, unmanaged switch) and still not working. For now, I use static IP address for PS4.

Changelog for the Mikrotik update:

What's new in v2.5:

*) SFP & SFP Status tabs are combined into one;
*) Global RSTP settings are moved unto RSTP tab;
*) Static Hosts & Hosts tabs are combined into one;
*) CSS106, CRS326, CRS317: added support for IGMP snooping;
*) CRS326 & CRS317: fixed occasional lockup on SFP module insertion;
*) CSS106: added global independent VLAN lookup option for all VLANs;
*) CSS106: do not enable IVL on reboot if it's disabled;
*) implemented DHCP client;
*) CRS326 & CRS317: added support for DHCP & PPPoE snooping and
injecting option 82 (Intermediate Agent info);
*) CRS317: support fans;

CAVEAT: switch address acquisition mode by default is DHCP with fallback to static address;

Note: I don't use VLAN or any of these fancy settings.

I stil have 2.4 firmware file, is it safe to downgrade from v2.5 to v2.4 via webGUI? Can someone provide an instruction? I want to downgrade to v2.4 and see if the issue is really in the Mikrotik.

Who is online

Users browsing this forum: No registered users and 11 guests