Community discussions

 
elbob2002
newbie
Topic Author
Posts: 48
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

CRS328-24P-4S+ - Insane Temperatures

Sat Jul 28, 2018 3:06 am

Upgraded to SwOS 2.8. Now getting this:
CPU Temperature 67C
Board Temperature 0C
FAN1 0 RPM
FAN2 0 RPM
PSU1 526mA @ 26.65V

Fans aren't spinning. Were before and were quite noisy.

SwOS 2.7 reported temperature in and around 30 to 38 degrees and fan speed around 4000rpm.

RB3011 sitting on top of the 328 reports:
Voltage 25.9 V
Temperature 37 C

750Gr3 on top of the 3011 reports this:
Voltage 26.4 V
Temperature 43 C

CRS125 in same room but different area reports this:
Voltage 26.0 V
Temperature 29 C

I'm assuming I should be very worried and prepare an RMA? Room temperature is 19 degrees .
 
nuffrespect
newbie
Posts: 38
Joined: Wed Jun 14, 2017 5:21 pm

Re: CRS328-24P-4S+ - Insane Temperatures

Fri Aug 03, 2018 3:49 pm

Hi, on some CRS328-POE we have the same bug!

Some switches updated normally, some are alive, but 0 RPM with 67-72 Temp

But there was no problem with cooling with 2.7p version, loudly - yes, but no 0 RPM :/
 
nuffrespect
newbie
Posts: 38
Joined: Wed Jun 14, 2017 5:21 pm

Re: CRS328-24P-4S+ - Insane Temperatures  [SOLVED]

Sat Aug 04, 2018 12:24 am

UPD
Well, the second repeat of update - partially, i think, solved the bug
temp decrease, health page now shows systemboard's temperature.

Can someone from Mikrotik explain this?
 
elbob2002
newbie
Topic Author
Posts: 48
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: CRS328-24P-4S+ - Insane Temperatures

Sat Aug 04, 2018 12:31 am

I’m out of the office now but thanks! I’ll try reinstalling the update and post my results here.
 
elbob2002
newbie
Topic Author
Posts: 48
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: CRS328-24P-4S+ - Insane Temperatures

Sat Aug 04, 2018 2:37 am

Forced a reboot of the switch and fans are working again!

CPU Temperature 39C
Board Temperature 35C
FAN1 4440 RPM
FAN2 4410 RPM
 
nuffrespect
newbie
Posts: 38
Joined: Wed Jun 14, 2017 5:21 pm

Re: CRS328-24P-4S+ - Insane Temperatures

Sun Aug 05, 2018 8:53 am

UPD2

On some devices after few hours after force reboot or update, I have the same problem.

60C CPU
0C Board
0 RPM
0 RPM


Because this switch in 2500 km from me, I don’t know about real cooling.

+ empty parameters in some excels in SFP+ tab

As I wrote earlier, force reboot, solves it, but that’s not normal situation, make reboots of the switch several times for the day.
 
sphitsa
just joined
Posts: 1
Joined: Thu Sep 27, 2018 11:00 am

Re: CRS328-24P-4S+ - Insane Temperatures

Thu Sep 27, 2018 11:14 am

CRS328-24P-4S+
SwOS 2.8

i found the same problem.

CPU Temperature : 61C
Board Temperature : 0C
FAN1 : 27648 RPM
FAN2 : 0 RPM

after reboot

CPU Temperature : 40C
Board Temperature : 30C
FAN1 : 4560 RPM
FAN2 : 4545 RPM

about 1-3 days will found the problem again.

Could you help me fix it, please?
 
elbob2002
newbie
Topic Author
Posts: 48
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: CRS328-24P-4S+ - Insane Temperatures

Fri Sep 28, 2018 10:55 pm

The only thing that worked for me was to reboot the switch.

I had a power failure here recently and since the power came back I've had no issues since. It's very strange.
 
8cqv
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Tue Mar 06, 2018 5:25 pm

Re: CRS328-24P-4S+ - Insane Temperatures

Tue Oct 02, 2018 8:17 pm

Have the same thing.
Image
Does your software report as 2.7p or 2.8?

My CSS326 just arrived today to go alongside my CRS328 but the flaky SwOS behaviour is worrying...
 
elbob2002
newbie
Topic Author
Posts: 48
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: CRS328-24P-4S+ - Insane Temperatures

Wed Oct 03, 2018 9:54 am

Mine says 2.8 (built at Fri Jul 13 2018 12:37:17 GMT+0100 (IST))

However I see there is now an update available:

Latest Available Version 2.8 (built at Wed Oct 03 2018 07:02:09 GMT+0100 (IST))

Will upgrade later this evening and see how it goes.
 
8cqv
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Tue Mar 06, 2018 5:25 pm

Re: CRS328-24P-4S+ - Insane Temperatures

Fri Nov 16, 2018 12:00 pm

Its firmware bug in SwOS, have a look here for more discussion:
viewtopic.php?t=132553#p685035

What I found was it was a very small PoE load that seemed to confuse it, now I a couple more devices 4-5w each the fans just run 24*7.

Its a worrying problem as once the fan control dies/crashes the fans never run and I found on several occasions the switch was getting very very hot to the touch so hate to think what the CPU temps were!
 
elbob2002
newbie
Topic Author
Posts: 48
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: CRS328-24P-4S+ - Insane Temperatures

Mon Nov 19, 2018 8:40 pm

I gave up on SwOS in the end. Booted to RouterOS and haven't had any issues since.

Who is online

Users browsing this forum: No registered users and 4 guests