Community discussions

 
Kurlec
just joined
Topic Author
Posts: 20
Joined: Wed Mar 16, 2016 9:07 am

CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Mon Feb 11, 2019 9:31 am

Hi,

Our CRS328-24P-4S+ is currently running on SWOS 2.9 and we are experiencing issues where the switch go into a idle state where no ports are talking to each other and does not pass traffic on ETH or VLANS also the switch is inaccessible during this time until the CRS328-24P-4S+ is rebooted then it runs again for a couple of days, we have replaced the switch as whole with another CRS328-24P-4S+ with SWOS 2.9 and receiving the same issue, we currently have 9 of these CRS328-24P-4S+ in the field all giving problems after 2.9 upgrade and i am unable to downgrade to SWOS 2.8

Also after 3-4 Hours of running we are receiving a red LED FAN failure error on all CRS328-24P-4S+ switches.
Image
Image

Also after upgrade to SWOS 2.9 port 23 and port 24 gives alot of link downs on a basis of 3 days almost 300 link downs, but when we plug that same device into port 22, we receive 0 link downs in 14 days.

SWOS Upgrade page also displaying same SWOS 2.9 as a new release with the same date, even after upgrade still the same
Image

Is there a fix coming soon for this or is there a work around?
 
Ragnos
just joined
Posts: 1
Joined: Thu Feb 14, 2019 9:35 am

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Thu Feb 14, 2019 9:40 am

I am experiencing the exact same issues. The FAN error occurs randomly with various timespans inbetween. Rebooting via WebInterface does fix this for the moment, that is unless the whole thing freezes. I've already tried a factory reset with restoring the backup, and redoing the whole configuration manually, but that didn't help either.

I've deployed this switch last summer and it worked fine up until this year.
 
ATROX
newbie
Posts: 44
Joined: Mon Oct 14, 2013 2:10 pm

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Fri Feb 22, 2019 7:23 am

Problem on CRS328-4C-20S-4S+
Everything freezes!
Developers - FIX it!
 
ATROX
newbie
Posts: 44
Joined: Mon Oct 14, 2013 2:10 pm

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Mon Mar 11, 2019 7:29 am

Time passes and a critical error is not FIXED!!!
 
EdPa
MikroTik Support
MikroTik Support
Posts: 11
Joined: Fri Sep 15, 2017 10:05 am
Location: Riga
Contact:

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Mon Mar 11, 2019 8:41 am

Regarding the fan fault-led, the SwOS v2.9 has few changes which require updated fan controller firmware that comes only within RouterOS. You should boot your CRS328-24P-4S+ in RouterOS and upgrade to the latest stable version (currently it is 6.44). Also, you can make a firmware update (/system routerboard upgrade). After that, you can simply boot back to SwOS.

In case you are still having these problems, I suggest writing to support@mikrotik.com.
 
erich408
just joined
Posts: 7
Joined: Sat Jan 19, 2019 6:07 am

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Mon Mar 11, 2019 8:38 pm

Regarding the fan fault-led, the SwOS v2.9 has few changes which require updated fan controller firmware that comes only within RouterOS. You should boot your CRS328-24P-4S+ in RouterOS and upgrade to the latest stable version (currently it is 6.44). Also, you can make a firmware update (/system routerboard upgrade). After that, you can simply boot back to SwOS.

In case you are still having these problems, I suggest writing to support@mikrotik.com.
Are you freaking kidding me? That is highly unacceptable. I bought one of these, updated to 2.9, had the same issue. RMA'd it, got a second one, has the same issue. To ask someone to reboot their switch into a different mode, just to update firmware is absolutely unacceptable, especially if they have it in production. Mikrotik needs to come up with a way to patch the firmware via swos, not a "boot into router os, update to latest routerOS, patch firmware, reboot back into SwOS. that's like telling someone running linux that they need to install Windows, update firmware, then go back to linux.

FIND A BETTER WAY
 
Kurlec
just joined
Topic Author
Posts: 20
Joined: Wed Mar 16, 2016 9:07 am

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Wed Mar 13, 2019 7:10 pm

Regarding the fan fault-led, the SwOS v2.9 has few changes which require updated fan controller firmware that comes only within RouterOS. You should boot your CRS328-24P-4S+ in RouterOS and upgrade to the latest stable version (currently it is 6.44). Also, you can make a firmware update (/system routerboard upgrade). After that, you can simply boot back to SwOS.

In case you are still having these problems, I suggest writing to support@mikrotik.com.
Hi guys,

All my problems has been solved, although i had to go out to each site which costed my alot of money, i booted the CRS328 into routerOS, upgraded the software to 6.44 and the Routerboot firmware to 6.44, booted back into SWOS and havent had any issues yet, been running for 24 days straight, no lags, no spikes and fans working perfectly.

Thanks we know that you guys are trying your best and this is a new product, i would like to ask to test this in factory first before releasing a new product.

Thanks for the update of 6.44 tho, much appreciated.
 
erich408
just joined
Posts: 7
Joined: Sat Jan 19, 2019 6:07 am

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Wed Mar 13, 2019 8:09 pm

Did you lose your switch settings when booting into routeros? Or does it save the swos configs during dual boot?
 
Kurlec
just joined
Topic Author
Posts: 20
Joined: Wed Mar 16, 2016 9:07 am

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Thu Mar 14, 2019 12:16 am

If you setup RouterOS or SWOS it saves the config so if you change to either RouterOS or SWOS the config is still saved if you boot back to SWOS or RouterOS depending what you configured. if you configured both then both will still have their config when you switch between RouterOS and SWOS

I don't know if this make sense xD
 
erich408
just joined
Posts: 7
Joined: Sat Jan 19, 2019 6:07 am

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Sat Mar 16, 2019 9:34 am

If you setup RouterOS or SWOS it saves the config so if you change to either RouterOS or SWOS the config is still saved if you boot back to SWOS or RouterOS depending what you configured. if you configured both then both will still have their config when you switch between RouterOS and SWOS

I don't know if this make sense xD
It does, I had a feeling it would, but this seems like a really stupid workaround to get this solved. I'll try it on mine this weekend and see if i can get it resolved, because the stupid fans ramping up and down in my rack is driving me nuts when im in the garage. Was getting sick of UBNT BS...starting to think Mikrotik is worse with this issue.

Thanks for confirming!
 
ATROX
newbie
Posts: 44
Joined: Mon Oct 14, 2013 2:10 pm

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Mon Mar 25, 2019 7:27 am

I confirm. After the update to FirmWare to 6.44 and boot SwOS - all problems are resolved. Uptime 10 days.
 
erich408
just joined
Posts: 7
Joined: Sat Jan 19, 2019 6:07 am

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Mon Mar 25, 2019 7:30 am

I confirm. After the update to FirmWare to 6.44 and boot SwOS - all problems are resolved. Uptime 10 days.
Finally did it, but this is a dumb workaround. So far so good, ~ 6 days no fan errors
 
User avatar
k6ccc
Member
Member
Posts: 425
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Mon Mar 25, 2019 11:56 pm

This thread is an interesting read. I have two CSS326-24G-2S+RM and one CRS326-24G-2S+RM that got updated to 2.9 a few days ago. Obviously no fan issues since the 326 doesn't have fans. I have not observed any problems - so far (64 1/2 hours). I will be watching however...
I'll laugh my ass off if MT says that I should boot the CSS326s into RouterOS to do a firmware update!
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
erich408
just joined
Posts: 7
Joined: Sat Jan 19, 2019 6:07 am

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Tue Mar 26, 2019 1:17 am

This thread is an interesting read. I have two CSS326-24G-2S+RM and one CRS326-24G-2S+RM that got updated to 2.9 a few days ago. Obviously no fan issues since the 326 doesn't have fans. I have not observed any problems - so far (64 1/2 hours). I will be watching however...
I'll laugh my ass off if MT says that I should boot the CSS326s into RouterOS to do a firmware update!
It's by far the dumbest suggestion I've heard from any customer support org... How that solution got approved is beyond me.
 
User avatar
kosyot
just joined
Posts: 17
Joined: Wed Jan 16, 2019 1:28 pm
Contact:

Re: CRS328-24P-4S+ Link Downs, Port Isolation, FAN Error

Tue Apr 09, 2019 9:36 pm

Just passing to say that MiktoTik support suggested same procedure (boot RouterOS upgrade to 6.44, routerboard too, back to SwOS 2.9) for freezing problem CRS317-1G-16S+RM.
Not working at all, back to latest stable SwOS for CRS317 -2.7.
I see above for CRS328 is OK, seems different problem for CRS317....

Who is online

Users browsing this forum: No registered users and 2 guests