Community discussions

MikroTik App
 
NguyenHuuTai
just joined
Topic Author
Posts: 11
Joined: Sat Oct 19, 2019 4:33 am

LOADBLACING

Mon Aug 24, 2020 7:56 am

hi everyone, i have two wan, The bandwidth is 200M and 100M, respectively, I want to configure the loadblacing to a 2: 1 ratio, please help me.
 
jarda
Forum Guru
Forum Guru
Posts: 7765
Joined: Mon Oct 22, 2012 4:46 pm

Re: LOADBLACING

Mon Aug 24, 2020 8:27 am

Have you used Google? Which posts from this forum you have tried?
Are you sure this should be in swOS forum section?


 
User avatar
anav
Forum Guru
Forum Guru
Posts: 5945
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: LOADBLACING

Fri Sep 11, 2020 9:39 pm

Which device are you using.
What have you tried so far?
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
DarkNate
Member Candidate
Member Candidate
Posts: 273
Joined: Fri Jun 26, 2020 4:37 pm

Re: LOADBLACING

Sat Sep 12, 2020 11:52 pm

hi everyone, i have two wan, The bandwidth is 200M and 100M, respectively, I want to configure the loadblacing to a 2: 1 ratio, please help me.
Why did you post this in SwOS? Did you bother to search with Google first?

Do something like this:
/ip firewall mangle
###Accept LAN traffic###
add action=accept chain=prerouting dst-address-list=not_in_internet in-interface-list=LAN

###Redirect incoming WAN traffic to their corresponding WAN interface###
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=pppoe-out1 new-connection-mark=ISP1_conn
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=pppoe-out2 new-connection-mark=ISP2_conn

#ForHTTPS###
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-list=!not_in_internet dst-port=80,443 in-interface=bridge new-connection-mark=ISP1_conn per-connection-classifier=both-addresses:3/0 protocol=tcp
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-list=!not_in_internet dst-port=80,443 in-interface=bridge new-connection-mark=ISP1_conn per-connection-classifier=both-addresses:3/1 protocol=tcp
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-list=!not_in_internet dst-port=80,443 in-interface=bridge new-connection-mark=ISP2_conn per-connection-classifier=both-addresses:3/2 protocol=tcp

###ForNormal connections, to get full speeds###
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-list=!not_in_internet in-interface=bridge new-connection-mark=ISP1_conn  per-connection-classifier=both-addresses-and-ports:3/0
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-list=!not_in_internet in-interface=bridge new-connection-mark=ISP1_conn  per-connection-classifier=both-addresses-and-ports:3/1
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-list=!not_in_internet in-interface=bridge new-connection-mark=ISP2_conn  per-connection-classifier=both-addresses-and-ports:3/2

add action=mark-routing chain=prerouting connection-mark=ISP1_conn dst-address-list=!not_in_internet in-interface=bridge new-routing-mark=to_ISP1 
add action=mark-routing chain=prerouting connection-mark=ISP2_conn dst-address-list=!not_in_internet in-interface=bridge new-routing-mark=to_ISP2 
add action=mark-routing chain=output connection-mark=ISP1_conn dst-address-list=!not_in_internet new-routing-mark=to_ISP1
add action=mark-routing chain=output connection-mark=ISP2_conn dst-address-list=!not_in_internet new-routing-mark=to_ISP2

/ip route
add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_ISP1 check-gateway=ping comment="Load Balancing Route to ISP 1"
add dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_ISP2 check-gateway=ping comment="Load Balancing Route to ISP 2"

Who is online

Users browsing this forum: EdPa and 7 guests