Community discussions

MikroTik App
User avatar
just joined
Topic Author
Posts: 1
Joined: Thu Oct 08, 2020 3:54 pm

SFP BiDi not working with certain devices

Thu Oct 08, 2020 4:13 pm


I got a really strange problem with my CRS309-1G-8S+ running SwOS.

I've got for almost a year now a connection between my server cabinet and my bedroom with the CRS309 with a SingleMode 1Gbit SFP BiDi module on the on end and on the other with a TP-Link Media Converter (MC220L) with also the opposite 1Gbit SFP BiDi module running without any problems.

Now as time goes by I needed more RJ45 ports (exactly 2 are needed) in my bedroom so I've bought a Trendnet 4 port Switch (TEG-S51SFP) with a SFP slot and put the module from the TP-Link Media Converter into the Trendnet Switch and strangely enough it's not working.
SwOS tells me that it transmits packages but doesn't receive packages.

So I've though I buy a Media Converter from FS with two RJ45 ports, I also received that yesterday and tried it.
Same as with the Trendnet 4 port Switch.

After 2 hours of troubleshooting, I booted into RouterOS and strangely enough both, the Trendnet Switch and also the MediaConverter from FS worked like nothing ever happened...

Can somebody tell me what's going on there?

I've run the latest version of SwOS and also tried reseting the CRS309 itself but that changed nothing.
I also got a CRS305-1G-4S+IN and it's the same on SwOS, if I switch over to RouterOS everything is working fine.


Who is online

Users browsing this forum: No registered users and 2 guests