Community discussions

MikroTik App
User avatar
just joined
Topic Author
Posts: 13
Joined: Tue Jan 26, 2021 12:51 pm
Location: Bay Area, CA

CSS610-8G-2S+ First Run Experience. Hint: Not Good

Mon Feb 08, 2021 9:08 am

This is an incendiary post. Perhaps too incendiary from a newcomer. I don't enjoy trashing a product and, by proxy, the dozens of people who worked on it, but I am angry and disappointed. I'd heard such great things about MikroTik and this switch was the exact product that I needed. There are literally no other options in this size and feature set at any price. So, despite reading about all the issues, I abandoned common sense and order a pair of them. What follows is an informal log of what I experienced from power-on. I tried to remain dispassionate until the end.

First Run:
The box finally arrived with my two new CSS610-8G-2S+ switches & pair of S+RJ10 transceiver units. I plugged in the first one and the blue power led came up fine.

Connected cat5e cable to port 1 and then MBP laptop. Link lights!

Tried connecting to (per online user manual) and got a spinning browser. Tried and saw the swOS screen. Made the mistake of trying to name the router, clicked on apply and lost connectivity. Held down the reset button and cycled the power. Tried again, but still spins, so back to

Installed 2.13rc12 quickly and lost connection, is dead, but works now. Go figure. Quickly add a password (no password by default? In 2021?) and it sticks.

Set to DCHP with fallback to the following and applied:

Identify: "TikSwitch-Test"

Relogin with new IP, see Identity set to "TikSwitch-" Ugh... First bug (or is that #2?).

Connect switch port #2 to network (NETGEAR switch behind pfSense router with switch MAC added to DHCP Server) and cycle power. Get IP on laptop, but can't reach switch. Doesn't respond at Scan network and find a new device at with the correct MAC address, so it didn't pick up DHCP. Double-check setting in pfSense, which is correct. Cycle power again and this time it responds to ping at .6. Then, suddenly it doesn't and appears on my network again. Cycle power again and .6 is back. I quickly run cli-speediest and get back: 123.39 Mbit/s - 158.89 Mbit/s via my 1G fiber. Meh. Save Backup successfully and the UI is still working.

Plug in S+RJ10 module into SFP1 with no cable and UI shows revision 2.16. Move network cable from port 2 (network) to SFP1. Still responds to pings, but UI shows no data when switching between tabs and then fails to reload. Mac shows link lights, but can't ping switch or router. Power cycle again. And it's back...

Run cli-speediest again and get: 783.07 Mbit/s - 165.31 Mbit/s. That's more like it. Though, this is puzzling as the transceiver is connected to a 1G port on the other side still.

Went to go get a drink, came back to find UI unresponsive and .157 back on the network. Going to give up on DHCP and set a static IP. Cycled power and UI is back on .6. DHCP client appears broken on this switch. Another bug, but manageable.

Switch still hasn't crashed after 15 minutes. Next going to try connecting a Sabrent USB to 2.5G Ethernet Adapter and see how the swOS likes the higher speed. Disconnect cable from SFP1 from wall jack, moved cable from computer to port 1 and connect to wall jack, then connected cable from SFP1 to Sabrent adapter. Happily, this time everything works. Connected at 2.5G with no crashes. (BTW, if anyone needs a quick 2.5G network adapter, the Sabrent is a really nice bit of kit. A solid aluminum block, good cable and thick USB A connector). That said, I'm disappointed to discover that MikroTik doesn't recommend running the S+RJ10 in adjacent SFP+ ports due to overheating and to instead space them, but since this switch only has a pair of said ports, I'm hosed.

The switch seems to regularly crash. Fortunately, it's coming back up and seems to remember the minor changes I've made. Too tired to battle with VLANs tonight. Perhaps tomorrow, but I am not optimistic.

I finally figured out the rationale for the odd choice of putting the power plug on the front of the unit. You need easy access, because you're going to be pulling it a lot...

Jokes aside, this is probably the worst first run experience I've ever had with any piece of hardware in my 30+ years in tech. Mikrotik should be ashamed for releasing such a shoddy product to the market when even a trivial run through would made apparent fundamental stability flaws. Speaking of shame, it is a shame such a nice bit of hardware has been so thoroughly ruined by crappy software. This little box is an ideal compact unit. My former company would have bought dozens of these to provide designers and 3D artists faster access to asset storage, but I'm not going to suggest it because the total product is garbage in current form. The ultimate shame of it is, that this product and, at least to me, Mikrotik's reputation are forever tainted.


Who is online

Users browsing this forum: No registered users and 6 guests