Community discussions

MikroTik App
just joined
Topic Author
Posts: 1
Joined: Mon Feb 15, 2021 4:17 am

CSS610-8G-2S+IN No Link on SFP+ with Intel X520

Wed Feb 17, 2021 11:37 pm

just wanted to let you know that there's a huge bug, using the CSS610-8G-2S+IN with an Intel X520-DA2.

The Switch will show an active Link on SFP+, but it doesnt get recognized by the Intel NIC, for both and DAC. Reproduced it with 2 different Intel Cards as well as 3 Transceiver pairs and cables and one DAC.

Tried following Firmwares:
2.12 (shipped with this)

With 2.13rc12 the issue is resolved, and i have a stable connection, but when updating to 2.13rc25 the issue is back. So there's definitly a bug in the firmware.

I already created a ticket for this issue, but as it did take me weeks to resolve this, i wanted to share incase someone has the same problem.
just joined
Posts: 1
Joined: Thu Feb 18, 2021 1:07 pm

Re: CSS610-8G-2S+IN No Link on SFP+ with Intel X520

Thu Feb 18, 2021 1:11 pm

Same thing i have a Intel X520 DA1
Tested multiple DAC and Transceiver.
2.12 didn't work
2.13rc12 worked

also tested an other 2.13 from support and didn't work.

Switch always show( even with the broken firmwares) link up and show info from DAC and Transceiver
just joined
Posts: 1
Joined: Tue Dec 03, 2019 10:51 pm

Re: CSS610-8G-2S+IN No Link on SFP+ with Intel X520

Fri Feb 19, 2021 6:39 pm

Looks like the same problem i have - Intel x520-1 cards with FS SFP-10GSR-85 sfp+ plugs on both windows and linux without luck (unplugged network cable/no carrier).
Everything looks great in the switch including that there should be link, but something seems to be failing in auto negotiation. Cards, sfp plugs and fiber is good in other equipment. Setting 1g full duplex manually on both ends works.

Edit: 2.13rc12 does indeed seem to allow me to link.
Last edited by smakkerlak on Fri Feb 19, 2021 7:42 pm, edited 1 time in total.
just joined
Posts: 1
Joined: Sat Feb 20, 2021 4:52 pm

Re: CSS610-8G-2S+IN No Link on SFP+ with Intel X520

Sat Feb 20, 2021 7:36 pm

Hi all, same thing here.

when back to rc12 from rc25. everything working for 12hours so far.
Downgrading keep all my settings

2 LAG enable (static and active)
2 Vlans (1,100)
DHCP working on all links
the SFPs are working (X520-da1)
watchdog enable
got mac on hosts
management through sfp2 is working
Last edited by duy31 on Sun Feb 21, 2021 10:33 am, edited 1 time in total.

Who is online

Users browsing this forum: No registered users and 7 guests