Community discussions

MikroTik App
 
torob2
just joined
Topic Author
Posts: 1
Joined: Tue Jun 08, 2021 3:26 pm

CSS610-8G-2S+ link issue with SwOS Lite 2.14 and Apple Mac mini

Tue Jun 08, 2021 4:41 pm

A recently purchased CSS610-8G-2S+ was shipped with SwOS Lite 2.13. After upgrading to 2.14, I noticed that an Apple Mac mini (Late 2012) with a Broadcom 57766-A1 Gigabit Ethernet controller can no longer establish a stable link with the switch. The link/speed LEDs are on for about 2 seconds, go out for about 2 seconds and this repeats forever. In the Link section of the web interface, I can see that the link disappears and reappears all the time. I cannot reach the Mac mini with 2.14 anymore. Using another port didn't help nor did a different ethernet cable.

Other devices weren't affected with 2.14. I downgraded to 2.13 and now I get a stable link with the Mac mini. So, it's quite obvious that 2.14 is causing this issue.
 
anschluss
just joined
Posts: 14
Joined: Fri Mar 30, 2018 3:46 pm

Re: CSS610-8G-2S+ link issue with SwOS Lite 2.14 and Apple Mac mini

Tue Jun 08, 2021 8:18 pm

It could be an issue with the automatic link speed detection. As a temporary solution, have you tried disabling link speed negotiation? Apple>System Preferences->Network>Ethernet->Advanced->Hardware/Ethernet and manually choose e.g. 1000baseT
 
User avatar
newyork10023
just joined
Posts: 5
Joined: Thu Feb 25, 2021 8:48 pm

Re: CSS610-8G-2S+ link issue with SwOS Lite 2.14 and Apple Mac mini

Tue Jun 29, 2021 8:53 am

I am having issues connecting to the web interface on SwitchOS v2.13 from a Mac mini 8.1 (2018). The advanced menu hardware option for VLAN interfaces does not include an option to change from autonegotiate to a fixed speed- only the primary Ethernet interface does. This lack of changing speed is also true on a Solarflare 10G SFN5122F card in a Thunderbolt enclosure.

Oddly, I can connect to SwitchOS in a Windows 7 VM on the same host with the same VLAN interface.

I posted a more full description of my issue in another post, and don't want to be accused of cross-posting ( viewtopic.php?f=17&t=175913 ).

I would be interested in thoughts and solutions.
 
User avatar
newyork10023
just joined
Posts: 5
Joined: Thu Feb 25, 2021 8:48 pm

Re: CSS610-8G-2S+ link issue with SwOS Lite 2.14 and Apple Mac mini

Wed Jun 30, 2021 2:24 am

I will note that the Mac mini 8.1 (2018) has a Broadcom 57766-C0, should that prove significant.

Who is online

Users browsing this forum: No registered users and 7 guests