Community discussions

 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

v6.0beta1 released!

Fri Apr 13, 2012 4:47 pm

What's new in 6.0beta1 (2012-Apr-13 15:26):

*) updated drivers and kernel (to linux-2.6.38.2);
*) improved interface management (scales well for up to thousands of interfaces and more);
*) improved queue management (/queue simple and /queue tree) - easily handles tens
of thousands of queues;
*) improved overall router performance when simple queues are used -
at least double the performance of v5, even bigger improvements on multicore systems;
*) very small overhead for packets that miss simple queues,
but simple queues are present in the system;
*) pcq queue is NAT aware (just like "/queue simple" and "/ip traffic-flow";
*) in "/ip firewall mangle" can specify "new-priority=from-dscp-high-3-bits";
*) new default queue types: pcq-download-default and pcq-upload-default;
*) simple queues have separate priority setting for download/upload/total;
*) slave flag shows up for interfaces that are in bridge,bonding or switch group;
*) global-in, global-out, global-total parent in /queue tree is
replaced with global that is equivalent to global-total in v5;
*) simple queues happen in different place - at the very end of
postrouting and local-in chains;
*) simple queues target-addresses and interface parameters are joined into one
target parameter, now supports multiple interfaces match for one queue;
*) simple queues dst-address parameter is changed to dst and now supports
destination interface matching;
*) dns cache logs requests to topics "dns" and "packet";
http://www.mikrotik.com/download.html

v6.0beta1 includes many changes, we suggest it for testing environment until you are confident that it works with necessary configuration.
Please, submit all reports to support@mikrotik.com (include suppout.rif file).
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.0beta1 released!

Fri Apr 13, 2012 4:52 pm

"Black Friday Edition" - Let the fun begin!!
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
nikolas22t
just joined
Posts: 17
Joined: Thu Jan 12, 2012 1:03 pm

Re: v6.0beta1 released!

Fri Apr 13, 2012 4:57 pm

can you put limit on interface that has a master port set ? for example on port 2 that has master port 1 ... to have tx or rc limit?
 
mietus
Member Candidate
Member Candidate
Posts: 122
Joined: Mon Jan 30, 2006 11:14 pm
Location: Poland

Re: v6.0beta1 released!

Fri Apr 13, 2012 5:02 pm

i cant see full packages? am i blind or smth? ;-)
SQ improvements looooking very nice.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.0beta1 released!

Fri Apr 13, 2012 5:15 pm

can you put limit on interface that has a master port set ? for example on port 2 that has master port 1 ... to have tx or rc limit?

you have to choose - ether you allow traffic to bypass CPU completely (by switching it to other port) or you wanna work with packets in CPU - there is no middle way.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
gmsmstr
Trainer
Trainer
Posts: 940
Joined: Fri Jun 04, 2004 2:22 am
Location: St. Louis, MO
Contact:

Re: v6.0beta1 released!

Fri Apr 13, 2012 7:55 pm

Kinda interesting that they released this on Friday the 13th :)
Dennis Burgess, MCTCE, MTCNA, MCTCTE, MTCWE, MTCNIE, A+, N+, MCP, MTCSE Mikrotik Certified Consultant / Trainer
Need Mikrotik Support: http://www.linktechs.net -- Link Technologies, Inc.
-- Author of "Learn RouterOS: Second Edition"
 
gmsmstr
Trainer
Trainer
Posts: 940
Joined: Fri Jun 04, 2004 2:22 am
Location: St. Louis, MO
Contact:

Re: v6.0beta1 released!

Fri Apr 13, 2012 8:18 pm

First screen shot of production v6 :) who hooooo
You do not have the required permissions to view the files attached to this post.
Dennis Burgess, MCTCE, MTCNA, MCTCTE, MTCWE, MTCNIE, A+, N+, MCP, MTCSE Mikrotik Certified Consultant / Trainer
Need Mikrotik Support: http://www.linktechs.net -- Link Technologies, Inc.
-- Author of "Learn RouterOS: Second Edition"
 
dzany
just joined
Posts: 3
Joined: Sun Nov 20, 2011 11:21 pm

Re: v6.0beta1 released!

Fri Apr 13, 2012 10:29 pm

One-way throughput is at half of v5 router with nstreme enabled and 5GHz-40 MHz mode, and station in 5GHz-Turbo with nstreme cannot connect to bridge. Changing sides solves problem. Significally less cpu usage (about 60% difference)...
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 221
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v6.0beta1 released!

Sat Apr 14, 2012 2:02 am

Each time I issue "/ipv6 firewall filter add chain=input comment="Accept established" connection-state=established" makes my RB1100 crash and reboot.

I didn't have time to do further testing, so I don't know yet if it triggers the bug alone or if it's related to some other configuration around.
 
vik1988
Member Candidate
Member Candidate
Posts: 235
Joined: Sun Oct 25, 2009 2:18 pm
Location: India

Re: v6.0beta1 released!

Sat Apr 14, 2012 6:39 am

Finally...........

Thanks
Vikas Kumar Gupta
If you Like my post then add KARMA
skype- kumarvikas_gupta
 
yogii
Member Candidate
Member Candidate
Posts: 148
Joined: Wed Jun 16, 2010 5:38 am
Location: Batam, Indonesia

Re: v6.0beta1 released!

Sat Apr 14, 2012 7:48 am

still no "routing mark" in firewall ipv6. why? but i have upgraded my device to v6. :)
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.0beta1 released!

Sat Apr 14, 2012 8:36 am

paoloaga, you are right, thank you very much for the report! Connection-state matcher in IPv6 firewall is the reason for reboot, other IPv6 firewall rules work fine.
We will fix the particular problem in the next 6.0 version.
 
yogii
Member Candidate
Member Candidate
Posts: 148
Joined: Wed Jun 16, 2010 5:38 am
Location: Batam, Indonesia

Re: v6.0beta1 released!

Sat Apr 14, 2012 9:10 am

hello Mr. Sergejs, in /queue tree i just make 1 rule with parent=global and no other parameter, but status shows invalid / the rule is red color. why?
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.0beta1 released!

Sat Apr 14, 2012 9:20 am

yogii, I think more information is required, here is the output from demo2.mt.lv router,
[sergejs@demo2.mt.lv] /queue tree> add parent=global
[sergejs@demo2.mt.lv] /queue tree> print
[sergejs@demo2.mt.lv] /queue tree> print
Flags: X - disabled, I - invalid
0 name="queue1" parent=global packet-mark="" limit-at=0 priority=8
max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
Contact MikroTik support with attached support output file, where queue is shown as invalid.
 
yogii
Member Candidate
Member Candidate
Posts: 148
Joined: Wed Jun 16, 2010 5:38 am
Location: Batam, Indonesia

Re: v6.0beta1 released!

Sat Apr 14, 2012 9:35 am

Sir, it's not works on my RB433AH, here is the pic. i will send the supout.rif file to support. thank you for quick response. :)

Image
 
yogii
Member Candidate
Member Candidate
Posts: 148
Joined: Wed Jun 16, 2010 5:38 am
Location: Batam, Indonesia

Re: v6.0beta1 released!

Sat Apr 14, 2012 12:52 pm

hello Mr.Sergejs, is ROS V6 with a new kernel support memory more than 1.5 GB?
and how about my Ticket#2012041466000142, is it bug?

thanks for information.
 
User avatar
bambangs2komputer
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Tue Oct 04, 2011 4:22 pm
Location: Kota Malang-Indonesia
Contact:

Re: v6.0beta1 released!

Sat Apr 14, 2012 2:22 pm

Netinstall RB750 with Version 6.0beta1
I can't Configuration hotspot with winbox / telnet,why....? :shock:
 
MrYan
Member Candidate
Member Candidate
Posts: 109
Joined: Sat Feb 27, 2010 6:13 pm

Re: v6.0beta1 released!

Sat Apr 14, 2012 3:29 pm

still no "routing mark" in firewall ipv6. why? but i have upgraded my device to v6. :)
And if you put an interface into a VRF under /ip route vrf it doesn't display the IPv6 route associated with the interface (as per my post here - http://forum.mikrotik.com/viewtopic.php?f=2&t=60574):
/interface ethernet set ether5-slave-local master-port=none
/ip route vrf add disabled=yes interfaces=ether5-slave-local routing-mark=test-vrf
/ipv6 address add address=2001:db8:ffff:ffff::1/64 advertise=no interface=ether5-slave-local
IPv6 connected route is visible
[admin@MikroTik] /ip route vrf> /ipv6 route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, o - ospf, b - bgp, U - unreachable
 #      DST-ADDRESS              GATEWAY                  DISTANCE
 0 ADC  2001:db8:ffff:ffff::/64  ether5-slave-local              0
[admin@MikroTik] /ip route vrf> print
Flags: X - disabled, I - inactive
 0   routing-mark=test-vrf interfaces=ether5-slave-local
[admin@MikroTik] /ip route vrf> set numbers=0 disabled=no
Now it's gone
[admin@MikroTik] /ip route vrf> /ipv6 route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, o - ospf, b - bgp, U - unreachable
 #      DST-ADDRESS              GATEWAY                  DISTANCE
 
ropebih
Member Candidate
Member Candidate
Posts: 109
Joined: Tue May 22, 2007 5:35 pm

Re: v6.0beta1 released!

Sat Apr 14, 2012 4:41 pm

IGMP proxy is not working anymore in v6 beta1.
 
axiang
newbie
Posts: 36
Joined: Sun Apr 25, 2010 7:38 am

Re: v6.0beta1 released!

Mon Apr 16, 2012 3:29 am

queue
dynamic speed limit of radius hotspot or ppp can not be normal
我是中国人
 
User avatar
otgooneo
Trainer
Trainer
Posts: 570
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: v6.0beta1 released!

Mon Apr 16, 2012 9:44 am

That`s great. Hope V6.0Beta will solve my simple queue issues.
No bug fix on IPSEC with 0.0.0.0/0 tunnel? :( :( :(
----------------------------
Want to learn more and more...
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.0beta1 released!

Mon Apr 16, 2012 10:00 am

yogii,
RouterOS memory support is not changed at v6.x
Thank you for support output file for queue tree, we are checking your problem.

bambangs2komputer,
do you have "hotspot" package installed?
run /system package print and make sure HotSpot package is there.

axiang,
Thank you for the report on RADIUS queues, we are testing them!

otgooneo,
If there is any problem with IPSec at v6.x, write report to support@mikrotik.com, include as much details as possible and do not forget to attach support output file.

Update
,
bambangs2komputer we have found one issue, that HotSpot setup does not work at 6.0beta1 router. Thank you very much for your information. We are working on the fix.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1810
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.0beta1 released!

Mon Apr 16, 2012 12:30 pm

Each time I issue "/ipv6 firewall filter add chain=input comment="Accept established" connection-state=established" makes my RB1100 crash and reboot.
This one caused me some grief, my RB433UAH was upgraded from 5.14 to 5.0beta1 and as soon as it booted, before I could log in it would lock and reboot on watchdog, I netinstalled 6.0beta1 on to it and reconfigured from scratch, as soon as I added my first ipv6 filter, an accept established it rebooted again!

Thanks for acknowledging it so quickly Sergejs :)
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.0beta1 released!

Mon Apr 16, 2012 1:16 pm

axiang,
queue
dynamic speed limit of radius hotspot or ppp can not be normal
Yes, it is correct. Dynamic queue speed is not applied correctly. As the result you get such queue (at 6.0beta1),
 0  D name="<pppoe-1>" parent=none packet-marks="" priority=8/8 
      queue=default-small/default-small limit-at=1M/1M max-limit=1M/1M 
      burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0
that does not have proper matcher to assign the limits, in the next version (6.0beta2) it will be fixed to "target=pppoe-1".
Thank you very much for the report!
 
TKITFrank
Member Candidate
Member Candidate
Posts: 236
Joined: Tue Jul 07, 2009 2:55 pm
Location: Sweden

Re: v6.0beta1 released!

Mon Apr 16, 2012 6:42 pm

paoloaga, you are right, thank you very much for the report! Connection-state matcher in IPv6 firewall is the reason for reboot, other IPv6 firewall rules work fine.
We will fix the particular problem in the next 6.0 version.
When will a fix (new beta) be available? :)
MTCNA

"I don't believe UNIX is Utopia. It's just the best set of tools around."
 
User avatar
cbrown
Trainer
Trainer
Posts: 1839
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

Re: v6.0beta1 released!

Mon Apr 16, 2012 10:00 pm

wow, this 751 can move some traffic... :D

I think the queue tree reporting might be a little off?
You do not have the required permissions to view the files attached to this post.
C.Brown

cbrown[at]ravenrocknetworks.com
MTCNA - MTCRE - MTCWE - MTCTCE
MTCSE - TRAINER-0179

Next Training
https://www.cbrown.co/2019/04/08/mtcna-june2019-wv/
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8292
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.0beta1 released!

Tue Apr 17, 2012 1:27 pm

all_packages_x86/advanced-tools-6.0beta1.npk is missing in Torrent...

actually, it's missing even in .zip
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.0beta1 released!

Tue Apr 17, 2012 2:50 pm

Chupaka, thank you very much for the report.
Advanced package is back to zip and torrent files.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8292
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.0beta1 released!

Tue Apr 17, 2012 3:30 pm

sergejs, thanks. when new torrent will be available? :)
I think the queue tree reporting might be a little off?
yep, it is. my queue shows 2 Mbps with actual traffic ~16 Mbps (packet rate is correct, btw)
also, it's yellow with max-limit=30M - it means, real avg-rate is between 15M and 23M :)
You do not have the required permissions to view the files attached to this post.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.0beta1 released!

Wed Apr 18, 2012 3:49 pm

Chupaka, cbrown, thank you very much for the report about incorrect stats report at queue tree. We were able to repeat the problem, it will be fixed in the next beta version.

P.S. Torrent is fixed as well!
 
lavv17
Member Candidate
Member Candidate
Posts: 120
Joined: Sat Sep 01, 2007 9:01 am

Re: v6.0beta1 released!

Wed Apr 18, 2012 4:49 pm

will there be a x86_64 version? Probably it would provide a better performance.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8292
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.0beta1 released!

Wed Apr 18, 2012 6:34 pm

as soon as RBs will have 64-bit CPUs :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
otgooneo
Trainer
Trainer
Posts: 570
Joined: Tue Dec 01, 2009 3:24 am
Location: Mongolia
Contact:

Re: v6.0beta1 released!

Thu Apr 19, 2012 4:46 am

Yes. Finally 64bit CPU but not X86. It will be PPC :D
----------------------------
Want to learn more and more...
 
ffernandes
Member Candidate
Member Candidate
Posts: 146
Joined: Mon Jun 23, 2008 11:20 pm

Re: v6.0beta1 released!

Thu Apr 19, 2012 2:59 pm

i don't know if is just me but .. when i've upgraded an x86 to 6.b01.... simples queues appear without the ip's of client... it's not all queues...
anyone else noticed?!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8292
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.0beta1 released!

Thu Apr 19, 2012 3:03 pm

if you're talking about dynamic queues, then yes - it's known bug, will be fixed in the next version
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.0beta1 released!

Fri Apr 20, 2012 3:01 pm

Who is online

Users browsing this forum: No registered users and 1 guest