Community discussions

 
gotsprings
Forum Veteran
Forum Veteran
Topic Author
Posts: 700
Joined: Mon May 14, 2012 9:30 pm

6.44.1 Broke Stuff Need to Downgrade to 6.44

Fri Mar 15, 2019 1:21 am

Updated a CCR1009 and hAP AC2 from 6.44 to 6.44.1

Lots of connections are suddenly getting dropped by my DROP INVALID Forwarding rule.
Pings between the 2 routers on VPN show timeouts that never did before.

How can I downgrade and hAP AC when the Files Directory doesn't show enough space to put in the packages.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 619
Joined: Fri Nov 10, 2017 8:19 am

Re: 6.44.1 Broke Stuff Need to Downgrade to 6.44

Fri Mar 15, 2019 2:11 am

Files menu calculate space on flash memory (16MB)
However, root folder in file menu is actually ramdisk which has usually more than enough free space - as long as your RAM (128MB) is not completely full.

Therefore, as long as you load the downgrade files into root folder instead of "flash" folder, you shouldn't have any issue, even if it is larger than displayed "free space".


ps: about your drop rules - is it possible that these are just connections which were established before you reset your device and now, they are considered invalid because they are not in conntrack anymore? If that is the case, it will likely happen with any version after reboot.
 
gotsprings
Forum Veteran
Forum Veteran
Topic Author
Posts: 700
Joined: Mon May 14, 2012 9:30 pm

Re: 6.44.1 Broke Stuff Need to Downgrade to 6.44

Fri Mar 15, 2019 2:59 am

The device is not properly setting connections as new then established. So it flags the connection as invalid. Then the router drops it on the next pass at invalid or dumps it on my drop all.

Been using this firewall for a couple of years now. This is new behavior.
Last edited by gotsprings on Fri Mar 15, 2019 4:24 am, edited 1 time in total.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: 6.44.1 Broke Stuff Need to Downgrade to 6.44

Fri Mar 15, 2019 4:05 am

When I'm testing, I like to update the MikroTik, update the firmware, them reset it without any configuration. Then I add back in my own script. That seems to fix issues others seem to have. Try that, then see if you still have found a bug.
 
anav
Forum Guru
Forum Guru
Posts: 2629
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: 6.44.1 Broke Stuff Need to Downgrade to 6.44

Fri Mar 15, 2019 1:30 pm

Maybe MT firmware is getting tired of people like me that didnt understand why some people write config correctly but long windedly using new in all FW rules and is putting the hammer down on shortcuts LOL.
From now on I promise to put new on all FW rules that come after established related LOL.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)

Who is online

Users browsing this forum: No registered users and 4 guests