Community discussions

MikroTik App
 
kapi2454
newbie
Topic Author
Posts: 30
Joined: Mon Oct 09, 2017 2:54 pm

FTP with WININET.dll Problem (Visual Foxpro)

Wed Apr 21, 2021 6:22 pm

Hi to everybody, I have a very strange problem here.
One of my client buy a "new" software. The problem is that not work with mikrotik, and wor fine with tplink or linksys.
I make a zoom to the code, And notice that the software login fine into a FTP server, but has error when try to upload.
I ask for the ip/user/pass and test it on Filezilla, this work fine. (ip/user/pass work fine). And why not work the software??
The owner of the software tell me that they use WININET.dll in Visual Prox. For that reason i see that the problem is that library.
I try this software in my home with a mikrotik and have the same problem. If I change the router for a linksys work fine.
In my home I hace a simple connection pppoe and all for default. I run the default script in mikrotik.

Is this a Mikrotik bug?
 
kapi2454
newbie
Topic Author
Posts: 30
Joined: Mon Oct 09, 2017 2:54 pm

Re: FTP with WININET.dll Problem (Visual Foxpro)

Thu Apr 22, 2021 3:32 pm

Now I test in a RB3011UiAS-RM, and work fine. The problem are the 3x 951G-2HnD
Any idea?
 
R1CH
Forum Veteran
Forum Veteran
Posts: 959
Joined: Sun Oct 01, 2006 11:44 pm

Re: FTP with WININET.dll Problem (Visual Foxpro)

Thu Apr 22, 2021 4:29 pm

Probably conntrack FTP helper is turned off or behind dual NAT. Winnet FTP uses active mode (requires open port) by default.
 
Znevna
Member Candidate
Member Candidate
Posts: 257
Joined: Mon Sep 23, 2019 1:04 pm

Re: FTP with WININET.dll Problem (Visual Foxpro)

Thu Apr 22, 2021 5:29 pm

user bug.
MTKEK Certified by IRC
 
kapi2454
newbie
Topic Author
Posts: 30
Joined: Mon Oct 09, 2017 2:54 pm

Re: FTP with WININET.dll Problem (Visual Foxpro)

Thu Apr 22, 2021 11:03 pm

thank for answer!!
user bug.
by default work fine in RB3011UiAS-RM
by default not work on 3x 951G-2HnD
by defoult work fine in linksys or tplink
why is a user bug? I disable all default rules in "/ip firewall filter"

Probably conntrack FTP helper is turned off or behind dual NAT. Winnet FTP uses active mode (requires open port) by default.
Only one WAN (pppoe)
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
/ip firewall filter
Disable all rule, all work fine except this software and the FTP

/ip service
set telnet disabled=yes
set ftp disabled=yes port=21
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set winbox port=12312
set api-ssl disabled=yes

/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
set udplite disabled=yes
set dccp disabled=yes
set sctp disabled=yes
 
R1CH
Forum Veteran
Forum Veteran
Posts: 959
Joined: Sun Oct 01, 2006 11:44 pm

Re: FTP with WININET.dll Problem (Visual Foxpro)

Fri Apr 23, 2021 1:23 am

This is expected as you've disabled the conntrack helper.
/ip firewall service-port
set ftp disabled=yes
 
kapi2454
newbie
Topic Author
Posts: 30
Joined: Mon Oct 09, 2017 2:54 pm

Re: FTP with WININET.dll Problem (Visual Foxpro)

Fri Apr 23, 2021 8:12 pm

This is expected as you've disabled the conntrack helper.
/ip firewall service-port
set ftp disabled=yes
Yes i try it disable that. Now I downgrade to 6.40 and the problem keep :S
 
kapi2454
newbie
Topic Author
Posts: 30
Joined: Mon Oct 09, 2017 2:54 pm

Re: FTP with WININET.dll Problem (Visual Foxpro)

Mon Apr 26, 2021 11:29 pm

Some new idea?

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], Chouby, Kove and 152 guests