Community discussions

MikroTik App
 
Andrew162
just joined
Topic Author
Posts: 17
Joined: Thu Mar 25, 2021 9:40 am

Owncloud port 80

Fri May 07, 2021 8:18 am

Hello

Month ago i configured Owncloud on rasspberry pi 4 4GB
server its working but its work on port 80
when i make firewall port 80 to Owncloud i got problem opening the webpage .. what i think its normal.. becaouse the port is used
http://prntscr.com/12lymwq
My NAT
http://prntscr.com/12lynza
and filter Rules
http://prntscr.com/12lyoir
I wanna finish with "myddnsname.somethink" now its work on myddnsname.somethink/owncloud
But its also block opening webpages and other programs becaouse port 80 its bussy
i try to solve that 2 month ... i start to give up so i came here
Its there a way to make myddnsname.somethink/owncloud with no conflict with my 80 port ?
Own cloud i change to port 800
but i dont want myddnsname.somethink:800/owncloud
more short -> better
Mikrotik Audience , Mikrotik rb3011uias-rm, Mikrotik hAP-mini RB931-2nD
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24882
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Owncloud port 80

Fri May 07, 2021 8:21 am

I don't see any issues. Your screenshot shows you have opened the raspberry device webpage, the error is from raspberry webserver ("Plaeholder page"). So NAT is working fine.

Edit: if owncloud sever is on port 800, but you want to use URL without the port, you need a new NAT rule, with parameters:

protocol tcp
dst-port 80
to-port 800
to-address 192.168.88.88 (the address of owncloud in the LAN)
No answer to your question? How to write posts
 
Andrew162
just joined
Topic Author
Posts: 17
Joined: Thu Mar 25, 2021 9:40 am

Re: Owncloud port 80

Fri May 07, 2021 10:02 am

http://prntscr.com/12m3qyv
cant use port 80 when i do by your method
- for example make that screenshot - need disable for start working
Mikrotik Audience , Mikrotik rb3011uias-rm, Mikrotik hAP-mini RB931-2nD
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24882
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Owncloud port 80

Fri May 07, 2021 10:13 am

do not disable anything, make screenshot of full rule settings
No answer to your question? How to write posts
 
joegoldman
Long time Member
Long time Member
Posts: 618
Joined: Mon May 27, 2013 2:05 am

Re: Owncloud port 80

Fri May 07, 2021 10:41 am


I wanna finish with "myddnsname.somethink" now its work on myddnsname.somethink/owncloud
This is to do with your Raspberry Pi / OwnCloud installation. It is not recognizing the URL as a host-header to point to /var/www/owncloud (or wherever its located on your Pi), but likely being caught by the default host header of just /var/www which is why you must add /owncloud to the end.

This is a better question for the owncloud forums/user groups etc - as they'll be able to teach you how to configure owncloud and your web server to use a DNS name. The fact you can get it on myddnsname.somethink/owncloud means the networking side is good and is done.
 
Andrew162
just joined
Topic Author
Posts: 17
Joined: Thu Mar 25, 2021 9:40 am

Re: Owncloud port 80

Thu May 13, 2021 11:45 am

https://prnt.sc/12vfby3
https://prnt.sc/12vfcdd
https://prnt.sc/12vfd0w
https://prnt.sc/12vfdb3
When i make for example port 800 i can ofcors enter webpages normal
but my host is like xxxxx.ddns.net:800/owncloud
Mikrotik Audience , Mikrotik rb3011uias-rm, Mikrotik hAP-mini RB931-2nD
 
joegoldman
Long time Member
Long time Member
Posts: 618
Joined: Mon May 27, 2013 2:05 am

Re: Owncloud port 80

Mon May 17, 2021 3:33 am

https://prnt.sc/12vfby3
https://prnt.sc/12vfcdd
https://prnt.sc/12vfd0w
https://prnt.sc/12vfdb3
When i make for example port 800 i can ofcors enter webpages normal
but my host is like xxxxx.ddns.net:800/owncloud
Read my post above - this is a web server configuration error.

You say yourself the site is working, you just dont want to put '/owncloud' at the end correct? YOU want it to work directly on "https://xxxxx.ddns.net"? In which case you need to configure your webserver to point that host header to the correct directory.

if "xxxxx.ddns.net:800/owncloud" is working - then you know the mikrotik is doing its job.

If you are unsure how to do this or how to find the answer, you may need to pay someone to help.

Who is online

Users browsing this forum: pablozucoloto, rextended, sdchristensen, webor and 182 guests