Community discussions

MikroTik App
 
User avatar
jalapeno
just joined
Topic Author
Posts: 3
Joined: Tue Aug 13, 2019 11:13 pm

wApR and LTE (AT&T sim specifically) DENIED

Mon Mar 22, 2021 11:08 pm

We have been using AT&T sims for a while (over a year) though lately "SOME" of the wapRs does not REGISTER to AT&T when modem attempts to connect.

Tried "BEC" brand device with sims(yes 3 different ones with 3 different IPv4's) that would not REGISTER to AT&T and they all register on BEC device but not on Tik WAPR (Rile-LTE-US)
Model: RBwAPR-2ND&R11e-LTE-US
Tried some older firmwares/ROS's nothing seems to be consistent. The sim either Registers on AT&T or it doesn't when in the WAPR.
Registers EVERYTIME on BEC device so SIMs are all good.

Thought IMEI tied to IP might be a problem when AT&T issues IP that's what led to several SIMS being tried. Still once a sim is DENIED on AT&T when inserted into the WAPR it does not seem to want to REGISTER ever. Though this other brand "BEC" it boots right up and REGISTERS within 2-3 minutes of boot up. (everytime)

The strange thing is that the WAPR's are not ALL having trouble, only some. I thought I had it solved with 6.40.9 ROS but not yet Again the APN number is set correctly for AT&T for the modem to use.

WapR's are being setup as PASS-THROUGH to provide wireless backup so the IP needs to be received through the device on the edge(CPE device) In most cases an IAD(Adrtran).
I have taken the IAD out of the mix and hooked up a 2011 to the LTE direct and allowed it to dhcp-client via LTE. You can see the modem hit the AT&T nettwork attempt to connect (SEARCHING)
Then after a few minutes you get "DENIED"

Here is a sample output of one that "WORKED" fine
MT-WAP-R-ATT] /interface lte> info 0
pin-status: ok
registration-status: registered
functionality: full
manufacturer: MikroTik
model: R11e-LTE-US
revision: MPSS: R11eL_v16.02.183961 APSS: R11eL_v05.03.183961
CUSTAPP:
current-operator: AT&T
lac: 26
current-cellid: 51468553
enb-id: 201049
sector-id: 9
phy-cellid: 202
access-technology: Evolved 3G (LTE)
imei: xxxxxxxxxxxxx875
imsi: xxxxxxxxxxxxxxx831
uicc: xxxxxxxxxxxxxxx8312
earfcn: 900
rssi: -51dBm
rsrp: -90dBm
rsrq: -15dB
********************************

Trying to find out what is different about wAPR LTE now that is only "SOMETIMES" causing this issue. Like I say the example above worked out of the box. I loaded the latest stable ROS 6.48.1 and updated firmware and it just REGISTERED.

So after two weeks of factory-reset / no default config / trying other ROS versions and updating firmware to those and even downgrading firmware many many times I am asking if anyone else has any other ideas.

If the SIMs were the trouble then why do they like the other brand LTE everytime and not the Tik wAPR? And then why only SOME of them have this issue.

Better question: Might there be some other diags other than info 0 that might log connection to AT&T via modem and provide some useful input ? ( other than REGISTERED / DENIED)

Thank you for any help you can provide
 
User avatar
SiB
Forum Guru
Forum Guru
Posts: 1573
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: wApR and LTE (AT&T sim specifically) DENIED

Tue Mar 23, 2021 11:04 am

We face similar problem, AT&T start be more restrictive ? like he not be before...

We use Quectel who should work out-of-box, but recentry we see that units must change imei to recovery internet, symtops are like yours, you see connection without internet.
Out detect-internet-and-fix it scripting do stuff like re-enable interfaces etc, try disable Cell Lock, try all Bands, try all APNs 2x, try reboot, try all APNs 2x , try IMEI, repeat from start.
We have sometime notification that internet is back after change APN, common should be broadband but some units detect internet at phone sic!...
Praise MikroTik for scripting feature :)
PS. USA Quectel sell units cheaper then AliE and that way we have original products who have certification and should work.

About R11e-LTE-US, we not use it but at start point we know it's work.
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL | Buy me a caffe
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
 
User avatar
jalapeno
just joined
Topic Author
Posts: 3
Joined: Tue Aug 13, 2019 11:13 pm

Re: wApR and LTE (AT&T sim specifically) DENIED

Mon May 10, 2021 11:49 pm

Went back and revisited this again.

Looks like this setting got it registered

/interface lte
set [ find ] name=lte1 network-mode=3g

@DENIED-WapR-LTE] /interface lte> inf 0
pin-status: ok
registration-status: registered
functionality: full
manufacturer: MikroTik
model: R11e-LTE-US
revision: MPSS: R11eL_v16.02.183961 APSS: R11eL_v05.03.183961 CUSTAPP:
current-operator: AT&T
lac: 20939
current-cellid: 212281596
access-technology: 3G
imei: xx-xx3462
imsi: xxx-xx6829
uicc: xxx-xx-xxx8296
rssi: -69dBm
 
Cablenut9
Member Candidate
Member Candidate
Posts: 278
Joined: Fri Jan 08, 2021 5:30 am

Re: wApR and LTE (AT&T sim specifically) DENIED

Tue May 11, 2021 12:57 am

There's a way to change the IMEI if AT&T restricts it (and they do for a couple special plans) but since it's a bit of a secret, I'm not sure how I can share it because there are no PMs in this forum. I sometimes have my wAP denied if it can't find a good enough tower to connect to, so that could have been a factor as well.
Serial question asker
 
User avatar
jalapeno
just joined
Topic Author
Posts: 3
Joined: Tue Aug 13, 2019 11:13 pm

Re: wApR and LTE (AT&T sim specifically) DENIED

Wed May 12, 2021 10:33 pm

I may be interested in that IMEI change.

I can use

/interface lte
set [ find ] name=lte1 network-mode=3g

and it registers to AT&T but does NOT obtain the public IP associated with the IMEI/simm.

If I use
/interface lte
set [ find ] name=lte1 network-mode=lte

It will go through it's motions and then do "DENIED" instead of registered

If I do
/interface lte
set [ find ] name=lte1 network-mode=gsm

I get error stating that gsm is not supported (not that using GSM would be an option for voice anyway but just to try all three options)
 
TLoecher
just joined
Posts: 2
Joined: Fri Dec 07, 2012 10:32 pm
Location: Jackson, MS, USA

Re: wApR and LTE (AT&T sim specifically) DENIED

Fri May 21, 2021 9:39 pm

I may be interested in that IMEI change.
Jalapeno and Cablenut9,
I also would be interested in instructions for modifying the IMEI. Please PM me.
 
Cablenut9
Member Candidate
Member Candidate
Posts: 278
Joined: Fri Jan 08, 2021 5:30 am

Re: wApR and LTE (AT&T sim specifically) DENIED

Sun Jun 13, 2021 3:41 pm

You can't send PMs on this forum.
Serial question asker

Who is online

Users browsing this forum: Baidu [Spider], PhoeKhwar, RoyT and 212 guests