Community discussions

MikroTik App
 
User avatar
donsergio
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Wed Jan 31, 2018 8:35 pm
Location: Spain

Queue all except an IP range

Wed May 12, 2021 7:05 pm

Hi, I have a queue (to internet) on my local LAN and this queue affect to other computers in another subnet but I want to exclude some IP ranges, I tried the code below but doesn´t work... with my code the Mikrotik limit at 200Mbps (all devices are connected at 1G)... if disable the rule "add dst=172.16.126.0/23 name=Red-Local-sin-limite queue=Upload_1000M/Download_1000M target=192.168.0.0/24" limit at 20Mbps...

How the best way to queue all my local LAN except the traffic from the LAN (192.168.0.0/24) to another private LAN 172.16.126.0/23

Best regards!!

/queue type
add kind=pcq name=Download_10M pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=10M pcq-src-address6-mask=64
add kind=pcq name=Upload_1M pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=1M pcq-src-address6-mask=64
add kind=pcq name=Download_impagados pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=1k pcq-src-address6-mask=64
add kind=pcq name=Upload_impagados pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=1k pcq-src-address6-mask=64
add kind=sfq name=SUBIDA
add kind=sfq name=BAJADA
add kind=pcq name=Download_20M pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=20M pcq-src-address6-mask=64
add kind=pcq name=Upload_5M pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64
add kind=pcq name=Download_4M pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=4M pcq-src-address6-mask=64
add kind=pcq name=Download_2M pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=2M pcq-src-address6-mask=64
add kind=pcq name=Upload_2M pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=2M pcq-src-address6-mask=64
add kind=pcq name=Download_1k pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=1k pcq-src-address6-mask=64
add kind=pcq name=Upload_1k pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=1k pcq-src-address6-mask=64
add kind=pcq name=Download_5M pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64
add kind=pcq name=Download_50M pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=50M pcq-src-address6-mask=64
add kind=pcq name=Upload_3M pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=3M pcq-src-address6-mask=64
add kind=pcq name=Download_6M pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=6M pcq-src-address6-mask=64
add kind=pcq name=Download_10M-original pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=10M pcq-src-address6-mask=64
add kind=pcq name=Upload_3M-original pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=3M pcq-src-address6-mask=64
add kind=pcq name=Upload_20M pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=20M pcq-src-address6-mask=64
add kind=pcq name=Download_1000M pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=1G pcq-src-address6-mask=64
add kind=pcq name=Upload_1000M pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=1G pcq-src-address6-mask=64


add dst=172.16.126.0/23 name=Red-Local-sin-limite queue=Upload_1000M/Download_1000M target=192.168.0.0/24
add name=Red-Local queue=Upload_20M/Download_20M target=192.168.0.0/24
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 3895
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: Queue all except an IP range

Wed May 12, 2021 7:11 pm

Use packet mark on mangle instead of only target,
simply mark what do not go between two LANs
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
donsergio
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Wed Jan 31, 2018 8:35 pm
Location: Spain

Re: Queue all except an IP range

Wed May 12, 2021 7:24 pm

my config is a bit... complicated and I´m marking packets and connections for another reasons and I think could be difficult implement this... is another way?

Thanks!
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 3895
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: Queue all except an IP range

Wed May 12, 2021 7:57 pm

Not without rework all.
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
donsergio
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 59
Joined: Wed Jan 31, 2018 8:35 pm
Location: Spain

Re: Queue all except an IP range

Thu May 13, 2021 12:27 pm

Thanks, I´ll try marking packets.

Best regards!!

Who is online

Users browsing this forum: Bing [Bot], felixhuynh27, mikeeg02, moby and 219 guests