Community discussions

MikroTik App
 
User avatar
laxmimikrotik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Tue Apr 25, 2017 1:44 pm

why mikrotik showing the mac of different van users even that vlan does not exist in switch.??

Sat May 15, 2021 6:07 pm

why mikrotik showing the mac of different van users even that vlan does not exist in switch..CRS305-1G-4S+
Thanks.
-------------------------------
Every problem Has Solution .
ip-noc Team.
MTCNA ,MTCRE,
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1462
Joined: Mon Apr 08, 2019 1:16 am

Re: why mikrotik showing the mac of different van users even that vlan does not exist in switch.??

Sat May 15, 2021 6:27 pm

viewtopic.php?t=64597

May be related.
 
User avatar
laxmimikrotik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Tue Apr 25, 2017 1:44 pm

Re: why mikrotik showing the mac of different van users even that vlan does not exist in switch.??

Sat May 15, 2021 7:06 pm

not similar..


My issue is , if a switch does have only vlan 10 and then how it will learn the mac of vlan 11,12,13 , How can i filter it in the trunk port of mikrotik ?

Any way ??

Find the config below..!!


/interface bridge
add name=SW-10 pvid=10 vlan-filtering=yes

/interface vlan
add interface=SW-10 name=vlan-10 vlan-id=10
add interface=SW-10 name=VLAN-63 vlan-id=63
add interface=SW-10 name=Vlan-61 vlan-id=61

/interface bridge port
add bridge=SW-10 interface=sfp-sfpplus2 pvid=10
add bridge=SW-10 frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=sfp-sfpplus1 pvid=10
add bridge=SW-10 interface=sfp-sfpplus3
add bridge=SW-10 interface=sfp-sfpplus4

/interface bridge vlan
add bridge=SW-10 tagged=sfp-sfpplus1,sfp-sfpplus2 untagged=sfp-sfpplus3 vlan-ids=61
add bridge=SW-10 tagged=sfp-sfpplus1,sfp-sfpplus2 untagged=sfp-sfpplus4 vlan-ids=63
add bridge=SW-10 tagged=sfp-sfpplus1,sfp-sfpplus2,SW-10 vlan-ids=10
Thanks.
-------------------------------
Every problem Has Solution .
ip-noc Team.
MTCNA ,MTCRE,
 
tdw
Forum Veteran
Forum Veteran
Posts: 862
Joined: Sat May 05, 2018 11:55 am

Re: why mikrotik showing the mac of different van users even that vlan does not exist in switch.??

Sat May 15, 2021 9:09 pm

The bridge will learn MAC addresses from packets arriving for any VLAN unless you specify ingress-filtering=yes, with that configuration you only filter the sfp-sfpplus1 interface.

There are also a number of errors:
/interface vlan entries are only required if you wish to access a VLAN by services on the Mikroik itself, they are not required for traffic passing through the bridge.
You refer to some VLANs both tagged and untagged, or have differing untagged VLAN IDs under /interface bridge port and /interface bridge vlan, which can cause unexpected behaviour.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 7450
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: why mikrotik showing the mac of different van users even that vlan does not exist in switch.??

Sun May 16, 2021 3:48 pm

Suggest you read this reference.............
viewtopic.php?f=23&t=143620
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!

Who is online

Users browsing this forum: Baidu [Spider], BartoszP, Google [Bot] and 177 guests