Community discussions

MikroTik App
 
gaelgnr
just joined
Topic Author
Posts: 2
Joined: Thu Jun 10, 2021 12:17 pm

port forwarding problem

Thu Jun 10, 2021 12:39 pm

Hello,
We have a LHG LTE KIT router updated in 6.48.3 version and only on Windows PC connected to the router.
We are trying to implement port forwarding but it is not working.

After a factory reset, we add one static IP address rule to the DHCP server.

Our connected PC has now the desired IP address and we are able to join internet.

Then we add the NAT rule in the Firewall :

/ip firewall nat> add chain=dstnat dst-port=1234 action=dst-nat protocol=tcp to-address=192.168.88.205 to-port=1234

In order to test if the port is “open”, we use one PC on a different (internet) network and we try to join our port with the following website (https://www.yougetsignal.com/tools/open-ports/) and with the public IP address of the router.

On the PC connected to the LTE router we check with wireshark if a tcp packet with dest port = 1234 is coming and its never happen.
On the router interface in the “statistic” tab of the added NAT rule all counters are stuck to 0. The rule seems to be unused.

Maybe we miss one step, can anyone could help us ?

Thanks in advance
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 4756
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: port forwarding problem

Tue Jun 15, 2021 4:12 am

Those IP are public or private IP?
The SIM provider, provide one Static IP or one shared IP (Static or Private not matter at this point)
 
gaelgnr
just joined
Topic Author
Posts: 2
Joined: Thu Jun 10, 2021 12:17 pm

Re: port forwarding problem

Fri Jun 18, 2021 12:07 pm

hello,

My SIM card has a private and non-public IP address and that’s is the problem, I probably won’t find alone thank you ;)

So now I have another problem, I have to get around this CG-NAT, so I have to go through an SSH tunel or a VPN server, but I believe that I can not put an SSH tunnel on the router 4G LHG LTE KIT so it remains the solution of the VPN server but I don’t know how do this. Do you have an idea of the way to implement a VPN client on the router ?
 
User avatar
diego73
newbie
Posts: 26
Joined: Tue Feb 12, 2019 8:22 pm
Location: ciudad de buenos aires, argentina

Re: port forwarding problem

Fri Jun 18, 2021 4:21 pm

The Kit is a modem, I think you need a router conected to modem ethernet port to gain all function.

Who is online

Users browsing this forum: Google [Bot], PackElend, runbound, sindy, zafarsyal and 84 guests