Community discussions

MikroTik App
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

wireless bridge between two Mikrotiks for IPTV STB

Wed Jun 23, 2021 5:32 pm

I would kindly ask for some help in my effort to establish solid wireless bridge between two Mikrotik devices to serve for IPTV STB.
Situation:
ISP router (in bridge mode) >> UTP cable >> ether4 on Hap AC3 >> wifi los 4 meters >> Pwr-line AP as station bridge >> UTP cable >> STB

Hap ac3 relevant config:
/interface bridge
add name=bridgeTV

/interface wireless security-profiles
add authentication-types=wpa2-psk management-protection=allowed mode=dynamic-keys name=wpa2profil supplicant-identity=sv wpa2-pre-shared-key=keysecret

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors mode=ap-bridge security-profile=wpa2profil ssid=ssidforhome station-roaming=enabled
add disabled=no mac-address=XX:XX:XX:XX:XX:XX master-interface=wlan1 name=wlanvirtual security-profile=wpa2profil ssid=ssidvirtualapTV wps-mode=disabled

/interface bridge port
add bridge=bridgeTV interface=ether4
add bridge=bridgeTV interface=ether5
add bridge=bridgeTV interface=wlanvirtual

/ip address
add address=192.168.89.1/24 interface=wlanvirtual network=192.168.89.0
Pwr-line ap relevant config:
/interface bridge
add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no name=bridge

/interface wireless security-profiles
add authentication-types=wpa2-psk management-protection=allowed mode=dynamic-keys name=wpa2profil supplicant-identity=MikroTik wpa2-pre-shared-key=keysecret

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no mode=station-bridge security-profile=wpa2profil ssid=ssidvirtualapTV station-roaming=enabled

/interface bridge port
add bridge=bridge comment=defconf interface=ether1
add bridge=bridge comment=defconf interface=pwr-line1
add bridge=bridge comment=defconf interface=wlan1

/ip address
add address=192.168.89.2/24 interface=wlan1 network=192.168.89.0

/ip route
add distance=1 gateway=192.168.89.1 pref-src=192.168.89.2

The "bridge connection" is established and IPTV kinda works but very sluggish with inadequate bandwidth. If I connect STB directly to Hap ac3 (to ether5 also in bridge) than it works great but with this "wifi bridge" the connection is not good enough. The iptv requires only arround 3 Mbps but I can see that max that I achive is arround 1,5 Mbps. This setup is all in the same room, full LoS, no walls... For sure, there are neighbours and 2,4 is partially crowded, but with my phone or laptop I can easly get 40 Mbps with hap ac3 as AP. It seams that wifi is the bottleneck for this bridge but it is strange that this connection can not run with 3 Mbps, so this made me think that my config is not good. Please help in solving this puzzle.
Thank you
 
mkx
Forum Guru
Forum Guru
Posts: 6225
Joined: Thu Mar 03, 2016 10:23 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Wed Jun 23, 2021 11:11 pm

I'd replace the pwr-line AP with some at least half-decent AP in this setup ....
BR,
Metod
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Thu Jun 24, 2021 12:05 am

Thank you very much!
I was afraid that I will get such an answer, but from my pleasant experience with Mikrotik during the years, I was thinking that for such a non complex and straightforward task even the lowest level of MTik will be enough.
I will test it with another Mtik and report here.

Can you please take a look at my config. Is it ok? Do you have some suggestions?
Thank you
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Thu Jun 24, 2021 12:46 am

I was able to test the same config with RB951G-2HnD replacing the Pwr-line AP and the result is the same. Some wifi connection is established between two mikrotiks and there is connection with the STB but the picture is sluggish if it exist, sound is horrible and also constantly interupted, and plenty of comunication errors in STB showing on the TV
So the main problem is my config, not the pwr-line AP.
I would kindly ask for some revisions, suggestions... Tnx
Thank you
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Fri Jun 25, 2021 2:05 am

I am digging into this issue and have found very very interesting thing:
If I remove wlan interfaces from the bridges and perform BCP bridging (PPP tunnel bridging) over wifi link than it works without a problem. BCP bridging over PPTP performed following this guide: https://wiki.mikrotik.com/wiki/Manual:B ... _bridging)
So, in my presented config the workaround is to remove wlan interfaces from the bridge and create pptp tunel over established wifi link and put the pptp client and server interfaces into respective bridges on both sides. This works like a charm.
So, the thing works when additional pptp tunnel is established over wifi connection while it does not work only with the wifi connection without the pptp tunnel. Then it must be something not fully adequate with the wifi bridge if it requires additionl pptp tunnel to work properly.
I solved my practical need but not in the way it should be (or at least how I understand wifi bridging), but now I am even more interested what is happening that wifi connection alone is "not capable" to provide working bridge? Is IPTV multicast maybe too demanding? Or...?
I would really appreciate thoughts from the experts to help solve this puzzle. I think it would be beneficial for lot of us non experts.
Thank you
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 2:08 am

Hi to all. In an effort to dig dipper into this, for couple of weeks I was testing different setups in order to have reliable L2 wireless bridge.

Successful solutions that I have tested
1) BCP bridge within Pptp tunel over wifi link.
2) Bridge using WDS = station-wds mode

Unfortunately, the one that I intuitively stary with, the station-bridge mode doesn't seem to work and can not establish the Layer 2 wireless bridge able to work for my iptv stb. I tried for weeks but without sucess. The configuration is presented at the beginning of the thread.
I would like to understand what am I doing wrong or is it suppose to be like it is. As I am reading the manual the station-bridge mode should work in my setup and I can not figure it out why it doesn't. I would kindly ask for some expert help in my effort to understand why station-bridge does not work while BCP bridge over pptp and station-wds are both working? Under "work" I mean being able to provide L2 bridge for ethernet packets for iptv stb
Tnx in advance!
Thank you
 
tangent
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Thu Jul 01, 2021 3:15 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 2:31 am

solid wireless bridge...IPTV STB

Are you mad? You've got a real-time high data rate application there, and you're going to run it over a shared broadcast medium?

It might be made to work, but only by interposing Twitch/Zoom type technology: quasi-streaming (really store-and-forward buffering) with heavy recompression so the inevitable delays and blips you get with WiFi can be papered over by sufficient client-side data buffering.

What IPTV technology is this, exactly? If you can give me data rates, stream formats, A/V container types, and codec types, I might be able to suggest something concrete, rather than express rabid incredulity. 😉

I can see that max that I achive is arround 1,5 Mbps.

How are you coming to that conclusion?

I don't disbelieve you. I've seen such things myself. I just want to know what your test method was, how you controlled the bandwidths, and so forth.

I can easly get 40 Mbps with hap ac3 as AP.

The thing is, that's not continuous. If it drops out for 1/10 of a second, the human isn't going to notice, but a true streaming IPTV system will. At 30 fps, each and every frame has to arrive in 1/30 of a second, no more, no less. A 1/10 second blip means you just lost 3 frames, and with a modern high-efficiency codec, you might then lose the remaining 297 frames in that GOP, so you lose the whole signal for 5 seconds on average.

This is why Internet video systems don't actually do "streaming" in the old sense. They can't tolerate common delays we never would have put up with back when IPTV was being designed, with the assumption that it would be multicast over switched Ethernet connections.
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 3:15 am

I like to believe that I am not mad, tnx for asking! ;-)
Maybe I was not fully clear in my description and that makes you think that I am requiring some "special" things... I will try to simplify it as simple as possible.

I am trying to establish relible wireless L2 bridge inside the apartment (distance couple of meters) that can transmit ethernet packets for the Iptv STB. It is an iptv service from the isp. It requires arround 3 Mbps. Regularly following the isp guidance the STB should be directly connected via ethernet cable to the ISP router. I am trying to achive that it can go wirelessly inside the apartment, so I need the bridge between stb and the isp router. I am doing this with two mikrotiks in the middle. As I said, I can achive this with BCP bridge over pptp as well ae station-wds mode but can not achive it with station-bridge mode. I am not 100% sure if station-bridge should work, but from what I am understanding it should, so I am trying to figure it out what is wrong with my config or...? My main concern is why I can not achive this bridge using station-bridge mode?

Regarding the technology used by the ISP, I am really not sure what it is. Maybe somebody will know better here. This is the service called MaxTV and the isp is Croatian telekom.
Thank you
 
mkx
Forum Guru
Forum Guru
Posts: 6225
Joined: Thu Mar 03, 2016 10:23 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 10:49 am

There is no such thing as "reliable wireless" in a shared spectrum (such as WiFi). There will always be possibility for some interferer to kill the performance of your wireless link.

There are two problems when sending broadcasts over wireless:
  1. wireless clients go to sleep. It's a big problem with smart phones which put their WiFi interfaces to sleep very aggressively to enhance the battery life. I don't know how aggressively does mikrotik wifi force to sleep when in client mode.
    While client radios are in sleep mode, they obviously don't listen. With unicast packets that's not a huge problem, those are buffered by AP and delivered with some delay (delay jitter is quite high when trying to ping wireless client from AP's side but not the other way around). With broadcast packets that's a show stopper because packets only get transmitted once and if listener misses them, they are lost (for that particular listener). As @tangent already described, if one packet of IPTV broadcast stream is lost, the effect can be anything between occasional bleep (either audio or video depending on which particular payload was included in lost packet) and 5-second pause of video (if the lost packet carried vital synchronisation information).
  2. multicast packets are transmitted at lowest allowed datarate (in MT it's called basic rate) so that even clients in worst radio conditions are able to receive it. Depending on AP wireless mode set that can be as low as 1Mbps. If multicast rate exceeds minimum rate of AP, some of stream will be dropped. Mind that the rate mentioned is what can be achievable without any other traffic in any direction. In reality, there will be some other traffic, perhaps some interference from other APs in the vicinity, so you really want to change the setting of basic-rates-a/g to at least 5-times the multicast stream rate to be on safe side. And you definitely want to disable the "b" wireless mode. Don't forget to set rate-set=configured.


And there's property multicast-helper which, when set to full, transforms multicast packets into unicast ones and that helps to deliver packets to individual clients more reliably. Which might solve both problems described above. Might solve your problems without changing other things, but you have to configure client AP to station-bridge (probably won't work in station mode).

Note that all of the above mentioned settings should be configured on AP ... client simply follows AP's commands.
BR,
Metod
 
tangent
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Thu Jul 01, 2021 3:15 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 11:33 am

I will try to simplify it as simple as possible.

You've oversimplified the matter to the point that I can't give much practical help, only general advice. I'm not afraid of deep technical details. Lay it on me.

isp guidance the STB should be directly connected via ethernet cable to the ISP router.

That's because your ISP knows what I do: that traditional real-time streaming style IPTV over WiFi is madness. Corporately, they certainly have longer and more bitter experience backing that judgement up, too.

Regarding the technology used by the ISP, I am really not sure what it is.

Capture a few seconds of one of these streams and put it up on a public server somewhere. I, or another with my skills, can then tell you more.

Try to capture a channel change, if you can.

5-second pause of video (if the lost packet carried vital synchronisation information).

With modern video codecs, it isn't a matter of "if," for most practical purposes.

If we assume the IPTV source is transmitting some kind of HD quality video and doing so in just 3 Mbps, the GOP size is likely large. 300 frames is a common number with modern codecs for Internet video.

(Thus the "297" number from my prior post: 3 frames lost from a 300-frame GOP. That's 10 seconds for 30 fps video, giving my average of 5 seconds of video loss for a single random packet loss.)

The linked diagram says it's a "typical" structure, but by that they mean the IPBB structure, not the 6-frame GOP size depicted. Even with MPEG-2 streams — pre-DVD technology — the GOP size is rarely less than half a second, so 12 frames for 24/25 fps video and 15 frames for 30 fps video. That half-second heuristic is based on testing during the design of MPEG-1 in the late 1980s that showed that longer GOPs were inadvisable due to error build-up: inter-frame video codecs need periodic resetting with I-frames to produce high perceptual quality.

A large part of the improvement you get with H.264, VP9, and so forth is reduced intra-GOP error build-up, permitting longer GOPs while maintaining equal perceptible video quality, reducing the frequency of those expensive I-frames. 300-frame GOPs are common for Internet streams.

multicast packets are transmitted at lowest allowed datarate (in MT it's called basic rate)

Ah, that's interesting to know. I've come across other WiFi routers with that feature, but I use MT only for wired, so I wasn't aware that they did this as well.

The reason it's done is because they want to allow low data rate protocols like mDNS through but to prevent things like IPTV from clogging the precious shared broadcast medium that is WiFi.

The people designing these WiFi routers also know that IPTV over WiFi is madness.

To those of you still not convinced: have you never experienced poor VoIP quality over WiFI? That has the same real-time streaming characteristics as IPTV but at much lower bandwidths and with much less inter-packet interdependence. If you can't get rock-solid reliable VoIP over WiFi, why would you expect to get it with IPTV?

And if you're wondering why YouTube, NetFlix, and so on work, they aren't "IPTV" at all. They're video-on-demand systems, designed for large PC-class video buffers. As for Twitch, Zoom and such, they're store-and-forward systems, not at all the same thing as the real-time streaming nature of most IPTV systems; as with VoD, they do unicast video with huge buffers, relative to what IPTV systems typically run. IPTV was designed in a world where the half-second MPEG-2 GOPs constituted a large amount of memory, so they don't have the multi-second buffers of a Roku or similar type box.
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 2:02 pm

If you can't get rock-solid reliable VoIP over WiFi, why would you expect to get it with IPTV?
The interesting fact for me is that iptv over wifi really works for me but only if I use BCP bridge over pptp or station-wds mode. If I use station-bridge as described here it doesn't work as I expected. So this means that there is no wifi link quality problem per se, but some other problem. BCP bridge over pptp as well as station-wds mode work without problem, quality is excellent in my setup. I am wondering why station-bridge mode does not provide same experience?
Thank you
 
tangent
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Thu Jul 01, 2021 3:15 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 2:30 pm

iptv over wifi really works for me but only if I use BCP bridge over pptp or station-wds mode.

These are point-to-point links, so the router's multicast traffic rules don't apply. They're unicast links, not subject to the "basic-rates" settings mkx brought up.

So sure, you can remove the multicast data rate limitations, and it might work...until you move one router beyond LoS, or the range increases to more than a few meters, or you get more clients on the network, or someone decides to browse Reddit on the same WiFi channel, or one of those ugly bags of mostly water walk in between the routers, or...

But hey, what do I know, I've only been doing IPTV for decades now...
 
mkx
Forum Guru
Forum Guru
Posts: 6225
Joined: Thu Mar 03, 2016 10:23 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 2:33 pm

... iptv over wifi really works for me but only if I use BCP bridge over pptp or station-wds mode. If I use station-bridge as described here it doesn't work as I expected.

That's because from wireless point of view, BCP is unicast (between AP and client) and is thus "bufferable". Even if it introduces some delay jitter it still helps with its payload (multicasts) ... typical IPTV set-top boxes do some buffering (e.g. 10 seconds, some even do unicast retrasmissions and for that buffering is a requirement). WDS might convert multicast packets to unicast packets or perform some similar magic.

You really don't seem to like answers which are not in the line of your thinking, do you?

If you think about it, even Ethernet over Powerline will likely work much better for IPTV than wifi. Much less chance of interference and, with some luck, running over same phase, same fuse, it might even over-perform the wireless solution.
BR,
Metod
 
mkx
Forum Guru
Forum Guru
Posts: 6225
Joined: Thu Mar 03, 2016 10:23 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 2:45 pm

The reason it's done is because they want to allow low data rate protocols like mDNS through but to prevent things like IPTV from clogging the precious shared broadcast medium that is WiFi.

Not really, this constraint is not payload-specific, it's the same for all multicast and broadcast. And exactly for the reason I already wrote: these packets must be delivered to all clients. Since they are broadcast (there's no such thing as multicast in L2 - ethernet/wireless, L3 - IP - multicast is mapped to L2 broadcast), and link adaptation (modifying modulaton, MIMO rank, Tx power, ...) is not an option (because it's the same for just every client and for clients sleeping in recent moments radio link conditions are not known). Therefore all broadcasts and multicasts are transmitted using slowest possible speed. If one changes that (e.g. allow only g/n on 2.4GHz, rise minimum speed), then also range of AP gets changed (it's smaller).

That's simply physics.
BR,
Metod
 
tangent
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Thu Jul 01, 2021 3:15 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 3:08 pm

there's no such thing as multicast in L2

Although IGMP snooping is technically L3, it affects L2. If you're doing without the IGMP querier, it's passive, so it's not adding any L3 traffic, only pruning L2 traffic.

The problem with WiFi is that everything is L2 broadcast, so every station on the network is forced to wake up and deal with L3 broadcast and multicast packets.

EDIT: Without IGMP snooping, MRP or GARP, multicast does indeed turn into broadcast at L2 but even then, it's technically incorrect that there is no such things as multicast at the L2 layer. It just can't be controlled by a dumb switch or by a smart one with these traffic control mechanisms turned off.

this constraint is not payload-specific

I realize that, but mDNS and such fit underneath the bandwidth limitation while IPTV does not. When the end user of the equipment finds, as OP has, that high-bandwidth multicast streams don't work, they generally just stop trying to do that over WiFi, which has the same effect as payload blocking. It doesn't prevent someone from jamming the channel up inadvertently, of course.
Last edited by tangent on Tue Jul 13, 2021 3:16 pm, edited 1 time in total.
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 3:11 pm

You really don't seem to like answers which are not in the line of your thinking, do you?
Fair point mkx! :-) It's probably a part of the human nature, but lifelong learning is a must!
Mkx thank you very very much on your knowledge sharing! It mighy be the problem that my networking knowledge is well under your level of expertise, so I do not understand everything fully. But it seams that I get here excellent answers that provide explanations why my initial expectations were maybe too much. Tnx
But hey, what do I know, I've only been doing IPTV for decades now...
Hey tangent! Thank you very very much on your valuable comments!! I am really an amateur, so honestly I even do not understand everything fully what you are talking about. I get the idea, the wifi is quite problematic when it comes to multicast. Thank you for that.

EDIT: For other readers that are not iptv gurus, is it fair to sum up that for iptv if wifi is not the only solution try to avoid it and if you really need wifi link for your iptv setup that it is a good practice to establishe a tunnel over wifi and use BCP bridging inside?
@mkx & @tangent what do you think?
Thank you
 
tangent
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Thu Jul 01, 2021 3:15 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 4:47 pm

for iptv if wifi is not the only solution try to avoid it

Very much "yes."

if you really need wifi link for your iptv setup that it is a good practice to establishe a tunnel over wifi and use BCP bridging inside?

I'd do it another way than tunneling, but without those details I've asked for, I can't tell you which of several available options to use. I've tried giving you a brain-dump before, and you ignored most of it, so at this point, you've got to give details if you want answers.

Let's start with that packet capture of an IPTV stream in progress, including a channel change event. I said a few seconds, but it probably should be something like 15 seconds to be sure all the necessary details are captured in the stream.
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 7:35 pm

I've tried giving you a brain-dump before, and you ignored most of it, so at this point, you've got to give details if you want answers.
Let's start with that packet capture of an IPTV stream in progress, including a channel change event. I said a few seconds, but it probably should be something like 15 seconds to be sure all the necessary details are captured in the stream.
Yes for sure I will gladly provide more. I really appreciate help, knowhow, experience and readiness to spend time. I have captured aprox 20 sec of packets. How do you want me to send you?
Thank you
 
tangent
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Thu Jul 01, 2021 3:15 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Tue Jul 13, 2021 8:54 pm

How do you want me to send you?

Put it up on a public server somewhere. Dropbox, GDrive, OneDrive, whatever.
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Thu Jul 15, 2021 2:56 am

Dear @tangent please find the captured packets
https://we.tl/t-UdWyYxpwkW

Please accept appologies for not attaching it sooner but I have tested a lot and now sending the packets that I think are most problematic.
There is a channel change as well as switch to watching "old" programme - couple of hours ago from the real time. The service provides an opportunity on some channels to watch everything in the last 2 days. I have noticed that this especially makes quality issues so I have also included this in the file. Please let me know what you qre thinking and tnx very much once more.
Thank you
 
tangent
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Thu Jul 01, 2021 3:15 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Thu Jul 15, 2021 3:32 am

It's an encrypted (i.e. DRM) MPEG-TS stream containing 720p H.264 video and MPEG-1 layer 2 audio. (So-called "MP2".)

If it was unencrypted, you'd have a bunch of options to capture and restream it in a way that'd transit a wireless network with a reasonable chance of success, but as is, you do indeed have no choice other than to send the raw packets across to the decoder/STB and hope for the best.

Sorry, but that's DRM for you.

Details:

Input #0, mpegts, from 'x.ts':
  Duration: 00:00:38.96, start: 19251.254211, bitrate: 1373 kb/s
  Program 1 
    Metadata:
      service_name    : RTL2 720p H264
      service_provider: T - HT
  Stream #0:0[0x121]: Video: h264 (Main) ([27][0][0][0] / 0x001B), yuv420p(tv, progressive), 1280x720 [SAR 1:1 DAR 16:9], 50 fps, 50 tbr, 90k tbn, 100 tbc
  Stream #0:1[0x221]: Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, fltp, 128 kb/s
  Stream #0:2[0x80](eng): Subtitle: dvb_teletext ([6][0][0][0] / 0x0006)
 
mada3k
Member
Member
Posts: 429
Joined: Mon Jul 13, 2015 10:53 am
Location: Sweden

Re: wireless bridge between two Mikrotiks for IPTV STB

Fri Jul 16, 2021 11:19 am

With good wiring and on same phase Powerline works very well for Multicast IPTV. There are actually some TV-vendors that provides this bundled sometimes.

Otherwise I would guess that a VPLS over a PtP WiFi would be the last choise.
CCR/CRS/hEX/wAP • Ansible • NetXMS
 
User avatar
webor
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sat Dec 20, 2008 2:33 am
Location: Europe

Re: wireless bridge between two Mikrotiks for IPTV STB

Fri Jul 16, 2021 11:43 pm

Sorry, but that's DRM for you.
Thank you very very much @tangent for spending your time on this. I have learned a lot in this thread. Tnx. After multuple tests comparing BCP bridging over PPTP tunnel Vs. WDS bridge I would say that BCP brisging brings better for me. I would like to ask you if you have some general suggestions for me what else could I try in order to improve quality. I have significant problems if I watch historical video on channels (as I said previously, some channels enable to watch everything in the last 2 days) and not the live stream. With live stream problems are minor but with this "old" streams, let's call the video-on-demand, the problem is bigger.
Otherwise I would guess that a VPLS over a PtP WiFi would be the last choise.
Thank you very much for your suggestion. Can you please say a little bit more about that?
Thank you
 
tangent
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Thu Jul 01, 2021 3:15 pm

Re: wireless bridge between two Mikrotiks for IPTV STB

Sat Jul 17, 2021 12:06 am

Thank you very very much @tangent for spending your time on this.

Sure. I just wish we had a better outcome.

I can't even tell you the GOP structure of the stream with that DRM in the way. Grrrr.

...improve quality. I have significant problems if I watch historical video on channels

IPTV is a digital signal: the bits get from one end to the other, or they do not. There is no in-between state. With a real-time UDP service like this, there isn't even an option for retransmission on checksum error. You'd have a completely trashed signal if the problem was frequent packet corruption. Any degradation is on the source side, not on your end. You're probably running it to an HDMI monitor, so it stays digital until it's turned into photons by the display.

It's difficult to say with the DRM in the way, but if we take your 1.5 to 3.0 Mbit/sec numbers and my discovery that they're using MP2 (!) audio and H.264, that explains a lot. Real-time video encoders generally can't get the stream down to the same bit rates as a high-quality offline encoder, and their choice to use MP2 rather than something more efficient like AAC eats into that bit rate budget. In brief, they're doing the best they can given their choices.

Who is online

Users browsing this forum: anav, AndyGs, foxco, Renfrew and 103 guests