Community discussions

MikroTik App
 
noib
Member Candidate
Member Candidate
Topic Author
Posts: 291
Joined: Fri Jan 25, 2013 6:04 pm
Location: France
Contact:

Advice on bridged VLANs

Wed Sep 23, 2015 12:25 pm

Hello

I want to pass several VLANS from ether1 to ether5, for example. As usual with mikrotik, there are several ways to do that, so i was wondering which one of the following was your preferred, and why?

Way 1: bridge physical interfaces and put VLANs on bridge
/interface bridge
add name=bridge_global protocol-mode=none
/interface bridge port
add bridge=bridge_global interface=ether1
add bridge=bridge_global interface=ether5
/interface vlan
add interface=bridge_global l2mtu=1594 name=vlan_100 use-service-tag=yes vlan-id=100
/interface bridge settings
set allow-fast-path=no
Way 2: create VLAN attached to each physical interface and bridge VLANS
/interface vlan
add interface=ether1 l2mtu=1594 name=vlan_100_eth1 use-service-tag=no vlan-id=100
add interface=ether5 l2mtu=1594 name=vlan_100_eth5 use-service-tag=yes vlan-id=100
/interface bridge
add name=bridge_vlan_100 protocol-mode=none
/interface bridge port
add bridge=bridge_vlan_100 interface=vlan_100_eth1
add bridge=bridge_vlan_100 interface=vlan_100_eth5
/interface bridge settings
set allow-fast-path=no
Way 3 (not possible in my case): use the switch chip to bridge physical interfaces and create VLANs on the master interface.



Apart from that, i have problems with RB750's connected to each other that way, they just hang several times a day (ping possible but impossible to connect to them via winbox/telnet/mac-telnet).
Are there best practices when mixing bridges, vlans (with use-service-tag on or off) and the fact that all that stuff is connected together via a 3rd party network, using VLAN too?

Thanks
 
MrYan
Member Candidate
Member Candidate
Posts: 160
Joined: Sat Feb 27, 2010 6:13 pm

Re: Advice on bridged VLANs

Wed Sep 23, 2015 3:48 pm

I'd say it depends. If you want to bridge all VLANs from ether1 to ether5 then I'd put both interfaces into the bridge. If you want to be more selective than I'd add VLAN interfaces per port and create a bridge per VLAN.

Also, unless you want to assign an IP address to the VLAN, I'd not bother creating the VLAN interfaces at all for the all bridged option.


Matt.

Who is online

Users browsing this forum: Amazon [Bot] and 161 guests