Community discussions

 
BroganOs
newbie
Topic Author
Posts: 44
Joined: Thu Aug 27, 2015 6:32 pm

DNS no resolving on failover wan

Mon Oct 19, 2015 7:34 pm

I have two Wan connections from different suppliers (different IP's, subnets and dns records), I'm using two different routes to set up a failover which is working well except that when I switch to Wan2 web pages dont load, we get DNS failure to resolve errors. I can ping ip addresses sucessfully though.

I'm guessing it's because the DNS records of both Wan's are different. any advise?
 
User avatar
rmmccann
Member Candidate
Member Candidate
Posts: 182
Joined: Tue Sep 25, 2012 11:15 pm
Location: USA

Re: DNS no resolving on failover wan

Mon Oct 19, 2015 9:53 pm

I'm assuming you mean DNS lookups/queries are failing over WAN2? If so, are you using ISP DNS or using something like Google, OpenDNS, UltraDNS, etc?

If using ISP DNS, keep in mind some ISP's block resolution from IPs outside their network. If you are trying to resolve DNS from ISP2 using DNS servers that belong to ISP1, it probably won't work.
A common mistake that people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools. --Douglas Adams
 
BroganOs
newbie
Topic Author
Posts: 44
Joined: Thu Aug 27, 2015 6:32 pm

Re: DNS not resolving on failover wan

Tue Oct 20, 2015 12:21 pm

Sorry yes I meant the DNS lookup's are failing. Do you know if there is a work around for this?
 
User avatar
rmmccann
Member Candidate
Member Candidate
Posts: 182
Joined: Tue Sep 25, 2012 11:15 pm
Location: USA

Re: DNS no resolving on failover wan

Tue Oct 20, 2015 4:26 pm

Your workaround would be to use public DNS servers instead of your ISP's DNS servers. It's unlikely your ISP will allow queries from outside of their IP space.

A lot of people will recommend either OpenDNS (208.67.222.222 and 208.67.220.220) or Google DNS (8.8.8.8 and 8.8.4.4). There are countless others.
A common mistake that people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools. --Douglas Adams
 
BroganOs
newbie
Topic Author
Posts: 44
Joined: Thu Aug 27, 2015 6:32 pm

Re: DNS no resolving on failover wan

Tue Oct 20, 2015 4:30 pm

Thanks, I was just about to reply as I saw your message. I hadnt created a src-nat rule in the firewall for wan2. Once I created that it worked perfectly.
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: DNS no resolving on failover wan

Thu Oct 22, 2015 5:23 am

On sites with multiple WAN interfaces and different ISP (therefore different DNS) I add a specific route for each DNS so it always uses the correct ISP.

In respect to failover, a script to change the DNS may be useful approach.

Using 8.8.8.8 or 8.8.4.4 does work but some CDN's do not like it and get content from distant sites rather than local (faster ones) e.g Microsft Update, Youtube etc
MTCNA, MTCWE, MTCRE, MTCTCE, MTCSE, MTCINE, Trainer
___________________
Mikrotik Distributor - New Zealand
http://www.campbell.co.nz

Who is online

Users browsing this forum: Google [Bot] and 11 guests