Community discussions

 
kiwibrew
just joined
Topic Author
Posts: 9
Joined: Tue Oct 04, 2011 3:08 am

RB532 + routeros mipsle 6.33 = fail

Sun Nov 15, 2015 1:23 pm

I've bricked several RB532s and a couple of 532As with the latest 6.33 - both with netinstall and by upgrading from 6.7.

Going to try downgrading them all to 5.26 using netinstall now.

What's the highest version of routeros 6.x that's known to work on RB532 (32mb RAM) with R52 wireless card?
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Sun Nov 15, 2015 1:59 pm

6.32.3 without any problems in productive environment. 6.33 not tested on those types by me yet.
I am always installing only individual selected packages that are necessary.
 
kiwibrew
just joined
Topic Author
Posts: 9
Joined: Tue Oct 04, 2011 3:08 am

Re: RB532 + routeros mipsle 6.33 = fail

Sun Nov 15, 2015 10:33 pm

Thanks @jarda - netinstall of 6.32.3 brought those dead routers back.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Mon Nov 16, 2015 1:02 am

Never use the newest version. Do your own tests before updating the productive devices. Congratulations that you managed to get them working back again.
 
jackdaws
just joined
Posts: 2
Joined: Sun Jul 19, 2015 1:11 am

Re: RB532 + routeros mipsle 6.33 = fail

Fri Dec 04, 2015 1:07 pm

i have tested and worked ok for me with rb532 this version all_packages-mipsle-6.33.2 ...
 
jackdaws
just joined
Posts: 2
Joined: Sun Jul 19, 2015 1:11 am

Re: RB532 + routeros mipsle 6.33 = fail

Fri Dec 04, 2015 2:53 pm

i have installed 6.32.2 and work ok
 
ALDISBEHMANIS
just joined
Posts: 16
Joined: Mon Aug 18, 2008 3:32 pm

Re: RB532 + routeros mipsle 6.33 = fail

Thu Dec 17, 2015 2:38 pm

I confirm!
Same problem here.
Updated 6.33 ->6.33.3 = CRASH! Does not come back from reboot. Had to power down and power UP.
Did clean reinstall from 5.21->6.32.x->6.33.3
Making export compact file=xxx complains about upnp config backup.
Probably problem is with this stuff somewhere.
upnp is one of fixes for 6.33.3
 
becs
MikroTik Support
MikroTik Support
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

Re: RB532 + routeros mipsle 6.33 = fail

Thu Dec 17, 2015 2:55 pm

MIkroTik support is working on this problem, we recommend to keep using v6.32.3 (bugfix) until it is fixed in v6.33.x
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2292
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RB532 + routeros mipsle 6.33 = fail

Thu Dec 17, 2015 5:01 pm

I can confirm this bug. RB532 dont work with 6.33.3. After downgrade to 6.32.2 works well
LAN, FTTx, Wireless. ISP operator
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2292
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RB532 + routeros mipsle 6.33 = fail

Wed Dec 30, 2015 10:05 am

MIkroTik support is working on this problem, we recommend to keep using v6.32.3 (bugfix) until it is fixed in v6.33.x
It is more then 14days old bug.
And 6.33.3 is for mipsle still on download page without any warning !! Why you don´t write warning for MIPSLE?
When released 6.33.4 with fix?

Thanks
LAN, FTTx, Wireless. ISP operator
 
User avatar
spippan
Member Candidate
Member Candidate
Posts: 100
Joined: Wed Nov 12, 2014 1:00 pm

Re: RB532 + routeros mipsle 6.33 = fail

Thu Jan 14, 2016 1:39 pm

I confirm!
Same problem here.
Updated 6.33 ->6.33.3 = CRASH! Does not come back from reboot. Had to power down and power UP.
Did clean reinstall from 5.21->6.32.x->6.33.3
Making export compact file=xxx complains about upnp config backup.
Probably problem is with this stuff somewhere.
upnp is one of fixes for 6.33.3
did or do you use UPnP anyway; e.g. do you have it activated?
---
raiffeisen data center infrastructure and security
...stay curious
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1743
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: RB532 + routeros mipsle 6.33 = fail

Thu Jan 14, 2016 3:56 pm

how many years ago do you have that rb532??
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Thu Jan 14, 2016 4:27 pm

What's wrong with age of 532s? They are great devices regardless of their age.
 
User avatar
spippan
Member Candidate
Member Candidate
Posts: 100
Joined: Wed Nov 12, 2014 1:00 pm

Re:

Fri Jan 15, 2016 10:21 am

What's wrong with age of 532s? They are great devices regardless of their age.
yep as long as it is working ;-)

i don't know how mikrotik handles backward compatibility of their rOS versions (but i hope they do not have an "apple-like" policy)
---
raiffeisen data center infrastructure and security
...stay curious
 
ekim
just joined
Posts: 3
Joined: Mon Oct 19, 2015 2:29 pm

Re: RB532 + routeros mipsle 6.33 = fail

Sun Jan 17, 2016 12:46 pm

here are some observations of 6.33.3 on RB532a. my own 50cents donation :)

very simple configuration here, eth1 goes to internet gateway, rest if's bridged , constituting local network . srcnat between them. wifi wmia-123ag(r) configured , however not used

as others mentioned before: system finishes booting maybe 3 times out of 10 power cycles, however if it goes properly then stopping of terminal communication might happen (from under winbox); didn't notice that with serial console yet.
i have experienced total hangs of whole system. sometimes just after rebooting, sometime after few hours

i use DNS service from localnetwork, with about 200 static definitions - mainly for blocking internet advertisements.
after some uptime, seems it is really random, situations happened where DNS service probably got hanged or crashed , and hostname resolutions became unavailable. i've noticed that winbox showed no previously defined static definitions then, and cached list was also empty. and also "servers" , "Dynamic servers" and "allow remote req" checkbox showed as service was totaly deconfigured

i wasn't able to login with winbox from time to time. before repowering all hardware

and finally pretty interesting observation i made - believe it's helpful. board has RTC set up by hand, i don't use SNTP
noticed that with 6.33.3 real time clock slows down ! quite much. didn't do precise estimation, but remember it drifts down a few hours per day.

maybe 6.33.x included some specific bug correlated with MIPS platform? some internal CPU timers, clock dividers are setup inappropriately. or any other evil thing was silently introduced with MIPS specific kernel hacks... i don't know.....

please, give any feedback if last info was useful for removing bug

right now downgraded to 6.32.3 and after 2 days uptime it works fine.

/edit: i forgot one thing yet, winbox dashboard likes to show 100% load when system becomes broken
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1743
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re:

Sun Jan 17, 2016 4:30 pm

What's wrong with age of 532s? They are great devices regardless of their age.

nothing wrong only curious about the longevity of a routerboard device like that
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Sun Jan 17, 2016 5:07 pm

I am also running some of them with 6.32.3 without any problems.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1743
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: RB532 + routeros mipsle 6.33 = fail

Wed Jan 20, 2016 5:37 pm

What's new in 6.33.5 (2015-Dec-28 09:13):

*) mipsle - architecture support dropped (last fully supported version 6.32.3);
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2292
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RB532 + routeros mipsle 6.33 = fail

Wed Jan 20, 2016 9:25 pm

What's new in 6.33.5 (2015-Dec-28 09:13):

*) mipsle - architecture support dropped (last fully supported version 6.32.3);
It is end for MIPSLE. But why is missing this warning?
RB111, RB112, RB133C, RB150 devices are not supported in v6, please use v5.
LAN, FTTx, Wireless. ISP operator
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Posts: 994
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: RB532 + routeros mipsle 6.33 = fail

Fri Jul 22, 2016 10:57 pm

I never noticed this topic:
I have a bunch of mipsle (Crossroads and RB500) boards.

I was not aware until very recently that the support for these products came to a grinding halt.

I have some of my mipsle based boards running 6.33.5 using the Mikrotik NV2 protocol and have never had any problems - except one of my 5xx boards needs to be remotely power cycled via my PDU sometimes if I software-reboot it.

My mibsle 6.33.5 boards are all in a production environment and work just fine - the only issue I have had is there is no longer any newer firmware support.

I even have a Crossroads with 6.33.5 using superchannel and with NV2 making a 15k connection.

North Idaho Tom Jones

Who is online

Users browsing this forum: No registered users and 132 guests