Community discussions

MikroTik App
 
sparrow
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jul 11, 2012 10:59 am

dhcp over VLAN on crs

Tue Nov 17, 2015 11:14 am

Hi Guys,
I've set up a network using vlan starting from rb2011 passing via crs125-24g-1S.
All works well with pc connetted to their port as an access port, they get a valid ip address from dhcp server configured on vlan, but if i connect one RB and setting on that a vlan with its vlanID whit dhcp-client configured, dhcp-server on rb2011 show that the lease are offered but not bound, and log says:

dhcp,warning Wi-Fi_dhcp offering lease 192.168.2.11 for 00:15:65:xx:xx:xx without success

Maybe I think that there is somthing I must configure in crs to start working VLAN via crs, this is my CRS confuguration:

/interface ethernet
set [ find default-name=ether2 ] master-port=ether1
set [ find default-name=ether3 ] master-port=ether1
set [ find default-name=ether4 ] master-port=ether1
set [ find default-name=ether5 ] master-port=ether1
set [ find default-name=ether6 ] master-port=ether1
set [ find default-name=ether7 ] master-port=ether1
set [ find default-name=ether8 ] master-port=ether1
set [ find default-name=ether9 ] master-port=ether1
set [ find default-name=ether10 ] master-port=ether1
set [ find default-name=ether11 ] master-port=ether1
set [ find default-name=ether12 ] master-port=ether1
set [ find default-name=ether13 ] master-port=ether1
set [ find default-name=ether14 ] master-port=ether1
set [ find default-name=ether15 ] master-port=ether1
set [ find default-name=ether16 ] master-port=ether1
set [ find default-name=ether17 ] master-port=ether1
set [ find default-name=ether18 ] master-port=ether1
set [ find default-name=ether19 ] master-port=ether1
set [ find default-name=ether20 ] master-port=ether1
set [ find default-name=ether21 ] master-port=ether1
set [ find default-name=ether22 ] master-port=ether1
set [ find default-name=ether23 ] master-port=ether1
set [ find default-name=ether24 ] master-port=ether1
/interface vlan
add interface=ether1 l2mtu=1584 name=vlan1_Management use-service-tag=yes vlan-id=1
/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports="ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,eth\
    er13,ether14,ether15,ether16,ether17,ether18,ether19,ether20,ether21,ether22,ether23,ether24"
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether1 vlan-id=10
add tagged-ports=ether1 vlan-id=20
add tagged-ports=ether1 vlan-id=30
add tagged-ports=ether1 vlan-id=2
add tagged-ports=ether1 vlan-id=110
add tagged-ports=ether1 vlan-id=120
/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=10 ports=ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11 sa-learning=yes
add customer-vid=0 new-customer-vid=20 ports=ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20 sa-learning=yes
add customer-vid=0 new-customer-vid=30 ports=ether21,ether22,ether23,ether24 sa-learning=yes
add customer-vid=0 new-customer-vid=2 ports=\
    ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20 \
    sa-learning=yes
add customer-vid=0 new-customer-vid=110 ports=ether21,ether22,ether23,ether24 sa-learning=yes
add customer-vid=0 new-customer-vid=120 ports=ether21,ether22,ether23,ether24 sa-learning=yes
/interface ethernet switch vlan
add ports=ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11 vlan-id=10
add ports=ether1,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether20 vlan-id=20
add ports=ether1,ether21,ether22,ether23,ether24 vlan-id=30
add ports="ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ether13,ether14,ether15,ether16,ether17,ether1\
    8,ether19,ether20" vlan-id=2
add ports=ether1,ether21,ether22,ether23,ether24 vlan-id=110
add ports=ether1,ether21,ether22,ether23,ether24 vlan-id=120
/ip address
add address=192.168.88.2/30 interface=vlan1_Management network=192.168.88.0
/ip route
add distance=1 gateway=192.168.88.1
I hope someone can help me!

Sorry for my bad english
Last edited by sparrow on Tue Nov 17, 2015 3:18 pm, edited 1 time in total.
MTCNA - MTCRE - MTCWE
 
sparrow
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jul 11, 2012 10:59 am

Re: dhcp over VLAN on crs

Tue Nov 17, 2015 1:30 pm

Just Solved now!!
Many thanks!
MTCNA - MTCRE - MTCWE

Who is online

Users browsing this forum: Google [Bot], nalawadesatyen, robsgax, sindy and 88 guests