Community discussions

MikroTik App
 
Mapik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Tue Nov 29, 2005 11:08 am

Routing-test 2.9.28 - ospf-out chain problem

Thu Aug 17, 2006 9:41 am

We upgraded our networks to 2.9.28 (about 110 routerboards) without problems. But now we see that ospf-out chain is not working. All routers have filter for ospf-in and ospf-out. I install one new today and I forget to set filter. I was shocked if I saw routing table, ospf-out chain is totally not working. Working well for us before upgrade... Can anyone help please ???
 
User avatar
Eugene
Forum Veteran
Forum Veteran
Posts: 993
Joined: Mon May 31, 2004 5:06 pm
Location: Cranfield, UK

Thu Aug 17, 2006 12:45 pm

Works fine for me. v2.9.28
Tout individu a droit à la vie, à la liberté et à la sûreté de sa personne.
 
Mapik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Tue Nov 29, 2005 11:08 am

Thu Aug 17, 2006 9:42 pm

Thank you for your reply Eugene, but it's still not working for us. This is export from one of the MTs...
# jan/07/2000 06:16:09 by RouterOS 2.9.28
# software id = 3NQC-3TT
#
/ routing filter 
add chain=ospf-out prefix=0.0.0.0/0 prefix-length=0 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-in prefix=0.0.0.0/0 prefix-length=0 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-in prefix=172.18.0.0/16 prefix-length=16-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-out prefix=172.18.0.0/16 prefix-length=16-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-in prefix=172.19.0.0/16 prefix-length=16-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-out prefix=172.19.0.0/16 prefix-length=16-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-in prefix=172.28.0.0/16 prefix-length=16-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-out prefix=172.28.0.0/16 prefix-length=16-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-in prefix=82.99.178.144/28 prefix-length=28-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-out prefix=82.99.178.144/28 prefix-length=28-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-in prefix=82.99.178.160/28 prefix-length=28-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-out prefix=82.99.178.160/28 prefix-length=28-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-in prefix=82.99.178.176/28 prefix-length=28-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-out prefix=82.99.178.176/28 prefix-length=28-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-in prefix=82.99.178.192/28 prefix-length=28-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-out prefix=82.99.178.192/28 prefix-length=28-32 invert-match=no action=accept comment="" disabled=no 
add chain=ospf-in invert-match=no action=reject comment="" disabled=no 
add chain=ospf-out invert-match=no action=reject comment="" disabled=no 
/ routing ospf 
set router-id=10.99.19.2 distribute-default=never redistribute-connected=as-type-1 redistribute-static=as-type-2 \
    redistribute-rip=no redistribute-bgp=no metric-default=1 metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=20 
/ routing ospf area 
set backbone area-id=0.0.0.0 type=default translator-role=translate-candidate authentication=none disabled=no 
add area-id=172.18.0.0 name="netair" type=default translator-role=translate-candidate authentication=md5 default-cost=1 \
    disabled=no 
/ routing ospf interface 
set FIXME interface=all cost=1 priority=1 authentication-key="xxx" network-type=broadcast \
    retransmit-interval=5s transmit-delay=1s hello-interval=10s dead-interval=40s 
/ routing ospf network 
add network=172.19.2.0/30 area=netair disabled=no 
Router should redistribute only some 172.x.x.x and some 82.99.178.x routes but i can see eg. ranges 192.168.5.0/24 and 192.168.1.0/24 from NATed ethernet in entire network. We have this problem on all routers with 2.9.28. Some solution for this, please ??
 
Mapik
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 90
Joined: Tue Nov 29, 2005 11:08 am

Wed Aug 23, 2006 3:44 pm

Please can someone help how to configure ospf-out filtering in 2.9.28 ??? Always not working for us :(

Who is online

Users browsing this forum: mkx and 78 guests