Community discussions

MUM Europe 2020
 
labor
just joined
Topic Author
Posts: 3
Joined: Fri Dec 04, 2015 6:42 am

RB2011UiAS-2HnD ROS 6.32.2 problem with SIP/RB2011UiAS-2HnD RoS 6.32.2 проблемы с SIP

Fri Dec 04, 2015 7:52 am

Good day!
(Sorry for my English...)

We occasionally have problems with ip telephony. The essence of the problem, Asterisk is unable to re-register as a trunk, as on Mikrotik hangs the connection. Attempts to reset it in manual result does not give, it helps only a complete reboot of the device.

Our telephony server is behind NAT, external connection to it, through a gateway goes traffic from our server to the telephony provider.

To Mikrotik was the usual gateway on Linux, works fine telephony was not. After changing the gateway, we started having problems... On the Asterisk side we have actually tried all the options, but alas.
============================================================================================
Добрый день!

У нас периодически возникают проблемы с ip телефонией. Суть проблемы, Asterisk не может произвести перерегистрацию транка, так как на Mikrotik зависает соединение. Попытки сбросить его в ручную результата не дают, помогает только полная перезагрузка устройства.

Наш сервер телефонии стоит за NAT, внешних подключений к нему нет, через шлюз ходит трафик от нашего сервера до провайдер телефонии.

До Mikrotik стоял обычный шлюз на Linux, нареканий на работу телефонии не было. После смены шлюза у нас начались проблемы... На стороне Asterisk мы перепробовали фактически все возможные опции, но увы.
/system routerboard print 
       routerboard: yes
             model: 2011UiAS-2HnD
     serial-number: 614A05xxxxxx
  current-firmware: 3.22
  upgrade-firmware: 3.24

# dec/04/2015 12:30:08 by RouterOS 6.32.2
# software id = 
#
/ip firewall address-list
add address=192.168.0.36 list=static-admin-hosts
/ip firewall filter
add chain=input comment="Static Admin Host Allow" src-address-list=static-admin-hosts
add chain=input comment="DDNS-Admin-Host Allow" src-address-list=ddns-admin-host
add action=drop chain=input comment="Input Invalid Drop" connection-state=invalid
add action=drop chain=forward comment="Forward Invalid Drop" connection-state=invalid protocol=tcp
add chain=input comment="Estab. Input Pass" connection-state=established
add chain=forward comment="Estab. Forward Pass" connection-state=established
add chain=forward comment="Related Forward Pass" connection-state=related
add action=reject chain=input comment="Drop all input for ssh,winbox" dst-port=8392-8393 protocol=tcp reject-with=icmp-host-unreachable
/ip firewall nat
add action=masquerade chain=srcnat log-prefix=nat- out-interface=pppoe-out1 src-address=192.168.0.0/24
/ip firewall service-port
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
 
User avatar
G2Dolphin
Member Candidate
Member Candidate
Posts: 157
Joined: Sun May 17, 2015 6:03 pm
Location: Moscow, Russia

Re: RB2011UiAS-2HnD ROS 6.32.2 problem with SIP/RB2011UiAS-2HnD RoS 6.32.2 проблемы с SIP

Fri Dec 04, 2015 1:11 pm

I heard they changed something in SIP helpers on last firmwares, so I can advice you to upgrade to the latest 6.33.3 and test it again. Oh and change "/ip firewall service-port set sip disabled=no". This is that SIP helper I'm talking about.
-----
Помню они что-то упоминали про SIP в одной из недавних новых прошивок, так что советую сначала обновиться до последней 6.33.3 и попробовать на ней. Да, и еще — /ip firewall service-port set sip disabled=no. Зря вы его выключили.
Home: RB3011UiAS-IN (2011 case+3011-RM), hAP ac, mAP2n/mAP2nD, GrooveA-52HPn, hEX (r3), hAP lite, RB951G-2HnD
Work: RB2011UiAS-RM / UiAS-2HnD-IN, RB951G-2HnD, hEX (r3), CRS125-24G-1S-2HnD-IN, CCR1009-8G-1S-1S+
 
labor
just joined
Topic Author
Posts: 3
Joined: Fri Dec 04, 2015 6:42 am

Re: RB2011UiAS-2HnD ROS 6.32.2 problem with SIP/RB2011UiAS-2HnD RoS 6.32.2 проблемы с SIP

Sat Dec 05, 2015 3:15 pm

Thank you also read the list of edits, recently updated. By the way, I tried different options:
 "/ ip firewall service-port set sip disabled = no" [/ code]
The problem does not go away ... I hope that will help the new firmware. Thanks for the answer.

====================================================================================
Спасибо, тоже почитал списки правок, на днях обновлю. Да кстати, я пробовал разные варианты:
[code]"/ip firewall service-port set sip disabled=no"
Проблема не исчезает... Буду надеяться, что прошивка новая поможет. Спасибо за ответ.
 
User avatar
RusConSPb
newbie
Posts: 28
Joined: Thu May 03, 2012 4:17 pm
Location: Helsinki, Finland

Re: RB2011UiAS-2HnD ROS 6.32.2 problem with SIP/RB2011UiAS-2HnD RoS 6.32.2 проблемы с SIP

Sat Dec 05, 2015 3:44 pm

Good day!
(Sorry for my English...)

We occasionally have problems with ip telephony. The essence of the problem, Asterisk is unable to re-register as a trunk, as on Mikrotik hangs the connection. Attempts to reset it in manual result does not give, it helps only a complete reboot of the device.
We have same issue... I have made script to remove SIP related connections (time based) - it's simplest way to have it working.
 
labor
just joined
Topic Author
Posts: 3
Joined: Fri Dec 04, 2015 6:42 am

Re: RB2011UiAS-2HnD ROS 6.32.2 problem with SIP/RB2011UiAS-2HnD RoS 6.32.2 проблемы с SIP

Tue Dec 08, 2015 4:12 am

I tried to make a forced reset of the session. For a while it helps, but then cease to be dropped, the session appears again, but in the hung state.

I tried this script:
:foreach i in=[/ip firewall connection find dst-address~":5060" protocol~"udp"] do={ /ip firewall connection remove $i }
Updated RoS v 6.32.2 to 6.33.3 and firmware to 3.22 and to 3.24, see how a show.
============================================================================================

Я пробовал сделать принудительный сброс сессии. Какое то время это помогает, но потом перестает сбрасываться, сессия появляется вновь, но в зависшем состоянии.

Пробовал таким скриптом:
:foreach i in=[/ip firewall connection find dst-address~":5060" protocol~"udp"] do={ /ip firewall connection remove $i }
Обновил RoS c 6.32.2 до 6.33.3 и firemware с 3.22 до 3.24, посмотрим как себя покажет.

Who is online

Users browsing this forum: No registered users and 119 guests