Community discussions

 
JJX
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Fri Nov 11, 2005 2:36 pm

Troubleshotting 100% CPU usage

Sat Dec 12, 2015 6:53 pm

Hello all,

almost every week (maximum 10 days) my mikrotik suddenly reach 100% CPU and network starts to become slow.
After a reboot everything returns back to 20-25% CPU usage, network delays vanish until the next time.

There is not excessive traffic to the network
Is there any way to troubleshoot this problem?

I am using 6.33.3 on RB433
The problem appears at least for 4-6 months randomly!
Thank you
 
regardtv
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Sat Jan 21, 2006 6:54 pm
Location: Johannesburg, South Africa
Contact:

Re: Troubleshotting 100% CPU usage

Sat Dec 12, 2015 11:23 pm

Hi JJX,

Debugging this one can be a bit hit and miss but I'd take a look at a few things:
1) RB433 isn't the fasted device around - ie averaging more than 20-30Mbps is going to suffer imo
2) Dynamic routing protocols like bgp can sometimes eat things alive if RAM is tight (check available RAM [/system resource print] - free memory
3) If you have any firewall rule that dynamically adds items to an address list - check the list didn't grow too big
4) One I most often see on customer device -- DNS server allows remote requests from outside the network ... DDOS kills the device. Add a firewall rule that looks for new dns requests ...

Hope that helps to start with
~If I helped please give me Karma - its free after all~
I make these posts in my personal capacity.
 
JJX
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Fri Nov 11, 2005 2:36 pm

Re: Troubleshotting 100% CPU usage

Sun Dec 13, 2015 3:52 pm

1) Yes, but it should be enough to handle an 24 MBit DSL and 3 WiFi clients....
If excessive traffic was the issue, the problem should be solved after a reboot or should reappear after the reboot (when all connections are re-established)

2)
/system resource print
uptime: 21h2m22s
version: 6.33.3 (stable)
build-time: Dec/03/2015 16:08:10
free-memory: 33.8MiB
total-memory: 64.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 300MHz
cpu-load: 27%
free-hdd-space: 42.4MiB
total-hdd-space: 64.0MiB
write-sect-since-reboot: 807
write-sect-total: 39812406
bad-blocks: 0%
architecture-name: mipsbe
board-name: RB433
platform: MikroTik
3) I don't have

4) DNS is allowed only to internal network.
Cache size is limited to 4096 KB
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1743
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Troubleshotting 100% CPU usage

Sun Dec 13, 2015 3:58 pm

use tools profile to see who is consuming cpu
 
JJX
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 84
Joined: Fri Nov 11, 2005 2:36 pm

Re: Troubleshotting 100% CPU usage

Wed Dec 16, 2015 3:12 pm

I will send an update the next time the problem reappears

Who is online

Users browsing this forum: raisulislam and 110 guests