Community discussions

MikroTik App
 
Freman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 76
Joined: Thu Jul 01, 2004 8:49 am

Get a list of connected PPPoE Sessions

Tue Oct 05, 2004 1:33 am

Is there any quick way to get a list of connected PPPoE Sessions?

I've thought about scripting a program to telnet in and get the information I need, but it is slow, is there a quick way to get a list of connected sessions say, through the api that winbox uses?

Or some other way?

Thanks
 
User avatar
mag
Member
Member
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany
Contact:

Re: Get a list of connected PPPoE Sessions

Tue Oct 05, 2004 9:00 am

probably per snmp.

connected pppoe-sessions are listed in /interface and
/interface pr oid
gives the snmp oid.
 
cmit
Forum Guru
Forum Guru
Posts: 1552
Joined: Fri May 28, 2004 12:49 pm
Location: Germany

Tue Oct 05, 2004 10:52 am

You can get a list of active pppoe connections from the console with the following script line:
:foreach n in=[/interface find type=pppoe-in] do={:put [/interface get $n name]}
Best regards,
Christian Meis
 
hci
Long time Member
Long time Member
Posts: 633
Joined: Fri May 28, 2004 5:10 pm

Wed Oct 06, 2004 2:18 am

:foreach n in=[/interface find type=pppoe-in] do={:put [/interface get $n name]}
Do you know a trick that will get a list of all current PPPoE users with there IP address like that?

Matthew
 
edzix
Member
Member
Posts: 335
Joined: Thu Jul 01, 2004 3:01 pm
Location: Latvia

Wed Oct 06, 2004 12:24 pm

:foreach n in=[/interface find type=pppoe-in] do={:put [/interface get $n name]}
Do you know a trick that will get a list of all current PPPoE users with there IP address like that?

Matthew

here you go:

:foreach i in [/ppp active find ] do={:put ([/ppp active get $i name] . " " . [/ppp active get $i address]}

Edgars
 
Freman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 76
Joined: Thu Jul 01, 2004 8:49 am

Thu Oct 07, 2004 4:39 am

Ah thank you, yes I can see how it would be easy to snmp walk for the information I'm looking for.

Thank you

Who is online

Users browsing this forum: Baidu [Spider], mrtrca, olivier2831 and 180 guests