Community discussions

 
lambert
Long time Member
Long time Member
Topic Author
Posts: 533
Joined: Fri Jul 23, 2010 1:09 am

Queues for PPPoE client on same bridge with DHCP clients

Sat Jan 16, 2016 9:00 pm

I have 70+ tower routers setup with DHCP on a bridge for AccessPoints. I am working to convert this to PPPoE so that we can have the usual accounting tools provided by PPP/RADIUS.

It make sense to me that my existing queue tree setup is not going to match download traffic in my existing queue tree which uses "AP_bridge" as the parent interface. The upload traffic, using my uplink interface as the parent interface, will probably be limited correctly.

Is there a way to modify my queue tree setup so that it will work for my dynamically created PPPoE client interfaces? Or is it best to just return the simple queue parameters via RADIUS for my PPPoE clients?

Here is an example of the configuration of my existing queues. I've only included the 1 up / 1 down plan. The mangle rules mark traffic in both directions with the same packet-mark.
/queue type
  add kind=sfq name=tcw-sfq-default sfq-allot=1514 sfq-perturb=5
  add kind=pcq name=PCQ_ded_down_1024k pcq-classifier=dst-address \
      pcq-limit=40 pcq-rate=1024k pcq-total-limit=2000
  add kind=pcq name=PCQ_ded_up_1024k pcq-classifier=src-address \
      pcq-limit=40 pcq-rate=1024k pcq-total-limit=2000
      
/queue tree
  add max-limit=20M name=Total_Upload_ether1 parent=ether1 priority=8 queue=tcw-sfq-default
  add max-limit=60M name=Total_Download_AP_bridge parent=AP_bridge priority=1 queue=tcw-sfq-default
  add name=ded_1024k_upload_ether1 packet-mark=1024kb_ded_packet parent=Total_Upload_ether1 \
      priority=4 queue=PCQ_ded_up_1024k
  add name=ded_1024k_download_AP_bridge packet-mark=1024kb_ded_packet parent=Total_Download_AP_bridge \
      priority=4 queue=PCQ_ded_down_1024k
      
 
lambert
Long time Member
Long time Member
Topic Author
Posts: 533
Joined: Fri Jul 23, 2010 1:09 am

Re: Queues for PPPoE client on same bridge with DHCP clients

Wed Feb 10, 2016 1:00 am

Janis replied to my support ticket request. He confirmed my suspicions.
In case you have many interfaces in one direction you need to use "Global" HTB instead.
That exactly the reason it was introduced, but you will have to mark upload and
download with separate marks.

You can use dynamic address lists, and add pppoe clients to specific address lists when
they connect, and later use these address lists in mangle.

Regards,
Janis M.
So basically, two options:

a) use Global as the parent and modify the mangle rules to mark packets separately for download and upload directions.

b) use simple queues.

If I'm marking packets separately in both directions, rather than using connection marks and then packet marks, I don't see any benefit to maintaining the queue tree method. Simple queues, here I come.

Who is online

Users browsing this forum: No registered users and 50 guests