Community discussions

 
laciaty
just joined
Topic Author
Posts: 5
Joined: Mon Mar 23, 2015 12:53 pm

RB951Ui-2HnD + huawei e3372 hilink + ipcam (forwarding ports and ddns issue)

Tue Jan 19, 2016 3:56 pm

Hello,
i've got an issue with configuration.
I have:
RB951Ui-2HnD + huawei e3372 hilink mode + ipcam sending stream rstp 554(udp)

I wanted to have remote acces to routerboard so i used script:
# No-IP automatic Dynamic DNS update

#--------------- Change Values in this section to match your setup ------------------

# No-IP User account info
:local noipuser ".............deleted............."
:local noippass "...........deleted................"

# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost "................deleted .................."

# Change to the name of interface that gets the dynamic IP address
:local inetinterface "lte1"

#------------------------------------------------------------------------------------
# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
:local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

# Strip the net mask off the IP address
:for i from=( [:len $currentIP] - 1) to=0 do={
:if ( [:pick $currentIP $i] = "/") do={
:set currentIP [:pick $currentIP 0 $i]
}
}

:if ($currentIP != $previousIP) do={
:log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
:set previousIP $currentIP

# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
:local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
:local noiphostarray
:set noiphostarray [:toarray $noiphost]
:foreach host in=$noiphostarray do={
:log info "No-IP: Sending update for $host"
/tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
:log info "No-IP: Host $host updated on No-IP with IP $currentIP"
}
} else={
:log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
}
} else={
:log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}
And it doesnt work. I have another routerboard with adsl modem and its working, i though that when i changed interface for ,,lte1" it will work.

2. i cannot forward 554 port
chain - dstnat
protocol - udp
dst port 554
In interface lte1

action: dst-nat
to address - 192.168.1.10
to port - 554
Doesnt work :/

I dont know exactly how does the modem works, it does not have any public ip assigned to lte1 interface, like for example a pppoe interface.

www and other services work fine.
1.jpg
2.jpg
can anybody know how to reconfigure this?
You do not have the required permissions to view the files attached to this post.
 
User avatar
ZeroByte
Forum Guru
Forum Guru
Posts: 4051
Joined: Wed May 11, 2011 6:08 pm

Re: RB951Ui-2HnD + huawei e3372 hilink + ipcam (forwarding ports and ddns issue)

Tue Jan 19, 2016 4:49 pm

I dont know exactly how does the modem works, it does not have any public ip assigned to lte1 interface, like for example a pppoe interface.
If the LTE service provider is giving you private IP addresses and performing NAT elsewhere, then you're pretty much out of luck - whatever device is doing NAT for your private IP would have to do a dstnat to map ports to your private IP so you could then map them again to your actual device.

If you can get a public IP address on your lte interface, then it should work as you expected.
When given a spoon,
you should not cling to your fork.
The soup will get cold.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5927
Joined: Mon Jun 08, 2015 12:09 pm

Re: RB951Ui-2HnD + huawei e3372 hilink + ipcam (forwarding ports and ddns issue)

Tue Apr 12, 2016 3:13 pm

There are 2 possible places where NAT occurs:
1. at the provider
2. in the LTE modem

Unfortunately even when the provider does not do NAT, there still is NAT inside those HiLink LTE modems.
You get a 192.168.8.x address from the modem (using DHCP), the modem gets an address from the provider
which can be public or RFC1918 or RFC6598. In the latter two cases there is another NAT at the provider.

It would be nice when the HiLink NAT could be turned off...

Who is online

Users browsing this forum: Google [Bot] and 78 guests