Community discussions

  • 1
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Mar 10, 2017 6:20 pm

Using 207.32.195.2
I cant seem to get more than 300-800Kbps on TCP Download?

Are others having an issue like this ?
TCP and UDP are different types of Internet communications protocols.

UDP is a "Fire and Forget" protocol. The sending device will send a packet or packets and not wait for the intended remote receiver device to acknowledge that anything was received. Kinda like shooting a machine gun - it just sends.

TCP is a "Fire and wait for from the intended remote receiver device to return an acknowledgement (ACK) that a packet was received". After the ACK is received back by the original sending device, then the next TCP packet is sent - and the wait for answer routine begins again. Kinda like shooting a single bullet from a rifle and waiting for somebody to tell you that you hit the target before you shoot again.

UDP can be great for something like a movie stream where if something gets missed , then you just continue on sending the rest of the movie. Thus there is no real guarantee that what you sent was verified that it was received.

TCP can be great for something like pulling up a web page. The web server gets acknowledgement (ACKs) back from the workstation that the web page was properly received. Thus you get fewer communication mistakes.

Let's assume the following (below) are some data packets you want to send - which protocol would you want to use ?
- Packet 1 "Hello Robert , please "
- Packet 2 "don't "
- Packet 3 "call me on the phone"
If using UDP and "Packet 2" is dropped/lost, then the entire message could be understood as something totally different"
If using TCP, the entire communications session can be much slower because there is a wait time for everything.

Now in your scenario where "I cant seem to get more than 300-800Kbps on TCP Download" , the answer could be that you are many hops away (somewhere on the other side of the world), and waiting time for a round-trip answer takes an extended period of time. With UDP, there could be multiple packets going through the Internet that the sender sent and has not been received yet - because those multiple packets are still traveling through the Internet.

There are also some other possible causes of slow TCP traffic such as QOS, priority, network saturation, firewall behavior, symmetric or asymmetric paths through the Internet and others.

I hope I partially answered your question.
((( lol - if you absolutely need faster TCP bandwidth to 207.32.195.2, then mabey you need to move to North Idaho - lol )))

North Idaho Tom Jones
 
olkitu
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Sat Feb 20, 2016 7:04 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Mar 10, 2017 9:24 pm

Nice testing server!

CCR1072-1G-8S+ and 10Gbps Fiber link just we open from Finland. Maybe need get up also similar speedtest server here for testing :)

Image
Network Specialist

Need know where is cellular tower? Try CellMapper to get know where is cellular tower:
https://www.cellmapper.net/map
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sat Mar 11, 2017 2:42 am

olkitu

Re: ...Maybe need get up also similar speedtest server here for testing...

So you thinking about setting up a public btest server ?
I suspect it would be very useful to all Mikrotik admins - especially near your part of the world.

North Idaho Tom Jones
 
abanghasan
just joined
Posts: 1
Joined: Sun Mar 12, 2017 10:48 am
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sun Mar 12, 2017 10:52 am

It is a good bandwith,,it is affordable?and share untul how much user
 
louisk
just joined
Posts: 1
Joined: Sun Mar 12, 2017 9:24 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sun Mar 12, 2017 9:28 pm

Hi there, I have been trying to test my CCR1009 connected to a 2Gbit fiber connection and I have tried both servers listed in this thread. I can consistently get 2GB's down (about 2.1-2.3 actually), but never really more than 1Gb up. Is there something I am doing wrong? I had the ISP come test, and they validated 2GB in each direction using their own tests so they claim the problem is in the CCR router.

Is there a way for me to reliably test 2GB in each direction? I am doing UDP testing.
 
olkitu
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Sat Feb 20, 2016 7:04 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Mar 14, 2017 10:30 am

olkitu

Re: ...Maybe need get up also similar speedtest server here for testing...

So you thinking about setting up a public btest server ?
I suspect it would be very useful to all Mikrotik admins - especially near your part of the world.

North Idaho Tom Jones
Yeah it's nice but let see when i have time to buy licence for 10G+ CHR and put that to VPS... We are ISP and Hosting Company so we have own peering what is 10G+ now. Also we are sell Mikrotik devices here Finland... Also need QOS rules because someone can use that make connection down... Also need server with 10G+ port, now mostly we have only 1G+...

This connection shared also to our customer also :)
Network Specialist

Need know where is cellular tower? Try CellMapper to get know where is cellular tower:
https://www.cellmapper.net/map
 
olkitu
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Sat Feb 20, 2016 7:04 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Mar 14, 2017 10:32 am

Hi there, I have been trying to test my CCR1009 connected to a 2Gbit fiber connection and I have tried both servers listed in this thread. I can consistently get 2GB's down (about 2.1-2.3 actually), but never really more than 1Gb up. Is there something I am doing wrong? I had the ISP come test, and they validated 2GB in each direction using their own tests so they claim the problem is in the CCR router.

Is there a way for me to reliably test 2GB in each direction? I am doing UDP testing.
I think on this free open servers have upload limits... Also where are u? So example here Finland cannot get 10G+ because too long line and too much peering... Thats why need also speedtest server here so can test :) - Both server is in US
Network Specialist

Need know where is cellular tower? Try CellMapper to get know where is cellular tower:
https://www.cellmapper.net/map
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sat Mar 25, 2017 7:13 am

Hi there, I have been trying to test my CCR1009 connected to a 2Gbit fiber connection and I have tried both servers listed in this thread. I can consistently get 2GB's down (about 2.1-2.3 actually), but never really more than 1Gb up. Is there something I am doing wrong? I had the ISP come test, and they validated 2GB in each direction using their own tests so they claim the problem is in the CCR router.

Is there a way for me to reliably test 2GB in each direction? I am doing UDP testing.
Let me guess Comcast gigabit-pro? Either way where are you located and what kind of configuration do you have on the ccr? Like NAT or only layer-3? firewall rules or even regex operations?
 
Groov
just joined
Posts: 1
Joined: Wed Apr 05, 2017 12:27 am

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Apr 05, 2017 12:32 am

Ukraine Dnepr
You do not have the required permissions to view the files attached to this post.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Apr 05, 2017 5:59 pm

3 Gig btest - wow, you definitely have high-speed Internet access.

North Idaho Tom Jones
 
npmarshall
just joined
Posts: 1
Joined: Wed Oct 26, 2016 6:51 am

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Apr 11, 2017 2:38 am

Nevada - performed with a CCR1036-8G-2S+. Thank you very much.
You do not have the required permissions to view the files attached to this post.
 
kei888
newbie
Posts: 47
Joined: Fri Feb 07, 2014 7:54 am

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Apr 20, 2017 3:39 am

Thank you so much for this. :)

More power!

God bless!
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 3:45 am

O come on now ...

It's one thing to run a brief bandwidth test to the public btest server at 207.32.195.2
But it's another thing to run a sustained btest for hours or days non-stop.

Although I have the bandwidth, the simple queues on this btest server will drop down in throughput rates when you keep a sustained btest running. Thus if anybody else tries to btest to the same server, they will never be able to see their peak throughput (because you have the simple queue slowing down the btest server for the next person wanting to test.)

So with that, 216.218.22.xx and 94.142.173.xx , you are more than welcome to btest to 207.32.195.2 - however please make these btest tests brief so the next person can also btest at full speed.

Thank you

North Idaho Tom Jones
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 4:15 am

Yo , planetcoop

Thought I would ask ...

Are you up for a btest server to btest server test ? (my 207.32.195.2 btest server to your 50.235.23.218 btest server) ?

If you have the bandwidth and available resources ...
Sometime tomorrow morning, I would like to run a 4 hours long btest ( both directions - UDP - with up and down speeds set to 1250M ).

I would like to stress test and hold both directions slightly faster than 1-gig. This way I can verify we are on 10-gig routers and switches end to end and that my normal ISP client traffic does not take any slowdown hits during this hours long test.

I was thinking about starting sometime after 8 AM PST tomorrow Friday. But I will wait for your permission btest first.

North Idaho Tom Jones
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 4:53 am

let it rip... :) You can try to PM me or email me if you want, i wouldn't mind an offline conversation.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 6:13 pm

let it rip... :) You can try to PM me or email me if you want, i wouldn't mind an offline conversation.
The btest is running now

Say - shoot me an email with your contact info - and I will call you

My email address is < tjones -at- cdatribe-nsn -dot- gov

North Idaho Tom Jones
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 7:15 pm

you should have an email from me and i have confirmed the test @ 1.35Gbps?
confirmed.png
You do not have the required permissions to view the files attached to this post.
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 10:04 pm

Previous testing
You do not have the required permissions to view the files attached to this post.
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 10:06 pm

Tom, today's test
You do not have the required permissions to view the files attached to this post.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 10:41 pm

btest-4-hours.png
Here are the results of the 4-hour long Mikrotik btest test we just performed:

Public btest server 207.32.195.2 to public btest server 50.235.23.218

This 4-hour long extended btest through the Internet used the following settings:
Local Tx Speed 1250M (aka 1.25 Gig)
Remote Tx Speed 1250M (aka 1.25 Gig)

Amount of data transmitted was more than 2.7 TB -&- amount of data received was more than 2.7 TB

North Idaho Tom Jones
You do not have the required permissions to view the files attached to this post.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 11:07 pm

FYI: public btest server was just software upgraded moments ago.
As of April 28th, 2017 1PM PST, the Mikrotik CHR-P10 is now running CHR-ROS version v6.39


by the way - - - If there are any other Mikrotik admins willing to run a public btest server , please post and let us know. If you do, we can offer some advice for how to limit the maximum btest bandwidth so that your networks continue running correctly during a btest session.

North Idaho Tom Jones
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Apr 28, 2017 11:31 pm

FYI: public btest server was just software upgraded moments ago.
As of April 28th, 2017 1PM PST, the Mikrotik CHR-P10 is now running CHR-ROS version v6.39


by the way - - - If there are any other Mikrotik admins willing to run a public btest server , please post and let us know. If you do, we can offer some advice for how to limit the maximum btest bandwidth so that your networks continue running correctly during a btest session.

North Idaho Tom Jones
I update my edge and btest at 5:30AM PST in preparation for today's btests. So far no issues. :)
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed May 03, 2017 5:24 pm

BUMPED to 6.39.1 current. :)
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed May 03, 2017 6:08 pm

BUMPED to 6.39.1 current. :)
 
wombat
newbie
Posts: 26
Joined: Thu May 14, 2015 10:12 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri May 12, 2017 7:18 pm

Hi,

Why doesn't work only UDP receive direction? All the time only "0 bps" with Both or TCP no problem.
Image
 
Sob
Forum Guru
Forum Guru
Posts: 2919
Joined: Mon Apr 20, 2009 9:11 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri May 12, 2017 7:36 pm

Firewall, most likely. UDP packets from BTest server look like unsolicited traffic.
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri May 12, 2017 9:12 pm

I have posted some high speed feedback for new device considerations in the other post, just mentioning it here to also check out. viewtopic.php?f=2&t=121533
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri May 12, 2017 9:32 pm

Re: ... Firewall, most likely. UDP packets from BTest server look like unsolicited traffic. ...

I agree

The 207.32.195.2 btest server does not have any firewall rules.
The 207.32.195.2 btest server is not behind another firewall.
The 207.32.195.2 btest server is directly connected to the Internet.

If somebody is having problems with a TCP and/or UDP btest in either or both directions, then you may want to examine your firewall rules.

North Idaho Tom Jones
 
wombat
newbie
Posts: 26
Joined: Thu May 14, 2015 10:12 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri May 12, 2017 10:54 pm

Ok, i have default firewall. When i disable drop rule. So it works good. Have I bad firewall rules?
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri May 12, 2017 11:08 pm

no, typically you do not want the internet or random networks hitting the input chain. you would have to allow for this with a rule additional to default rules but you can also enable/disable rules based on testing or other requirements.

As Tom said in his previous post about the btest, mine is not as accessible due to ipv4 limitations i have. Mine is NAT4 behind an address on a ccr1036 and is also available on ipv6 directly routed through the ccr1036. In my own testing the NATipv4 configuration is not a limitation in testing and has a port range to support testing.
 
jarda
Forum Guru
Forum Guru
Posts: 7249
Joined: Mon Oct 22, 2012 4:46 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri May 12, 2017 11:19 pm

Most probably it is better than nothing. Just add accepting rule for the traffic from the ip addresses you want to get packets from.
 
User avatar
k6ccc
Member Candidate
Member Candidate
Posts: 262
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue May 30, 2017 9:48 pm

First of all, thanks guys for offering these bandwidth tests.
I'm trying to set this up as a script with the output to a file which will then be E-Mailed to me. The idea being that once a day, the router will perform the test. If I see substantial changes in performance, I can investigate. For testing this, I am using the following commands:
[admin@RB750Gr3 #2] /tool> bandwidth-test 50.235.23.208 direction=both duration=15s random-data=yes user=btest password=btest

This produces a correct output after 15 seconds:
status: done testing
duration: 16s
tx-current: 12.1Mbps
tx-10-second-average: 12.1Mbps
tx-total-average: 11.8Mbps
rx-current: 121.2Mbps
rx-10-second-average: 95.4Mbps
rx-total-average: 68.8Mbps
lost-packets: 0
random-data: yes
direction: both
tx-size: 1500
rx-size: 1500

Then I change the command to:
[admin@RB750Gr3 #2] /tool> bandwidth-test 50.235.23.208 direction=both duration=15s random-data=yes user=btest password=btest file="BW_test.txt"

This produces the file BW_test.txt as expected, but not with the expected data. All I get in the output file is:
# may/30/2017 11:28:43 by RouterOS 6.39.1
# software id = [redacted]
#
status: connecting
duration: 0s
tx-current: 0bps
tx-10-second-average: 0bps
tx-total-average: 0bps
rx-current: 0bps
rx-10-second-average: 0bps
rx-total-average: 0bps
lost-packets: 0
random-data: yes
direction: both
tx-size: 1500
rx-size: 1500

I never get any results after connecting.

Any suggestions about what I'm missing???

BTW, this is from the Los Angeles area on my newly installed Spectrum cable based connection (massive improvement over my DSL!)

Thanks
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
User avatar
k6ccc
Member Candidate
Member Candidate
Posts: 262
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Jun 01, 2017 6:14 pm

BTW, ignore my typo of the IP address that I'm using for my testing. I really am using 50.235.23.218
RB750Gr3, RB750r2, CRS326-24G-2S (in SwitchOS), CSS326-24G-2S, CSS106-5G-1S, RB260GS
Not sure if I beat them in submission, or they beat me into submission


Jim
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Jun 06, 2017 3:23 pm

I have updated my CHR btest 50.235.23.218 to 6.39.2: viewtopic.php?f=21&t=122322
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Jun 06, 2017 10:22 pm

I have updated my CHR btest 207.32.195.2 to 6.39.2
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Jun 06, 2017 10:29 pm

btest002.png
btest001.png
FYI - below is a cacti graph of my 207.32.195.2 btest server
You do not have the required permissions to view the files attached to this post.
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Jun 06, 2017 11:44 pm

Anyone notice the pickup in testing between both servers and the sustained testing?
bleeding.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 1:43 am

Anyone notice the pickup in testing between both servers and the sustained testing?
bleeding.png
On the 207.32.195.2 btest server, I have been seeing some btest sessions that appear to not quit after a few minutes.
I have seen some btest sessions that will go 24 hours non-stop.

Hay everybody - please do not run sustained btest tests. These btest servers are intended for brief btest testing.
When one person holds a continued non-stop btest, then other Mikrotik admins can get skewed results to the same btest server.

Example - on my 207.32.195.2 btest server, I have a simple-queue that will auto drop the bandwidth after a minute or so to around 500 meg in both directions.
When somebody holds an extended btest test, the simple-queue kicks in. Then when a 2nd Mikrotik admin starts a btest, then both admins are sharing a 500 meg max throughput session.
I often see 5 btest tests at the same time - this means that when one person has triggered the simple-queue (because of a lengthy btest) , then all 5 Mikrotik admins can only get a slice to the 500 meg (due to simple-queue).
When nobody in btesting, the simple-queue clears itself and the first person to execute a btest test can actually hit 2-gig and faster for a minute-or-so until the simple-queue kicks in again.

North Idaho Tom Jones
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 1:49 am

Re - the sustained btest Mikrotik tests

We know who the extended non-stop btest testers are. We just use our Winbox and go to Tools - BTest server - Sessions (there is your IP testing to our btest server)

Please play nice and fair for other btest testers and please do not hold extended non-stop btest tests.

If you have a special need, we can and are willing to set-up something special for temporary extended testing.

North Idaho Tom Jones
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 1:56 am

Re - the sustained btest Mikrotik tests

Yo Mikrotk ROS programmers ... Is there a possibility of a newer ROS to have a new option in the btest server ?
[ ] Enabled
[ ] Authenticate
Allocate UDP Ports from: [ 2000 ]
Max Sessions: [ 100 ]
Timeout per btest session in seconds [ 300 ]
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 3:23 am

I really did not want to do this - but I had a customer trying to use the btest server
So I had to simple-queue a continuous non-stop btest from a remote location

138-117-109-222.png
You do not have the required permissions to view the files attached to this post.
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 4:17 am

Here is the raw filter i am thinking of. ID the user source address with a timer of 5 minutes and then block all traffic for 2 hours until the next time. :)
raw filters.png
You do not have the required permissions to view the files attached to this post.
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 4:19 am

I have enabled my rules. :)
raw filters tested.png
You do not have the required permissions to view the files attached to this post.
Last edited by planetcoop on Wed Jun 07, 2017 4:25 am, edited 1 time in total.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 4:21 am

Here is the raw filter i am thinking of. ID the user source address with a timer of 5 minutes and then block all traffic for 2 hours until the next time. :)
raw filters.png
Looks interesting :)

Does it block only the single IP address for 2 hours and allow everybody else to still test ?

I am gonna have to take a look at this !

North Idaho Tom Jones
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 4:25 am

yes, source ip addresses

/ip firewall raw
add action=accept chain=prerouting comment="testers accepted" src-address-list=tester
add action=drop chain=prerouting comment="previous testers drop" src-address-list=previous
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=udp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=udp
raw filters results.png
You do not have the required permissions to view the files attached to this post.
Last edited by planetcoop on Wed Jun 07, 2017 4:32 am, edited 1 time in total.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 4:28 am

yes, sent you an email if you want to call


/ip firewall raw
add action=accept chain=prerouting comment="testers accepted" src-address-list=tester
add action=drop chain=prerouting comment="previous testers drop" src-address-list=previous
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=udp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=udp
It's almost the end of my work day and I am getting tired...
Do you need to enter a specific IP address , or is it automatic ?
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 4:32 am

Post wars, its automagic and RAW is wirespeed
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 780
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 4:43 am

Post wars, its automagic and RAW is wirespeed
I am heading home
Tomorrow I will make a backup and give it a try.

With that - a note to all Mikrotik admins who btest to the 207.32.195.2 server , I am going to be testing the above changes tomorrow.
I will post a final config and then ask for user input on how well it is performing.

North Idaho Tom Jones
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 6:35 am

Forum and friends. I have just banned any address related to AS14868 and any related AS as i was just hit with a massive wave of btests.
https://ipinfo.io/AS14868

This isnt a business btest server, but rather a CHR in my home. It is free to use and conduct random tests. Please do not use my personal network for business deployments or use without my expressed permission.
abuse.png
You do not have the required permissions to view the files attached to this post.
 
planetcoop
Member Candidate
Member Candidate
Posts: 109
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 7:46 am

Well, this is getting fun. I have now blocked 176.0.0.0-201.0.0.0. Sorry for the inconvenience to the rest of my fellow testers.
  • 1
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9

Who is online

Users browsing this forum: No registered users and 32 guests