Community discussions

 
User avatar
pukkita
Trainer
Trainer
Posts: 2975
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 11:05 am

Hello guys!

It's sad how some people spoils others good will and hard work :evil:

I helped another forum user to apply queues to bw-test.

Posting here as this is the most dense-packed thread on bw-test.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 4:34 pm

Ok, my current IP ban list blocked from my network:
/ip firewall address-list
add address=176.0.0.0/4 list=blocklist
add address=192.0.0.0/5 list=blocklist
add address=200.0.0.0/7 list=blocklist
add address=77.xx.xxx.132 list=blocklist
add address=160.0.0.0/4 list=blocklist

/ip firewall raw
add action=accept chain=prerouting comment="allow lan" src-address=192.168.0.0/24
add action=drop chain=prerouting comment="testers to block" src-address-list=blocklist
add action=accept chain=prerouting comment="testers accepted" src-address-list=tracking
add action=accept chain=prerouting comment="testers accepted" disabled=yes src-address-list=tester
add action=drop chain=prerouting comment="previous testers drop" disabled=yes src-address-list=previous
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" disabled=yes dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" disabled=yes dst-port=2000-2100 protocol=udp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" disabled=yes dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" disabled=yes dst-port=2000-2100 protocol=udp
add action=add-src-to-address-list address-list=tracking address-list-timeout=1d chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=tracking address-list-timeout=1d chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=udp

I will also be changing my btest rules. I will remove the 5 minute limitation and the every 2 hour rules. The past 8 hours have proved effective and my CHR has not been abused otherwise. Enjoy.
1f7zvoFbGoj9tn0U.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 6:26 pm

planetcoop

Is this all I need to do to try your settings ?

[admin@207-32-195-2-CHR-P10] > ip
[admin@207-32-195-2-CHR-P10] /ip> firewall
[admin@207-32-195-2-CHR-P10] /ip firewall> export
# jun/07/2017 08:15:57 by RouterOS 6.39.2
# software id =
#
[admin@207-32-195-2-CHR-P10] /ip firewall> raw
[admin@207-32-195-2-CHR-P10] /ip firewall raw> export
# jun/07/2017 08:16:29 by RouterOS 6.39.2
# software id =
#
[admin@207-32-195-2-CHR-P10] /ip firewall raw> ..
[admin@207-32-195-2-CHR-P10] /ip firewall> export
# jun/07/2017 08:16:34 by RouterOS 6.39.2
# software id =
#
[admin@207-32-195-2-CHR-P10] /ip firewall> /ip firewall raw
[admin@207-32-195-2-CHR-P10] /ip firewall raw> add action=accept chain=prerouting comment="testers accepted" src-address-list=tester
[admin@207-32-195-2-CHR-P10] /ip firewall raw> add action=drop chain=prerouting comment="previous testers drop" src-address-list=previous
[admin@207-32-195-2-CHR-P10] /ip firewall raw> add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=tcp
[admin@207-32-195-2-CHR-P10] /ip firewall raw> add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=udp
[admin@207-32-195-2-CHR-P10] /ip firewall raw> add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=tcp
[admin@207-32-195-2-CHR-P10] /ip firewall raw> add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=udp
[admin@207-32-195-2-CHR-P10] /ip firewall raw>

planetcoop - is this correct and should work ?
I am not experienced with ROS firewalls. For core, in-house, for business firewalls, I generally use PfSense instead or Cisco firewalls.

North Idaho Tom Jones
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 6:58 pm

That should be it with several assumptions, 5 minute test window every 2 hours based on source ip. This will also include your address ranges. Also that tcp/udp 2000-2100 for the port range.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 7:07 pm

That should be it with several assumptions, 5 minute test window every 2 hours based on source ip. This will also include your address ranges. Also that tcp/udp 2000-2100 for the port range.
OK - some questions:
- What is needed for a allow this network at all times? Such as I want to allow all of my Class C networks at all times where they skip the firewall raw configs.
- Is there a way to see what IP address are temporarily in the 2-hour blocked window & when those IPs entered that state?
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 7:25 pm

/ip firewall address-list
add address=YOURNET/22 list=tester

/ip firewall raw
add action=accept chain=prerouting comment="allow lan" src-address=192.168.0.0/24
add action=drop chain=prerouting comment="testers to block" src-address-list=blocklist
add action=accept chain=prerouting comment="testers accepted" src-address-list=tracking
add action=accept chain=prerouting comment="testers accepted" disabled=yes src-address-list=tester
add action=drop chain=prerouting comment="previous testers drop" disabled=yes src-address-list=previous
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=udp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=udp
add action=add-src-to-address-list address-list=tracking address-list-timeout=1d chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=tracking address-list-timeout=1d chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=udp
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 8:32 pm

1st - a special thanks to planetcoop for all of his help and assistance and participation in the public btest servers for all Mikrotik admins.

Below is my 207.32.195.2 best server configuration (as of today):

[admin@207-32-195-2-CHR-P10] > export
# jun/07/2017 10:09:19 by RouterOS 6.39.2
# software id =
#
/interface ethernet
set [ find default-name=ether1 ] loop-protect=off
/queue simple
add burst-limit=3600M/3600M burst-threshold=500M/500M burst-time=11m40s/11m40s max-limit=500M/500M name=3.6-Gig
/snmp community
((( My SNMP configuration settings )))
/user group
add name=btest policy=test,winbox,romon,tikapp,!local,!telnet,!ssh,!ftp,!reboot,!read,!write,!policy,!password,!web,!sniff,!sensitive,!api,!dude
/ip address
add address=207.32.195.2/30 interface=ether1 network=207.32.195.0
/ip dns
set servers= ((( My DNS servers )))
/ip firewall address-list
add address= ((( One of my networks ))) list=tester
add address= ((( One of my networks ))) list=tester
add address= ((( One of my networks ))) list=tester
add address= ((( One of my networks ))) list=tester
add address= ((( One of my networks ))) list=tester
add address= ((( One of my networks ))) list=tester
/ip firewall raw
add action=accept chain=prerouting comment="allow lan" src-address=192.168.0.0/24
add action=drop chain=prerouting comment="testers to block" src-address-list=blocklist
add action=accept chain=prerouting comment="testers accepted" src-address-list=tracking
add action=accept chain=prerouting comment="testers accepted" disabled=yes src-address-list=tester
add action=drop chain=prerouting comment="previous testers drop" disabled=yes src-address-list=previous
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=tester address-list-timeout=5m chain=prerouting comment="add to tester" dst-port=2000-2100 protocol=udp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=previous address-list-timeout=2h chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=udp
add action=add-src-to-address-list address-list=tracking address-list-timeout=1d chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=tcp
add action=add-src-to-address-list address-list=tracking address-list-timeout=1d chain=prerouting comment="add to previous" dst-port=2000-2100 protocol=udp
/ip route
add distance=1 gateway=207.32.195.1
/ip service
((( My NTP configuration setting )))
/snmp
((( My SNMP configuration settings )))
/system clock
set time-zone-autodetect=no time-zone-name=America/Los_Angeles
/system identity
set name=207-32-195-2-CHR-P10
/system ntp client
((( My NTP configuration settings )))
/tool graphing interface
add interface=ether1
/tool netwatch
add comment="btest server in Plummer at Red-Spectrum" host=207.32.195.2
[admin@207-32-195-2-CHR-P10] >

If any Mikrotik admins experience any new problems with my public 207.32.195.2 btest server, please let me know. Also, if it appears to be running normal and behaving as you have experienced in the recent past, again please let us know.

FYI - I will let some traffic pass for several hours then post a newer/updated bandwidth graph for this btest server.

Again - thanks to everybody who helps support everybody in this btest project :) Your comments and support help everybody :)

North Idaho Tom Jones
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jun 07, 2017 9:21 pm

planetcoop

Question for you
what are the two grayed out items (marked inside the red box) and what do they do if I enable them - should they be enabled ?

Thanks
North Idaho Tom Jones
question1.png
You do not have the required permissions to view the files attached to this post.
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Jun 08, 2017 12:24 am

Sorry for the delay, but you should enable them. It enforces the 5 minute and 2 hour rules.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Jun 08, 2017 4:44 am

info btest server 207.32.195.2

I have some new rules in place in the configuration to block and stop "robo-btest testing". Where a remote mikrotik is scripted to perform robo btests to 207.32.195.2
Also
Please limit your btest tests to 1 minute. Anything longer will auto place you in a block for a period of time.

Note: When we see robo automated btest tests to the public btest servers - and when we see non-stop-continouis btest tests to the public btest servers, we conclude the following:
- Somebody is abusing the public btest servers
-and/or-
- Somebody may be abusing their Internet ISP by creating sustained network loads on their ISP and all router paths to the public btest servers

Again - Everybody is welcome to manually test to the btest servers, however please limit the actual btest session to 1-minute or less - and please wait a minimum of 15 minutes before starting your next btest. Please remember, there are many many many other Mikrotik admins in many countries also using these btest servers.

Thank you

North Idaho Tom Jones
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Jun 08, 2017 8:40 pm

Great news for the day, the DDOS was hitting "btest.planetcoop.com" has been blocked for the moment and the CHR up time is over 48 hours now. Additionally, this should allow for more beneficial test results. Please update us if you are having any issues with btest throughput.
 
Greg
just joined
Posts: 1
Joined: Sat Jun 10, 2017 11:59 pm
Location: Switzerland

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sun Jun 11, 2017 12:06 am

First things first, thank you for making those servers available.

We got a solid performance from Geneva, Switzerland, Europe.
Image

The graph page at https://btest.planetcoop.com:10443/graphs/iface/ether1/ didn't seem to show the test however.
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Mon Jun 12, 2017 6:15 am

First things first, thank you for making those servers available.

We got a solid performance from Geneva, Switzerland, Europe.
Image

The graph page at https://btest.planetcoop.com:10443/graphs/iface/ether1/ didn't seem to show the test however.
Depending on the length of test the graph wont show it. I think the shortest interval is 5 minutes per average. You would have to run it for 5 or more minutes to start showing detail. If you would like you may run the test longer.
 
User avatar
JohnSmith75
just joined
Posts: 4
Joined: Mon Jun 12, 2017 2:14 pm
Location: USA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Mon Jun 12, 2017 2:24 pm

Thanks for the service Tom. Very useful one, in my opinion, it's great alternative to speedtest.
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Mon Jun 19, 2017 8:05 pm

Happy to report this week that i have not seen any issues without blocking select ip addresses and a 5 minute per hour rule. Please let me know if you have issue with "btest.planetcoop.com". Also as it has been said before, if you have a special use case for a longer test or other requirement, please PM or post here so that we can help test and support the Mikrotik community.
 
ajack46
newbie
Posts: 36
Joined: Tue Mar 28, 2017 9:08 am

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Jun 20, 2017 12:13 pm

Thanks for the service Tom. Very useful one, in my opinion, it's great alternative to speedtest.
Couldn't agree more, some good tool for speed test indeed.
 
aliclubb
just joined
Posts: 3
Joined: Tue Mar 07, 2017 12:29 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Jun 29, 2017 1:39 pm

Happy to report this week that i have not seen any issues without blocking select ip addresses and a 5 minute per hour rule. Please let me know if you have issue with "btest.planetcoop.com". Also as it has been said before, if you have a special use case for a longer test or other requirement, please PM or post here so that we can help test and support the Mikrotik community.
Can't seem to PM you, but would really like to discuss current list of blocked IPs, suspect I was a dipstick and left a btest running on a customers router by accident as a certain portion of our IPs seem to be unable to btest to btest.planetcoop.com now.
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Jun 30, 2017 1:56 am

Happy to report this week that i have not seen any issues without blocking select ip addresses and a 5 minute per hour rule. Please let me know if you have issue with "btest.planetcoop.com". Also as it has been said before, if you have a special use case for a longer test or other requirement, please PM or post here so that we can help test and support the Mikrotik community.
Can't seem to PM you, but would really like to discuss current list of blocked IPs, suspect I was a dipstick and left a btest running on a customers router by accident as a certain portion of our IPs seem to be unable to btest to btest.planetcoop.com now.
I am currently using several rule sets to block ip addresses as discussed in this thread:
viewtopic.php?f=9&t=98804

Additionally i have the 5 minute btest rule per every hour as well. I have finally created one rule for a 5 minute test every 12 hours with an ending ip of .132. If this is your ip it is not a problem and i am willing to allow it to use the 5 minute out of the hour in my main rule set. At this point i am trying to understand the traffic patterns as you have seen my previous posts about abuse from Brazil-net AS network that are un-secure.

FYI, i am also not sure on the PM part of the forum.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2975
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Jun 30, 2017 11:07 am

PM is disabled.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
aliclubb
just joined
Posts: 3
Joined: Tue Mar 07, 2017 12:29 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Jul 04, 2017 2:12 pm

Happy to report this week that i have not seen any issues without blocking select ip addresses and a 5 minute per hour rule. Please let me know if you have issue with "btest.planetcoop.com". Also as it has been said before, if you have a special use case for a longer test or other requirement, please PM or post here so that we can help test and support the Mikrotik community.
Can't seem to PM you, but would really like to discuss current list of blocked IPs, suspect I was a dipstick and left a btest running on a customers router by accident as a certain portion of our IPs seem to be unable to btest to btest.planetcoop.com now.
I am currently using several rule sets to block ip addresses as discussed in this thread:
viewtopic.php?f=9&t=98804

Additionally i have the 5 minute btest rule per every hour as well. I have finally created one rule for a 5 minute test every 12 hours with an ending ip of .132. If this is your ip it is not a problem and i am willing to allow it to use the 5 minute out of the hour in my main rule set. At this point i am trying to understand the traffic patterns as you have seen my previous posts about abuse from Brazil-net AS network that are un-secure.

FYI, i am also not sure on the PM part of the forum.
Ok, no that's not our IP. Would you be able to shoot me an email to ali@airbroadband.co.uk to discuss this further in private? I'm still having issues, and just looked at it further and there is some weird behaviour going on, potentially on your servers end?
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Jul 04, 2017 11:45 pm

I have sent an email. If anyone else has an issue please post here. I am not trying to eliminate bandwidth usage but I am trying to keep my network from contributing to internet abuses. Thank you.
 
shaider
just joined
Posts: 11
Joined: Thu Mar 23, 2017 6:54 am
Location: Taytay, Philippines
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Jul 20, 2017 5:56 pm

may i know if the btest server is still active or online? at first its working on my end then today. i cant get any results.
thank you for sharing your network ^^,v
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Jul 20, 2017 6:12 pm

may i know if the btest server is still active or online? at first its working on my end then today. i cant get any results.
thank you for sharing your network ^^,v
My 207.32.195.2 btest server is working. (However I just rebooted it to make sure).

planetcoop and I ( TomJ North Idaho ) , both run public accessible Mikrotik CHR btest servers which are connected to the Internet using 10-gig interfaces.

We both made some changes somewhat recently which block/drop extended/lengthy/non-stop/frequently-repeating btests. We both have slightly different rules for the configuration.

My 207.32.195.2 btest test server (here in North Idaho) has the following:
- Max up/down speeds of about 3-gig btest
- I have a limit of about 2 minutes for a btest then the test auto terminates - then you will need to wait a few minutes before you can btest again.

I configured the rules on my 207.32.195.2 btest server because we were seeing extended/lengthy/non-stop btests and/or auto-repeating btests every minute of every hour of every day. This was preventing other btesters from getting good/clean btest results because the btest server bandwidth was shared between everybody testing at the same time - which made slower btest results for everybody testing at the same time.

I am pretty sure planetcoop has very similar reasons for his btest limits also.

Anyways - if you are testing to my North Idaho 207.32.195.2 btest server , try waiting 4 minutes , then run a btest for about 1 minute up , wait 4 minutes then run a btest for about 1 minute down - then optionally repeat a few times to make sure your btest results come out the same.

North Idaho Tom Jones
 
shaider
just joined
Posts: 11
Joined: Thu Mar 23, 2017 6:54 am
Location: Taytay, Philippines
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Jul 20, 2017 8:02 pm

i see. maybe thats the reason why i coudnt do any btest. but lately i did. i was able to do btest twice. and thats the limitation per day..
thank you for sharing your network. Image
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Jul 21, 2017 8:50 pm

I have limited my btest CHR to a 5 minute window once per hour. once the server sees traffic or the session from you it will block you at the end of the five minutes and then allow the connection 60 minutes after first contact again. As Tom has described we have seen some lengthy testing. Please feel free to test as much as you want within that window to btest.planetcoop.com. If you need additional testing, please reach out as i can work with you to add you on a longer testing white list.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sat Jul 22, 2017 1:02 am

I have limited my btest CHR to a 5 minute window once per hour. once the server sees traffic or the session from you it will block you at the end of the five minutes and then allow the connection 60 minutes after first contact again. As Tom has described we have seen some lengthy testing. Please feel free to test as much as you want within that window to btest.planetcoop.com. If you need additional testing, please reach out as i can work with you to add you on a longer testing white list.
planetcoop - a question re the "5 minute window once per hour" on your btest server

Will this work below (without your rules blocking for an hour) ?:
1 minute btest TCP send
1 minute btest TCP receive
1 minute btest UDP send
1 minute btest UDP receive

(or any combination of different btest(s) within an hour prior to adding up to 5-minutes within the hour)

North Idaho Tom Jones
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Mon Jul 24, 2017 3:31 pm

I have limited my btest CHR to a 5 minute window once per hour. once the server sees traffic or the session from you it will block you at the end of the five minutes and then allow the connection 60 minutes after first contact again. As Tom has described we have seen some lengthy testing. Please feel free to test as much as you want within that window to btest.planetcoop.com. If you need additional testing, please reach out as i can work with you to add you on a longer testing white list.
planetcoop - a question re the "5 minute window once per hour" on your btest server

Will this work below (without your rules blocking for an hour) ?:
1 minute btest TCP send
1 minute btest TCP receive
1 minute btest UDP send
1 minute btest UDP receive

(or any combination of different btest(s) within an hour prior to adding up to 5-minutes within the hour)

North Idaho Tom Jones
At the moment it is by ip address and the remote address starts the 5 minute timer. So for example your btest to my btest. The first packet starts the timer and you have 5 minutes to conduct any testing. After 5 minutes, the btest CHR blocks the address for the next 55 minutes. After that, the temporary blocked address is removed and valid to pursue any further tests with the same ongoing rules as above. It is harsh, but i have found that to be very effective and it dynamically weeds out abuse. I have also said i can whitelist any tester if they need additional testing as we have in the past tested beyond a 5 minute test. :)
 
gdo
just joined
Posts: 8
Joined: Wed Jul 26, 2017 12:30 am

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Jul 26, 2017 1:20 am

thank u
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Jul 27, 2017 8:27 pm

Notice: I just upgraded my 207.32.195.2 public accessible Mikrotik CHR btest server to v6.40

If you experience any issues, please let me know

North Idaho Tom Jones
 
shaider
just joined
Posts: 11
Joined: Thu Mar 23, 2017 6:54 am
Location: Taytay, Philippines
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Jul 28, 2017 2:56 am

Thank you TomjNorthIdaho for the btest server. we are now using it right now. and we added some script to make things easier.

:do {
:local MTUSRPHsource "https://s.mep.ph/btest/";
:local scriptName "btest.rsc";
:put "Downloading btest script...";
:do {
/tool fetch url="$MTUSRPHsource$scriptName" mode=https dst-path="/$scriptName";
} on-error={
:put "Error. Download failed";
}
:put "Importing update script...";
:do {
/import "$scriptName";
} on-error={
:put "import failed. unknown error.";
}
:put "Removing update script...";
:do {
/file remove "$scriptName";
} on-error={}
:put "Update Complete.";
}
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Jul 28, 2017 8:25 pm

Notice: I just upgraded my 207.32.195.2 public accessible Mikrotik CHR btest server to v6.40

If you experience any issues, please let me know

North Idaho Tom Jones
Updated btest.planetcoop.com to 6.40 yesterday as well. Enjoy :)
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Jul 28, 2017 8:26 pm

Thank you TomjNorthIdaho for the btest server. we are now using it right now. and we added some script to make things easier.

:do {
:local MTUSRPHsource "https://s.mep.ph/btest/";
:local scriptName "btest.rsc";
:put "Downloading btest script...";
:do {
/tool fetch url="$MTUSRPHsource$scriptName" mode=https dst-path="/$scriptName";
} on-error={
:put "Error. Download failed";
}
:put "Importing update script...";
:do {
/import "$scriptName";
} on-error={
:put "import failed. unknown error.";
}
:put "Removing update script...";
:do {
/file remove "$scriptName";
} on-error={}
:put "Update Complete.";
}
I have reviewed your script and i will give it a try, but please be careful, your gmail account details are in the script and un-encrypted.... You could pull the tool section and make it another script not publicly available.
 
shaider
just joined
Posts: 11
Joined: Thu Mar 23, 2017 6:54 am
Location: Taytay, Philippines
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sat Jul 29, 2017 9:34 am

thank you planetcoop for the concern about the email on the rsc.. its ok to put it on public. we just use it here in Philippines for or as sending recipient on our routerboard..
once again thank you so much for the btest server. ^^,v
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Aug 04, 2017 8:20 pm

FYI - I just upgraded the public accessible 207.32.195.2 btest server from v6.40 to v6.40.1
If you encounter any new/strange issues , please let me know.

North Idaho Tom Jones
 
JKais
just joined
Posts: 1
Joined: Wed Aug 16, 2017 1:51 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Fri Aug 18, 2017 2:43 pm

Hi,

I have been trying to do it from our office in Spain, but haven't been able to do it. Any suggestion?

Would be super appreciate it.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Aug 23, 2017 3:19 pm

Hi,

I have been trying to do it from our office in Spain, but haven't been able to do it. Any suggestion?

Would be super appreciate it.
Is it working now ?

Over the weekend, I had to turn-off the 207.32.195.2 btest server. I had a 10-gig fiber cut and my business fell back to a less-than-500-meg Microwave link. Everything was turned back on Tuesday morning.

North Idaho Tom Jones
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1040
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Aug 23, 2017 5:02 pm

Hi,

I have been trying to do it from our office in Spain, but haven't been able to do it. Any suggestion?

Would be super appreciate it.
Is it working now ?

Over the weekend, I had to turn-off the 207.32.195.2 btest server. I had a 10-gig fiber cut and my business fell back to a less-than-500-meg Microwave link. Everything was turned back on Tuesday morning.

North Idaho Tom Jones
Unfortunately does not seem to be working, I just tried and it ties to connect and then fails to connect
MTCNA, MTCTCE, MTCRE & MTCINE
 
User avatar
ionas
just joined
Posts: 11
Joined: Tue May 05, 2015 9:41 pm
Location: Nicosia
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Aug 23, 2017 7:30 pm

Thank you so much! It is so helpful!

Tested from Holland
You do not have the required permissions to view the files attached to this post.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Aug 23, 2017 8:08 pm

Request - a little help please ...

I suspect my 10-Gig physical Internet connection (2-Gig burstable to 4-Gig), may not be achieving what I am paying for. It appears like I am only running on a 1-Gig Internet connection.
Thus, I suspect my 207.32.195.2 btest server may also not be performing at greater than 1-Gig btest speeds.

This is where I am asking for help.
Just now, I disabled all bandwidth limits and rules on my 207.32.195.2 btest server.
Please, will the Mikrotik admins with 1-Gig and faster Internet connections please perform a couple of btests to my 207.32.195.2 btest server and then please post their btest throughput results.

I will attempt to keep the 207.32.195.2 btest server open & un-limited for a few days - or until I begin to experience bandwidth load issues - or until I am able to confirm my upstream bandwidth problems.

Note - please limit your btest testing to a maximum of 1 to 2 minutes per test.

btest server: 207.32.195.2
User: btest
Password: btest
Thank you

North Idaho Tom Jones
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sun Aug 27, 2017 10:32 pm

Request - a little help please ...

I suspect my 10-Gig physical Internet connection (2-Gig burstable to 4-Gig), may not be achieving what I am paying for. It appears like I am only running on a 1-Gig Internet connection.
Thus, I suspect my 207.32.195.2 btest server may also not be performing at greater than 1-Gig btest speeds.

This is where I am asking for help.
Just now, I disabled all bandwidth limits and rules on my 207.32.195.2 btest server.
Please, will the Mikrotik admins with 1-Gig and faster Internet connections please perform a couple of btests to my 207.32.195.2 btest server and then please post their btest throughput results.

I will attempt to keep the 207.32.195.2 btest server open & un-limited for a few days - or until I begin to experience bandwidth load issues - or until I am able to confirm my upstream bandwidth problems.

Note - please limit your btest testing to a maximum of 1 to 2 minutes per test.

btest server: 207.32.195.2
User: btest
Password: btest
Thank you

North Idaho Tom Jones
3.6/1.7gbps in separate tests.
down-and-up.png
You do not have the required permissions to view the files attached to this post.
 
rbobbitt
just joined
Posts: 1
Joined: Mon Nov 10, 2008 6:25 pm

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Aug 30, 2017 5:05 pm

Tom,

First: Thank you for the Outstanding service that you are providing to the Mikrotik community!

Now to my problem.

Do you have any IP's blocked at the firewall?
When I test through my 100x100 Spectrum Cable link all is well but when I test trough my 100x100 Windstream Cloud Firewall connection (via MPLS) I cannot connect.
My public IP on the Windstream service is in the 40.138.114.0 space.

Windstream says that they are made a policy that is "wide open" for my source address but I still cannot connect through them.

I've tried TCP, UDP, packet size 500 to 1500 etc.

Any ideas anyone?

Thanks,

Ray
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Aug 30, 2017 6:50 pm

Tom,

First: Thank you for the Outstanding service that you are providing to the Mikrotik community!

Now to my problem.

Do you have any IP's blocked at the firewall?
When I test through my 100x100 Spectrum Cable link all is well but when I test trough my 100x100 Windstream Cloud Firewall connection (via MPLS) I cannot connect.
My public IP on the Windstream service is in the 40.138.114.0 space.

Windstream says that they are made a policy that is "wide open" for my source address but I still cannot connect through them.

I've tried TCP, UDP, packet size 500 to 1500 etc.

Any ideas anyone?

Thanks,

Ray
Thank you for your nice reply :)

My 207.32.195.2 btest server does not have any firewalls - except for the following:
There is a rule that after a couple minutes of testing, it will auto block your IP address for about an hour. Then after the hour has elapsed, the IP address will be released.

What IP address are you testing from?
If you are able to reply promptly, I can then drop all rules , then post for you to try it. Then later re-enable my btest usage rules.

North Idaho Tom Jones
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Thu Sep 07, 2017 3:37 pm

Please -

Please , do not robo auto-btest

I see at least one auto/robo/automated btest every-20-minutes

I can understand why you would want something like this, but a robo automated btest to my 207.32.195.2 best server is not what I intended it for (especially one I see running every 20 minutes) . Also, if it auto btests during any other manual btest at the same time, the results can be incorrect because of the shared bandwidth while the two btest(s) were running at the same time.

I might be able to work with an automated 1-time-a-day after midnight my time robo btest , but I would want to know and set the schedule.

Currently, the intent is supposed to be for all mikrotik admins performing brief manual btests at any time of the day.

North Idaho Tom Jones
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sat Sep 09, 2017 2:37 am

Please ...

No robo automated btest clients to the 207.32.195.2 btest server !!!!
I see at least 4 robo btest servers auto testing to the 207.32.195.2 btest server.

I want to be a nice guy
I don't want to have to place your robo test IP address into a full blocked access to my network or my 207.32.195.2 btest server
If I have to block it, I will also publish the IP address of your robo btest IP address - and who you are.

This server is intended to be used by a physical person who is manually testing bandwidth. It is not for robo btest devices to auto-check the performance of your network every few minutes or hours or days. Please - manual btest performed by a human only.

If you need a full-time dedicated btest server for your robo test device to test to 24x7, then lets talk about a co-location server that you pay for instead of me.

Please - lets play nice :)

North Idaho Tom Jones

EDIT: Do I really need to block the following ?:
109117138222.ip73.static.mediacommerce.com.co [138.117.109.222]
inetnum: 138.117.108/22
status: allocated
aut-num: N/A
owner: Media Commerce Partners S.A
ownerid: CO-CUOC1-LACNIC
responsible: Víctor Fabián Serna Villa

EDIT: 138.117.109.222 You are now blocked.
Last edited by TomjNorthIdaho on Sat Sep 09, 2017 6:32 pm, edited 1 time in total.
 
planetcoop
Member Candidate
Member Candidate
Posts: 113
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sat Sep 09, 2017 10:05 am

I am sorry to say, i have already blocked 138.0.0.0/8 due to massive ip flooding of my btest.planetcoop.com CHR... Thanks for playing 138. I have also seen special traffic from 0.0.0.0 so i have blocked it obviously as forged traffic. I have started long term btest ip address logging and review ip address counts daily.

Sadly my block list is very long:
0.0.0.0
46.163.178.0/24
46.163.179.0/24
46.163.188.0/24
138.0.0.0/8
160.0.0.0/4
176.0.0.0/4
192.0.0.0/5
200.0.0.0/7
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Sun Sep 10, 2017 4:43 pm

TomjNorthIdaho"]
Please ...No robo automated btest clients to the 207.32.195.2 btest server !!!!


2017-09-09 138.117.109.222 - You are now blocked ( banned because of continued automated non-stop robo btesting )

2017-09-10 185.34.121.32 - You are now blocked ( banned because of continued automated non-stop robo btesting )
 
User avatar
BrianHiggins
Long time Member
Long time Member
Posts: 593
Joined: Mon Jan 16, 2006 6:07 am
Location: Norwalk, CT
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Sep 12, 2017 9:21 pm

Months ago I embedded a 10 second duration upload and download test into our web provisioning platform to assist with determining bandwidth performance when doing new installations (this generates at most less than 5 or 10 minutes of collective tests spread over the course of a month, so definitely not abuse levels!), and noticed today that the planetcoop test server (50.235.23.218) isn't accepting any connections, and when I manually tried the 207.32.195.2 server, it blocked me after about 2 minutes from running the first download test, before I could conduct a upload test.

Would an update on the current status and details on the rules you are both applying be possible? Really appreciate having the tools available, but need to know the limits and availability on using it.
-Brian

http://www.aditumims.com
Complete web based ISP in-a-box solution, designed specifically for Multi-Tenant properties, works great for WISPs too.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Tue Sep 12, 2017 11:50 pm

Months ago I embedded a 10 second duration upload and download test into our web provisioning platform to assist with determining bandwidth performance when doing new installations (this generates at most less than 5 or 10 minutes of collective tests spread over the course of a month, so definitely not abuse levels!), and noticed today that the planetcoop test server (50.235.23.218) isn't accepting any connections, and when I manually tried the 207.32.195.2 server, it blocked me after about 2 minutes from running the first download test, before I could conduct a upload test.

Would an update on the current status and details on the rules you are both applying be possible? Really appreciate having the tools available, but need to know the limits and availability on using it.
I would guess that planetcoop and myself are willing to consider almost anything that benefits all Mikrotik admins, providing the item being considered does not have a negative effect on the btest servers.

However, prior to considering other options, please note - at this time :
- planetcoop and myself are wanting to avoid the use of automated robo client btest servers.
- planetcoop and myself are saying that the use of manual human-at-the-controls-in-real-time client btest are permitted.

One possibly important item I discovered recently that needs some research to be verified is the following:

- Last week I wrote up my own in-house robo-client btest application which would sequence one-at-a-time through several hundred of my Mikrotik clients and have them perform robo-btest(s) to my 207.32.195.2 btest server. I was using a Linux server with a telnet/ssh expect script to Mikrotik clients using the CLI which would login into each client Mikrotik and have them perform UDP download speed tests.
- What I discovered (possibly a bug), is that after the time allocated in the btest command, and after the Linux telnet/ssh expect script /quit the connection, the 207.32.195.2 btest server would sometimes still continue the UDP btest send to the client Mikrotik (even after the client btest time allocated had expired and the remote login had logged-out). The result was a continued btest that would not-stop and would continue running indefinitely. When sequencing one-at-a-time through about 50 client Mikrotiks, I could end up with 3 to 10 btest that would continue running non-stop long after the expect script to the client had timed-out the btest, waited a minute then logged out.
- The logs on the remote client Mikrotik used to initiate the btest session did show the login and the logout - however - after the logout and the log showing the logout, the btest still continued to run.
- I suspect this may be a bug

For this reason (and my past statements in this forum) , I am asking the Mikrotik admin community to please not use robo-automated-btest sessions to the btest servers.
When a human is at the controls, this condition is easily identifiable and correctable. If this happens with a robo-automated-btest client to a btest server, the effects can possibly saturate networks and make the results of other Mikrotik admins performing a btest to the same server give skewed bandwidth results (and also have a lasting effect on my network until each problem client is rebooted or the btest server is rebooted).
I suspect I may off seen this many times with multiple long-time-btest sessings that appeared to never stop. If I remember correctly, (prior to some additional rules), I had seen some btest sessions running non-stop for several days.

Thank you

North Idaho Tom Jones
 
User avatar
BrianHiggins
Long time Member
Long time Member
Posts: 593
Joined: Mon Jan 16, 2006 6:07 am
Location: Norwalk, CT
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Sep 13, 2017 12:14 am

Just to be clear, my implementation is done only upon one of our admins clicking the test bandwidth button inside the web admin console they use to manage their hardware, and it's hard coded to run only a single 10 second test up, followed by a single 10 second test down, it then disables the test button once it's been ran once. They would have to exit and re-enter that configuration screen to be able to run it a 2nd time. so while it's automated in the sense that it is launched programmatically through the hardware, it is initiated and requested by an admin.

Before test is ran:
before testing.PNG
After test is ran:
After test.PNG
You do not have the required permissions to view the files attached to this post.
-Brian

http://www.aditumims.com
Complete web based ISP in-a-box solution, designed specifically for Multi-Tenant properties, works great for WISPs too.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Topic Author
Posts: 880
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: Public-Mikrotik-Bandwidth-Test-Server(s)

Wed Sep 13, 2017 1:03 am

Just to be clear, my implementation is done only upon one of our admins clicking the test bandwidth button inside the web admin console they use to manage their hardware, and it's hard coded to run only a single 10 second test up, followed by a single 10 second test down, it then disables the test button once it's been ran once. They would have to exit and re-enter that configuration screen to be able to run it a 2nd time. so while it's automated in the sense that it is launched programmatically through the hardware, it is initiated and requested by an admin.

Before test is ran:
before testing.PNG

After test is ran:
After test.PNG
So much to think about. My brain hurts - lol

My robo-testing to my 207.32.195.2 btest server was initiated from a remote Linux computer. What I discovered is that when using any "duration=" value on even a single client Mikrotik would sometimes start the non-stop continuous btest.

I tried and tested a few hundred variants of the line below many times to a single Mikrotik and to many Mikrotiks (in a sequence one-after-another) and I was able to randomly repeat the problem.
/tool bandwidth-test 207.32.195.2 duration=15 protocol=udp direction=receive without-paging interval=00:00:05 remote-tx-speed=27500000

This was in a my Linux sh script as shown below ( sh ./Script-Name.sh a.b.c.d )
#
host=$1
#
echo > logfile.txt
#
/usr/bin/expect <<EOF | tee TEMP-FILE-Results.txt > ./Results-Directory/$1
spawn telnet $host
expect "Login"
send "admin+c132we\r"
expect "Password"
#
send "ClientMtikPassword\r"
expect "command"
expect ">"
#sleep 1
send "..\r"
#sleep 1
send "..\r"
#sleep 1
send "..\r"
expect ">"
send "/tool bandwidth-test 207.32.195.2 duration=15 protocol=udp direction=receive without-paging interval=00:00:05 remote-tx-speed=27500000\r"
--- Note - login & password not shown in above line ---
sleep 60
expect ">"
#
send "/quit\r"
expect eof


I tested hundreds of variants of this script and discovered that at random, the btest session would not terminate and would even continue after the telnet/ssh script has logged out of the client Mikrotik.
The random problem may of appeared to happen more often on weaker/worse/more-distant client Mikrotiks.

Until I get an understanding of what is happening, I do ask to please not use any script initiated btest sessions.

Thank you

North Idaho Tom Jones

Who is online

Users browsing this forum: rimelis and 51 guests