Community discussions

MikroTik App
 
mstead
Member Candidate
Member Candidate
Topic Author
Posts: 113
Joined: Sat Mar 04, 2006 2:41 am

Proxy-ARP And Public IP's Over A LAN

Sat Aug 26, 2006 3:38 am

Hi guys,

I am trying to route a block of public IP's over a private LAN. The following is a diagram of what I am trying to achieve:

Image

I can use the public IP on the 10.14.0.0/24 subnet. However I would like to use it on the 10.14.5.128/26 subnet. I enabled Proxy-ARP on interfaces B & C thinking this would work. However when I try to set interface D to ANY of the public IP's interface C responds to the ARP request saying the IP is already in use - which is most definitely NOT!

The laptop is set to use IP of 87.198.198.201, mask of 255.255.255.128 and gateway of 87.198.198.254.


Any thoughts or suggestions anyone?

Regards,

Malcolm
 
Gerard
Trainer
Trainer
Posts: 336
Joined: Wed Apr 26, 2006 4:21 am
Location: Kentucky, USA
Contact:

Sat Aug 26, 2006 6:00 am

I'm pretty sure for proxy arp to work your MT Router 2 needs to have an IP on the subnet that you wan to proxy arp for.. Try adding an 87.198.198.128/25 ip to Interface C on MT Router 2..

-Gerard
 
jarosoup
Long time Member
Long time Member
Posts: 600
Joined: Sun Aug 22, 2004 9:02 am

Sat Aug 26, 2006 9:21 pm

For this to work, you need to add a route statement on Router 2 for your client with a gateway of the inside Router 2 address and a destination /32 of your intended client IP:

/ip route add destination=87.198.198.201/32 gateway=10.14.5.190

Since you've got a hop in the middle, you might need to try a different gateway. Note that when you do this, it'll take a few seconds for things to start working.

Who is online

Users browsing this forum: Bing [Bot], ivanfm, martinclaro, VanceG and 108 guests