Community discussions

MikroTik App
 
User avatar
VoicehostSupport
just joined
Topic Author
Posts: 10
Joined: Thu Jan 28, 2016 11:53 am

Steam VPN Streaming!

Fri Feb 05, 2016 4:11 pm

Has anyone got steam streaming over VPN to work between two mikrotiks?

And if so, what config did you use?
 
User avatar
lordkappa
Member Candidate
Member Candidate
Posts: 133
Joined: Wed May 16, 2012 1:53 pm
Location: Vancouver, Canada

Re: Steam VPN Streaming!

Fri Feb 05, 2016 9:40 pm

The discovery of local steam clients is done using broadcasts. You'd have to be using a single flat ip range and a TAP VPN setup.
 
quickes
just joined
Posts: 2
Joined: Thu Dec 28, 2017 9:50 am

Re: Steam VPN Streaming!

Wed Mar 28, 2018 11:47 am

HI!
I make worked configuration for streaming over internet with mikrotik.
I have two mikrotik with fixed wan ip.
home network LAN: 192.168.10.0/24 WAN: 85.x.x.x
remote network LAN: 192.168.0.0/24 WAN: 213.x.x.x
Between mikrotik's wan I make eoip with vlan and add vlan into LAN bridge.
HOME settings:
# make base eoip vpn
/interface eoip
add clamp-tcp-mss=no local-address=85.x.x.x mac-address=02:51:90:C4:xx:xx name=eoip-vpn remote-address=213.x.x.x tunnel-id=0
# add vlan 14 with smaller MTU on vpn interface, all 192.168.10.0/24 traffic into vpn will be marked
/interface vlan
add arp=proxy-arp interface=eoip-spark mtu=1400 name=vlan17 vlan-id=17
# add vlan into local network bridge with DHCP server, remote devices can take local ip addresses.
/interface bridge port
add bridge=LAN interface=vlan17

REMOTE settings:
# add bridge for grouping home interfaces
/interface bridge
add name=HOME
# make vpn
/interface eoip
add clamp-tcp-mss=no local-address=213.x.x.x mac-address=02:6F:41:37:xx:xx name=eoip-home remote-address=85.x.x.x tunnel-id=0
/interface vlan
add arp=proxy-arp interface=eoip-home mtu=1400 name=vlan-home vlan-id=17
add interface=LAN mtu=1400 name=vlan_vm vlan-id=15
# add interfaces to HOME bridge
/interface bridge port
add bridge=LAN interface=ether10
add bridge=HOME interface=vlan-home
add bridge=HOME interface=vlan_vm

Variant 1)
I take vlan 17 from home over VPN and mark as vlan 15 into remote local network bridge.
On remote computer add vlan 15 over main network connection with dhcp client (debian os used as Steam client)
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 40:a8:f0:3f:74:57 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.21/24 brd 192.168.0.255 scope global dynamic eno1
3: vhome@eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1400 qdisc noqueue state UP group default qlen 1000
link/ether 40:a8:f0:3f:74:57 brd ff:ff:ff:ff:ff:ff
inet 192.168.10.113/24 brd 192.168.10.255 scope global dynamic vhome
As result you have home ip on remote computer's vlan interface.

Variant 2)
You can add one interface (ether10 for example) into HOME bridge and connect computer into this port.
You device will take home ip address and all traffice will go over vpn into home, as you device will be connected to home router.

Warning! MTU = 1400 on all vlan interfaces for working without packet drops.

All done, you can start steam app and stream you games over internet.

Sorry for my bad english, my primary language is Russian. If you have question, you can write me quick.es@gmail.com.
 
anav
Forum Guru
Forum Guru
Posts: 3637
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: Steam VPN Streaming!

Wed Mar 28, 2018 7:44 pm

I read, cant remember where that EOIP and GRE were excellent for multicast streaming as there were no restrictions............
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)

Who is online

Users browsing this forum: kakaxa, MSN [Bot] and 35 guests