Community discussions

 
uberdome
newbie
Topic Author
Posts: 34
Joined: Fri Oct 31, 2014 5:50 pm

Queue Not Limiting Download

Fri Feb 12, 2016 9:56 pm

With "Use IP Firewall" enabled, I often run a simple queue on a port. Periodically, that queue will only limit upload, not download.

I just moved a port that was running correctly (with a queue applied to that port) from one bridge to another. Now that queue only works on upload, not download.

I created a new queue with the same parameters, but it still does not work correctly.

Is there a specific order in which to add a port to a bridge and then add a queue?

Thank you,
Chris
 
Revelation
Member
Member
Posts: 338
Joined: Fri Dec 25, 2015 5:59 am

Re: Queue Not Limiting Download

Sat Feb 13, 2016 1:45 am

Not sure how the rest of your config works.... Here's an example that I threw together where I can limit the download and upload of a specific IP behind my Mikrotik using simple queues.
Flags: X - disabled, I - invalid, D - dynamic 
 0 XI  name="Test" target=10.10.25.66/32 parent=none packet-marks="" priority=8/8 queue=default-small/default-small 
      limit-at=0/0 max-limit=512k/512k burst-limit=768k/768k burst-threshold=768k/768k burst-time=10s/10s
 
uberdome
newbie
Topic Author
Posts: 34
Joined: Fri Oct 31, 2014 5:50 pm

Re: Queue Not Limiting Download

Sat Feb 13, 2016 10:27 am

I'm limiting the speed on a port-by-port basis. I've generally had trouble with port speed queues, but I thought I had the issue resolved. It has been working correctly for months. All I changed was the bridge the port was connected to.

This is a queue that was functioning:
/queue simple
add limit-at=10M/10M max-limit=10100k/10100k name=TH-5M target=\
    ether2-TH-Service
The only connection to this port is through a bridge. I changed the bridge port, and now the download is unlimited on the queue, even though the queue has not changed.

I've tried re-entering the queue, but it does not help.
 
uberdome
newbie
Topic Author
Posts: 34
Joined: Fri Oct 31, 2014 5:50 pm

Re: Queue Not Limiting Download

Wed Feb 17, 2016 4:18 pm

BUG?

I got the queue to work. This is on an RB750 running bugfix v6.32.4.

This does not work, and only limits upload:
/queue simple
add max-limit=10100k/10100k name=queue1 target=ether2
This does work, and limits both upload and download correctly:
/queue simple
add max-limit=10100k/10100k name=queue1 target=ether2,0.0.0.0/0
If I check in WinBox, the queue now shows two targets. BUT, in the CLI, printing the queues and the configuration export only shows ether2. Is there something I'm missing here?
 
flynno
Member Candidate
Member Candidate
Posts: 241
Joined: Wed Aug 27, 2014 8:11 pm

Re: Queue Not Limiting Download

Wed Feb 17, 2016 9:29 pm

Have you tried with bridge ip firewall disabled?
 
uberdome
newbie
Topic Author
Posts: 34
Joined: Fri Oct 31, 2014 5:50 pm

Re: Queue Not Limiting Download

Wed Feb 17, 2016 10:53 pm

Have you tried with bridge ip firewall disabled?
The queue does not function at all with "Use IP Firewall" disabled.
 
flynno
Member Candidate
Member Candidate
Posts: 241
Joined: Wed Aug 27, 2014 8:11 pm

Re: Queue Not Limiting Download

Fri Feb 19, 2016 4:35 pm

Have you tried to remove the port from the bridge?

I use a simple que

/queue simple
add max-limit=1M/5M name=queue1 target=ether1-gateway
 
uberdome
newbie
Topic Author
Posts: 34
Joined: Fri Oct 31, 2014 5:50 pm

Re: Queue Not Limiting Download

Fri Feb 19, 2016 8:46 pm

Have you tried to remove the port from the bridge?
I have not. I need the bridge for my system to function correctly (specifically with IP usage, I cannot dedicate a /30 to each port I need to limit).
 
flynno
Member Candidate
Member Candidate
Posts: 241
Joined: Wed Aug 27, 2014 8:11 pm

Re: Queue Not Limiting Download

Sat Feb 20, 2016 10:35 pm

Disable Bridge

Interfaces> "Select Ether Port" >General
Master Port > "Select Port to make master" to bridge ports you want to bridge this way

That's how I sorted the Queue problem on my metal
You do not have the required permissions to view the files attached to this post.
 
facubertran
just joined
Posts: 22
Joined: Sat Sep 24, 2016 4:18 pm

Re: Queue Not Limiting Download

Sun Sep 03, 2017 4:09 am

Hi, Could you find the solution?
 
User avatar
tomasi
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Fri Oct 03, 2014 6:40 pm
Location: Brazil
Contact:

Re: Queue Not Limiting Download

Thu Aug 30, 2018 5:22 pm

Same bug here:

Queue over ether3 only controls upload:

Image

Who is online

Users browsing this forum: MSN [Bot] and 45 guests