Community discussions

MUM Europe 2020
 
User avatar
Here4U
just joined
Topic Author
Posts: 20
Joined: Thu Feb 04, 2016 5:50 pm

Connecting to inside servers fails

Sat Feb 20, 2016 1:35 pm

I will try to explain what i mean, since i dont remember what the function is called.

Inside my lan i have some services (ip camera and some other services).
These are forwarded in the routeros and works well from the outside, but If im on the lan connecting to my WAN ip:port i cant access them, i assume that im missing a nat rule, but not sure. There are no firewall rulles blocking anything.

In example my WAN ip is 84.212.4.56 and i have a device on the lan side on 172.16.239.7, If i connect my iPad to 4G and connect to 84.212.4.56 port 88 i can access my ip camera, If i disconnect from 4G and connect to my wifi. And try to access 84.212.4.56 port 88 i cant reach it. But If i connect to the physical lan ip of the ip camera It works fine.

So to be able to access my ip cameras now i have to change the settings in ip cam viewer depending on if im remote or local.

Any suggestions?
 
kiaunel
Member Candidate
Member Candidate
Posts: 211
Joined: Mon Jul 21, 2014 7:59 pm
Location: Romania

Re: Connecting to inside servers fails

Sat Feb 20, 2016 2:05 pm

I think you need Hairpin NAT :http://wiki.mikrotik.com/wiki/Hairpin_NAT
You need to nat your inside packets
/ip firewall nat
add chain=srcnat src-address=172.16.239.0/24 \
dst-address=172.16.239.7 protocol=tcp dst-port=80 \
out-interface=LAN action=masquerade

Who is online

Users browsing this forum: MSN [Bot] and 78 guests