Community discussions

 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Slow speeds from CRS125

Fri Mar 11, 2016 1:38 am

Hello everyone,
I am posting here because I need some help.
On a small client I do work for, I installed a Mikrotik CRS125.
They get their internet from a cable-internet provider, using an Arris TG862 modem.

The problem is:
When plugging my laptop via ethernet directly to the Arris modem, I get 88 Mbps download and 4 Mbps upload.
Which is really good.
Image

If I then plug in the Mikrotik CRS125 into the Arris modem, then plug the laptop into one of the ethernet ports of the CRS, I get horrible internet speed -- 2.9 Mbps down, 3.8 upload.
Image

I attach the configuration of the CRS125 below.
There are a couple of things I have tried.

I tried to setup the Arris TG862 as "bridged".
In the Arris I:
turned off the Firewall
DHCP server
set NAT mode as "Bridged"
went into the "WAN" setup and disabled DHCP

I then plug in the Mikrotik CRS125 into eth1 of the Arris, and give it a go.
Still get those horrible upload speeds.
Image

I followed two instruction sets (pretty similar) to configure the Arris as Bridged, and try to not interfere with the connection (no NAT, no Firewall, etc.)
One of the instructions is the last post in this forum thread.
And another set (almost the same) is this video walk-through in YouTube.

Another test I did was to disable all the firewall rules I had set in the CRS125... the speed went up slightly (I think 8.0 Mbps download), yet still way below what it should be.

I copy/paste below the "export" of the Mikrotik CRS125 with the FW rules in-place and enabled.
Then below the CRS125 export with the FW rules disabled.

Here below the copy/paste of the config with the FW rules in-place and enabled.
[admin@MikroTik] > export
# mar/10/2016 18:05:58 by RouterOS 6.27
# software id = DE10-SLCQ
#
/interface bridge
add admin-mac= auto-mac=no name=bridge-local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-ht-above disabled=no distance=indoors frequency=auto l2mtu=2290 mode=ap-bridge ssid=theSSID \
    wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local name=ether5-slave-local
set [ find default-name=ether6 ] master-port=ether2-master-local name=ether6-slave-local
set [ find default-name=ether7 ] master-port=ether2-master-local name=ether7-slave-local
set [ find default-name=ether8 ] master-port=ether2-master-local name=ether8-slave-local
set [ find default-name=ether9 ] master-port=ether2-master-local name=ether9-slave-local
set [ find default-name=ether10 ] master-port=ether2-master-local name=ether10-slave-local
set [ find default-name=ether11 ] master-port=ether2-master-local name=ether11-slave-local
set [ find default-name=ether12 ] master-port=ether2-master-local name=ether12-slave-local
set [ find default-name=ether13 ] master-port=ether2-master-local name=ether13-slave-local
set [ find default-name=ether14 ] master-port=ether2-master-local name=ether14-slave-local
set [ find default-name=ether15 ] master-port=ether2-master-local name=ether15-slave-local
set [ find default-name=ether16 ] master-port=ether2-master-local name=ether16-slave-local
set [ find default-name=ether17 ] master-port=ether2-master-local name=ether17-slave-local
set [ find default-name=ether18 ] master-port=ether2-master-local name=ether18-slave-local
set [ find default-name=ether19 ] master-port=ether2-master-local name=ether19-slave-local
set [ find default-name=ether20 ] master-port=ether2-master-local name=ether20-slave-local
set [ find default-name=ether21 ] master-port=ether2-master-local name=ether21-slave-local
set [ find default-name=ether22 ] master-port=ether2-master-local name=ether22-slave-local
set [ find default-name=ether23 ] master-port=ether2-master-local name=ether23-slave-local
set [ find default-name=ether24 ] name=ether24-slave-local
set [ find default-name=sfp1 ] master-port=ether2-master-local name=sfp1-slave-local
/ip neighbor discovery
set ether1-gateway discover=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys wpa-pre-shared-key= wpa2-pre-shared-key=
/ip pool
add name=default-dhcp ranges=192.168.50.4-192.168.50.240
add name=PublicWiFi ranges=192.168.100.100-192.168.100.225
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge-local name=default
add address-pool=PublicWiFi disabled=no interface=ether24-slave-local name=PublicWiFi
/port
set 0 name=serial0
/queue simple
add burst-time=10s/10s max-limit=1M/2M name=InternalWiFi target=wlan1
add max-limit=512k/2M name=PublicWiFi target=192.168.100.0/24 time=0s-1d,sun,mon,tue,wed,thu,fri,sat
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.50.1/24 comment="default configuration" interface=ether2-master-local network=192.168.50.0
add address=192.168.100.1/24 interface=ether24-slave-local network=192.168.100.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
/ip dhcp-server lease
add address=192.168.50.26 client-id=1:70:71:bc:ac:f6:73 mac-address= server=default
add address=192.168.50.4 client-id=1:34:17:eb:cb:30:a3 mac-address= server=default
add address=192.168.50.15 client-id=1:34:17:eb:ce:5a:3f mac-address= server=default
add address=192.168.50.7 client-id=1:d0:50:99:25:50:1f mac-address= server=default
add address=192.168.50.5 client-id=1:0:23:ae:9f:84:3 mac-address= server=default
add address=192.168.50.17 client-id=1:34:17:eb:c9:f6:11 mac-address= server=default
add address=192.168.50.13 client-id=1:f4:b7:e2:c1:9d:1b mac-address= server=default
/ip dhcp-server network
add address=192.168.50.0/24 comment="default configuration" dns-server=192.168.50.1 gateway=192.168.50.1
add address=192.168.100.0/24 dns-server=192.168.100.1 gateway=192.168.100.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.50.1 name=router
/ip firewall filter
add action=drop chain=input comment="Public WiFi block everything coming into the Mikrotik's .50.1" dst-address=192.168.50.1 src-address=192.168.100.0/24
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established,related
add action=drop chain=input comment="default configuration" in-interface=ether1-gateway
add chain=forward comment="default configuration" connection-state=established,related
add action=drop chain=forward comment="default configuration" connection-state=invalid
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat connection-state=new in-interface=ether1-gateway
add action=drop chain=forward comment="Public WiFi block everything coming into the office 192.168.50.0/24 network." dst-address=192.168.50.0/24 src-address=\
    192.168.100.0/24
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" out-interface=ether1-gateway
/system clock
set time-zone-name=America/Puerto_Rico
/system routerboard settings
set protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=ether6-slave-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=ether11-slave-local
add interface=ether12-slave-local
add interface=ether13-slave-local
add interface=ether14-slave-local
add interface=ether15-slave-local
add interface=ether16-slave-local
add interface=ether17-slave-local
add interface=ether18-slave-local
add interface=ether19-slave-local
add interface=ether20-slave-local
add interface=ether21-slave-local
add interface=ether22-slave-local
add interface=ether23-slave-local
add interface=ether24-slave-local
add interface=sfp1-slave-local
add interface=wlan1
add interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=ether6-slave-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=ether11-slave-local
add interface=ether12-slave-local
add interface=ether13-slave-local
add interface=ether14-slave-local
add interface=ether15-slave-local
add interface=ether16-slave-local
add interface=ether17-slave-local
add interface=ether18-slave-local
add interface=ether19-slave-local
add interface=ether20-slave-local
add interface=ether21-slave-local
add interface=ether22-slave-local
add interface=ether23-slave-local
add interface=ether24-slave-local
add interface=sfp1-slave-local
add interface=wlan1
add interface=bridge-local
[admin@MikroTik] > 
The config of the Mikrotik CRS125 with the FW rules disabled.
[admin@MikroTik] > export
# mar/10/2016 18:08:41 by RouterOS 6.27
# software id = DE10-SLCQ
#
/interface bridge
add admin-mac= auto-mac=no name=bridge-local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=\
    20/40mhz-ht-above disabled=no distance=indoors frequency=auto l2mtu=2290 \
    mode=ap-bridge ssid=theSSID wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=\
    ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=\
    ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local name=\
    ether5-slave-local
set [ find default-name=ether6 ] master-port=ether2-master-local name=\
    ether6-slave-local
set [ find default-name=ether7 ] master-port=ether2-master-local name=\
    ether7-slave-local
set [ find default-name=ether8 ] master-port=ether2-master-local name=\
    ether8-slave-local
set [ find default-name=ether9 ] master-port=ether2-master-local name=\
    ether9-slave-local
set [ find default-name=ether10 ] master-port=ether2-master-local name=\
    ether10-slave-local
set [ find default-name=ether11 ] master-port=ether2-master-local name=\
    ether11-slave-local
set [ find default-name=ether12 ] master-port=ether2-master-local name=\
    ether12-slave-local
set [ find default-name=ether13 ] master-port=ether2-master-local name=\
    ether13-slave-local
set [ find default-name=ether14 ] master-port=ether2-master-local name=\
    ether14-slave-local
set [ find default-name=ether15 ] master-port=ether2-master-local name=\
    ether15-slave-local
set [ find default-name=ether16 ] master-port=ether2-master-local name=\
    ether16-slave-local
set [ find default-name=ether17 ] master-port=ether2-master-local name=\
    ether17-slave-local
set [ find default-name=ether18 ] master-port=ether2-master-local name=\
    ether18-slave-local
set [ find default-name=ether19 ] master-port=ether2-master-local name=\
    ether19-slave-local
set [ find default-name=ether20 ] master-port=ether2-master-local name=\
    ether20-slave-local
set [ find default-name=ether21 ] master-port=ether2-master-local name=\
    ether21-slave-local
set [ find default-name=ether22 ] master-port=ether2-master-local name=\
    ether22-slave-local
set [ find default-name=ether23 ] master-port=ether2-master-local name=\
    ether23-slave-local
set [ find default-name=ether24 ] name=ether24-slave-local
set [ find default-name=sfp1 ] master-port=ether2-master-local name=\
    sfp1-slave-local
/ip neighbor discovery
set ether1-gateway discover=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
    dynamic-keys wpa-pre-shared-key= wpa2-pre-shared-key=
/ip pool
add name=default-dhcp ranges=192.168.50.4-192.168.50.240
add name=PublicWiFi ranges=192.168.100.100-192.168.100.225
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge-local name=default
add address-pool=PublicWiFi disabled=no interface=ether24-slave-local name=\
    PublicWiFi
/port
set 0 name=serial0
/queue simple
add burst-time=10s/10s disabled=yes max-limit=1M/2M name=InternalWiFi target=\
    wlan1
add disabled=yes max-limit=512k/2M name=PublicWiFi target=192.168.100.0/24 \
    time=0s-1d,sun,mon,tue,wed,thu,fri,sat
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.50.1/24 comment="default configuration" interface=\
    ether2-master-local network=192.168.50.0
add address=192.168.100.1/24 interface=ether24-slave-local network=\
    192.168.100.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=\
    no interface=ether1-gateway
/ip dhcp-server lease
add address=192.168.50.26 client-id=1:70:71:bc:ac:f6:73 mac-address=\
    70:71:BC:AC:F6:73 server=default
add address=192.168.50.4 client-id=1:34:17:eb:cb:30:a3 mac-address=\
    34:17:EB:CB:30:A3 server=default
add address=192.168.50.15 client-id=1:34:17:eb:ce:5a:3f mac-address=\
    34:17:EB:CE:5A:3F server=default
add address=192.168.50.7 client-id=1:d0:50:99:25:50:1f mac-address=\
    D0:50:99:25:50:1F server=default
add address=192.168.50.5 client-id=1:0:23:ae:9f:84:3 mac-address=\
    00:23:AE:9F:84:03 server=default
add address=192.168.50.17 client-id=1:34:17:eb:c9:f6:11 mac-address=\
    34:17:EB:C9:F6:11 server=default
add address=192.168.50.13 client-id=1:f4:b7:e2:c1:9d:1b mac-address=\
    F4:B7:E2:C1:9D:1B server=default
/ip dhcp-server network
add address=192.168.50.0/24 comment="default configuration" dns-server=\
    192.168.50.1 gateway=192.168.50.1
add address=192.168.100.0/24 dns-server=192.168.100.1 gateway=192.168.100.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.50.1 name=router
/ip firewall filter
add action=drop chain=input comment=\
    "Public WiFi block everything coming into the Mikrotik's .50.1" disabled=\
    yes dst-address=192.168.50.1 src-address=192.168.100.0/24
add chain=input comment="default configuration" disabled=yes protocol=icmp
add chain=input comment="default configuration" connection-state=\
    established,related disabled=yes
add action=drop chain=input comment="default configuration" disabled=yes \
    in-interface=ether1-gateway
add chain=forward comment="default configuration" connection-state=\
    established,related disabled=yes
add action=drop chain=forward comment="default configuration" \
    connection-state=invalid disabled=yes
add action=drop chain=forward comment="default configuration" \
    connection-nat-state=!dstnat connection-state=new disabled=yes \
    in-interface=ether1-gateway
add action=drop chain=forward comment="Public WiFi block everything coming int\
    o the office 192.168.50.0/24 network." disabled=yes dst-address=\
    192.168.50.0/24 src-address=192.168.100.0/24
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
    out-interface=ether1-gateway
/system clock
set time-zone-name=America/Puerto_Rico
/system routerboard settings
set protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=ether6-slave-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=ether11-slave-local
add interface=ether12-slave-local
add interface=ether13-slave-local
add interface=ether14-slave-local
add interface=ether15-slave-local
add interface=ether16-slave-local
add interface=ether17-slave-local
add interface=ether18-slave-local
add interface=ether19-slave-local
add interface=ether20-slave-local
add interface=ether21-slave-local
add interface=ether22-slave-local
add interface=ether23-slave-local
add interface=ether24-slave-local
add interface=sfp1-slave-local
add interface=wlan1
add interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=ether6-slave-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=ether11-slave-local
add interface=ether12-slave-local
add interface=ether13-slave-local
add interface=ether14-slave-local
add interface=ether15-slave-local
add interface=ether16-slave-local
add interface=ether17-slave-local
add interface=ether18-slave-local
add interface=ether19-slave-local
add interface=ether20-slave-local
add interface=ether21-slave-local
add interface=ether22-slave-local
add interface=ether23-slave-local
add interface=ether24-slave-local
add interface=sfp1-slave-local
add interface=wlan1
add interface=bridge-local
[admin@MikroTik] > 
Where am I messing up?
Any help?
How can I get the Mikrotik CRS125 to take advantage of speed the Arris is providing?

Eagerly awaiting for your feedback!
Thank you!
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: Slow speeds from CRS125

Fri Mar 11, 2016 4:39 am

Try disabling any simple queues and changing the WAN port interface queue type as per http://forum.mikrotik.com/viewtopic.php?t=103542
MTCNA, MTCWE, MTCRE, MTCTCE, MTCSE, MTCINE, Trainer
___________________
Mikrotik Distributor - New Zealand
http://www.campbell.co.nz
 
darkprocess
Member Candidate
Member Candidate
Posts: 253
Joined: Fri Mar 20, 2015 1:16 pm

Slow speeds from CRS125

Fri Mar 11, 2016 3:10 pm

Strange. My crs125 provides 500Mbs have you tried the default configuration?
 
mpreissner
Member
Member
Posts: 356
Joined: Tue Mar 11, 2014 11:16 pm
Location: Columbia, MD

Re: Slow speeds from CRS125

Fri Mar 11, 2016 3:34 pm

You should definitely be able to push more than 20 mbps through NAT, but remember, the CRS is designed primarily as a switch, not a router, so you're only going to get so much out of it at layer 3.
Michael Preissner
CISSP, CCSP, CEH, PMP
 
User avatar
alexvdbaan
Trainer
Trainer
Posts: 38
Joined: Sun Feb 22, 2015 12:12 pm
Location: Amsterdam, Netherlands
Contact:

Re: Slow speeds from CRS125

Fri Mar 11, 2016 3:44 pm

You can find the solution here: http://forum.mikrotik.com/viewtopic.php?t=92711#p463429

You need to change your queue type settings from from only-hardware-queue to default-ethernet. That will do the trick, good luck

Alex
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Fri Mar 11, 2016 4:21 pm

But on the other side the only hardware queue should be the one that supports the fasttrack...
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Fri Mar 11, 2016 10:26 pm

So far, I have changed the Queue type (Queues --> Interface Queues) on ether2-master-local to "ethernet-default".

The download is still very slow (3.2 Mpbs).
I then also changed ether1-gateway to queue type "ethernet-default", and the download is still slow (3.4 Mbps).

Looking now to see if I downgrade to 6.32.4 (as per this post), via downloading it from Mikrotik's Downloads page.

Will update soon.

=====
Update:
With ether1-dateway set with Queue Type as "ethernet-default", and ether2-master-local set as "only-hardware-queue", the download speed now runs at 22 Mbps

Much better than before.

Still not the 88 Mbps that the Arris modem is pushing, yet definitely improved.

I still have not done a "downgrade" to version 6.32.4... do you guys think I should give it a try?

Thank you!

=====
One more update:
Well, without any changes, the download is now running at 32.4 Mbps


If you guys have any additional feedback and suggestions, please let me know!
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: Slow speeds from CRS125

Mon Mar 14, 2016 11:23 pm

I would check the MTU and MSS of your WAN too - just to be sure......

1. download MTUPATH.EXE ( http://www.iea-software.com/products/mtupath.cfm ) and see what the results for MSS are;

2. download MTUROUTE.EXE (http://www.elifulkerson.com/projects/mturoute.php ) and see what it finds

It may be a VLAN is present at the ARRIS reducing your WAN to 1492 instead of 1500 and causing fragmentation ?
MTCNA, MTCWE, MTCRE, MTCTCE, MTCSE, MTCINE, Trainer
___________________
Mikrotik Distributor - New Zealand
http://www.campbell.co.nz
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: Slow speeds from CRS125

Mon Mar 14, 2016 11:43 pm

Smells like bufferbloat, try forcing the Arris to 100Mbps Full Duplex.. As well as the MikroTik ofcourse.

You could also configure auto negotiation to only advertise 100Mbps Full Duplex.

Best regards,

Menno
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Tue Mar 15, 2016 12:09 am

Thanks for the help!
Here are the results for mturoute:
Image

And here is the mtupath results:
Image
I would check the MTU and MSS of your WAN too - just to be sure......

1. download MTUPATH.EXE ( http://www.iea-software.com/products/mtupath.cfm ) and see what the results for MSS are;

2. download MTUROUTE.EXE (http://www.elifulkerson.com/projects/mturoute.php ) and see what it finds

It may be a VLAN is present at the ARRIS reducing your WAN to 1492 instead of 1500 and causing fragmentation ?
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Tue Mar 15, 2016 12:11 am

Smells like bufferbloat, try forcing the Arris to 100Mbps Full Duplex.. As well as the MikroTik ofcourse.

You could also configure auto negotiation to only advertise 100Mbps Full Duplex.
Can I force this from the Mikrotik?

The Arris' interface does not have a lot of options... and I haven't seen an option for Full Duplex, etc.

Thank you!
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: Slow speeds from CRS125

Tue Mar 15, 2016 12:18 am

Smells like bufferbloat, try forcing the Arris to 100Mbps Full Duplex.. As well as the MikroTik ofcourse.

You could also configure auto negotiation to only advertise 100Mbps Full Duplex.
Can I force this from the Mikrotik?

The Arris' interface does not have a lot of options... and I haven't seen an option for Full Duplex, etc.


Thank you!
If you run a recent RouterOS, you should be able to control what speeds you are advertising.. Its under the 'Ethernet' tab under the interface connected to the Arris. Just advertise 100full only and see of it helps :D

Menno
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: Slow speeds from CRS125

Tue Mar 15, 2016 12:23 am

Thanks for the help!
Here are the results for mturoute:
Image

And here is the mtupath results:
Image
I would check the MTU and MSS of your WAN too - just to be sure......

1. download MTUPATH.EXE ( http://www.iea-software.com/products/mtupath.cfm ) and see what the results for MSS are;

2. download MTUROUTE.EXE (http://www.elifulkerson.com/projects/mturoute.php ) and see what it finds

It may be a VLAN is present at the ARRIS reducing your WAN to 1492 instead of 1500 and causing fragmentation ?
One theory down :? At least we know it's not that :)
MTCNA, MTCWE, MTCRE, MTCTCE, MTCSE, MTCINE, Trainer
___________________
Mikrotik Distributor - New Zealand
http://www.campbell.co.nz
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: Slow speeds from CRS125

Tue Mar 15, 2016 12:24 am

Smells like bufferbloat, try forcing the Arris to 100Mbps Full Duplex.. As well as the MikroTik ofcourse.

You could also configure auto negotiation to only advertise 100Mbps Full Duplex.
Can I force this from the Mikrotik?

The Arris' interface does not have a lot of options... and I haven't seen an option for Full Duplex, etc.


Thank you!
If you run a recent RouterOS, you should be able to control what speeds you are advertising.. Its under the 'Ethernet' tab under the interface connected to the Arris. Just advertise 100full only and see of it helps :D

Menno
Ps. Only use this as a workaround, when you for some reason want to force certain speeds, you should try your best in forcing it on both devices. When that's not possible, you can resort to this mentioned 'procedure' :D
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Tue Mar 15, 2016 12:26 am

If you run a recent RouterOS, you should be able to control what speeds you are advertising.. Its under the 'Ethernet' tab under the interface connected to the Arris. Just advertise 100full only and see of it helps :D

Menno
Ok!
Did that... Went into ether1-gateway, Ethernet tab... and checkmark ON only on 100M full.

Download speed tests are showing as:
18.6 Mbps download, 4.3 Mbps upload
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Tue Mar 15, 2016 12:27 am

[*]
One theory down :? At least we know it's not that :)
Yes!
And thank you for the help!
I greatly appreciate it.
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: Slow speeds from CRS125

Tue Mar 15, 2016 12:35 am

If you run a recent RouterOS, you should be able to control what speeds you are advertising.. Its under the 'Ethernet' tab under the interface connected to the Arris. Just advertise 100full only and see of it helps :D

Menno
Ok!
Did that... Went into ether1-gateway, Ethernet tab... and checkmark ON only on 100M full.

Download speed tests are showing as:
18.6 Mbps download, 4.3 Mbps upload
Thanks for your reply, no bufferbloat here then..

Just for the sake of .... can you put a switch between the Arris and the MT? Just a dumb one would do..
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Tue Mar 15, 2016 1:34 am

Just for the sake of .... can you put a switch between the Arris and the MT? Just a dumb one would do..
I have one if these guys - Linksys wrt120n
Image

Will that work?
I have left the client's physical offices for the day... yet I hope to be back tomorrow.

How would you connect this small switch?

-----
Now I am thinking that maybe, for testing, setup the CRS125 to just be a switch, and have the Arris hand-out IPs (DHCP serveR).

What do you guys think?
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: Slow speeds from CRS125

Tue Mar 15, 2016 9:22 am

Just for the sake of .... can you put a switch between the Arris and the MT? Just a dumb one would do..
I have one if these guys - Linksys wrt120n
Image

Will that work?
I have left the client's physical offices for the day... yet I hope to be back tomorrow.

How would you connect this small switch?

-----
Now I am thinking that maybe, for testing, setup the CRS125 to just be a switch, and have the Arris hand-out IPs (DHCP serveR).

What do you guys think?
Oh no ;), don't you have a small real switch or something?, this will only complicate things :D .. a normal 'dumb' switch will do in this case.

I doubt letting the Arris do the DHCP etc will help, what you are doing should be totally possible. Can you see high CPU on the CRS whilst downloading/speedtesting?

Best regards,

Menno
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Tue Mar 15, 2016 1:50 pm

Hello Menno,
The other equipment I have is a Mikrotik RG951, and a hub (not a switch).

I haven't paid attention to the CPU as I do the speed tests.
Will do a test today in the afternoon and report back.

I am thinking that maybe I messed-up something in the CRS125 when I initally configured it. Maybe to factory-scratch it and try again would be worthwhile.

Will report back asap.
Thank you!
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Tue Mar 15, 2016 11:56 pm

Hello everyone,
Sorry to do a "bump"... yet any other suggestions to try on this network?
I am still getting "slow" speeds when I connect via the CRS125, versus via the Arris modem directly.

All ideas are welcomed!
 
darkprocess
Member Candidate
Member Candidate
Posts: 253
Joined: Fri Mar 20, 2015 1:16 pm

Slow speeds from CRS125

Wed Mar 16, 2016 12:05 am

Have you imported you last config ? If yes i suggest a reset config without importîg your config.
I m having 700Mbps with mine.
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 12:09 am

Have you imported you last config ? If yes i suggest a reset config without importîg your config.
I m having 700Mbps with mine.
When you say "imported last config"...
Do you mean to save it to a file?

And you suggestion is to:
Factory reset the CRS125, and then try again?

I am going to try that tomorrow (factory reset), as I am becoming desperate with these speeds.
 
darkprocess
Member Candidate
Member Candidate
Posts: 253
Joined: Fri Mar 20, 2015 1:16 pm

Slow speeds from CRS125

Wed Mar 16, 2016 1:02 am

Is the default config that you are running or a customized?
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 1:04 am

Is the default config that you are running or a customized?
Customized
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: Slow speeds from CRS125

Wed Mar 16, 2016 1:34 pm

Hi!,

please do a export verbose (strip the sensitive stuff) and post the output here, maybe we can see something wrong.

Can't you get a switch from anywhere to see if that helps?, i renember a issue i had some time ago.. the 2 NIC's did not like each other and it could only be solved with a switch in between :D

Best regards,

Menno
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 3:40 pm

Thanks for the help mennowz!
please do a export verbose (strip the sensitive stuff) and post the output here, maybe we can see something wrong.
I will post it in a couple of hours, when I am on-site with the client!

Can't you get a switch from anywhere to see if that helps?, i renember a issue i had some time ago.. the 2 NIC's did not like each other and it could only be solved with a switch in between :D
The only switches I have is the Linksys mentioned above, and the Mikrotik RB951.

Will those help?
Can the RB951 be configured ... as a "dumb" switch?

Thank you!
 
User avatar
munkitkat
just joined
Posts: 7
Joined: Wed Mar 09, 2016 3:14 pm

Re: Slow speeds from CRS125

Wed Mar 16, 2016 3:57 pm

You need to change your queue type settings from from only-hardware-queue to default-ethernet. That will do the trick, good luck :)
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 4:24 pm

You need to change your queue type settings from from only-hardware-queue to default-ethernet. That will do the trick, good luck :)
I tried that on the master ethernet, and the one going to the Arris router.

Still slow speeds.

Do I have to change the Queue type of all the interfaces to "default-ethernet"?

Thank you for the help!
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: Slow speeds from CRS125

Wed Mar 16, 2016 5:29 pm

Thanks for the help mennowz!
please do a export verbose (strip the sensitive stuff) and post the output here, maybe we can see something wrong.
I will post it in a couple of hours, when I am on-site with the client!

Can't you get a switch from anywhere to see if that helps?, i renember a issue i had some time ago.. the 2 NIC's did not like each other and it could only be solved with a switch in between :D
The only switches I have is the Linksys mentioned above, and the Mikrotik RB951.

Will those help?
Can the RB951 be configured ... as a "dumb" switch?

Thank you!
Hi!,

not sure if the RB951 will solve it,.. you can configure it to bridge all ports though.. You could try the Linksys to act as a switch (disable DHCP!). Just a tip : Buy a simple 8 ports switch (e.g. HP or something), i always carry one with me to sort these issues out :)

Let us know !

Menno
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 5:34 pm

I just changed the Interface Queues.
Queues --> Queue List --> Interface Queueus
I set as "ethernet default" on:
ether1-gateway
ether2-master-local
ether4-slave-local (where I have connected my laptop)

I ran a speed test on my laptop, and still got 19Mbps download and 4.2 Mbps upload.
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 5:36 pm

When I logged into the CRS125 right now, I went to Terminal to do an export.

The terminal displayed these messages on the top:
mar/10/2016 17:25:29 dhcp,critical,error dhcp-client on ether1-gateway lost IP add
ress 192.168.50.2 - received NAK from dhcp server 192.168.0.1
mar/14/2016 18:08:46 system,error,critical login failure for user anonymous from 1
92.168.50.27 via ftp
mar/14/2016 18:08:46 system,error,critical login failure for user anonymous from 1
92.168.50.27 via ftp
mar/14/2016 18:23:42 system,error,critical login failure for user anonymous from 1
92.168.50.27 via ftp
mar/14/2016 18:24:12 system,error,critical login failure for user anonymous from 1
92.168.50.27 via ftp
mar/16/2016 07:41:56 dhcp,critical,error dhcp-client on ether1-gateway lost IP add
ress 192.168.0.2 - received NAK from dhcp server 192.168.0.1
Anything I should be concerned about there?
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 5:42 pm

And here is an export of the current configuration
[admin@MikroTik] > export
# mar/16/2016 11:31:14 by RouterOS 6.27
# software id = DE10-SLCQ
#
/interface bridge
add admin-mac=E4:8D:8C:A1:EC:97 auto-mac=no name=bridge-local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-ht-above disabled=no distance=indoors frequency=auto l2mtu=2290 mode=ap-bridge ssid=theSSID \
    wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] advertise=100M-full name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local name=ether5-slave-local
set [ find default-name=ether6 ] master-port=ether2-master-local name=ether6-slave-local
set [ find default-name=ether7 ] master-port=ether2-master-local name=ether7-slave-local
set [ find default-name=ether8 ] master-port=ether2-master-local name=ether8-slave-local
set [ find default-name=ether9 ] master-port=ether2-master-local name=ether9-slave-local
set [ find default-name=ether10 ] master-port=ether2-master-local name=ether10-slave-local
set [ find default-name=ether11 ] master-port=ether2-master-local name=ether11-slave-local
set [ find default-name=ether12 ] master-port=ether2-master-local name=ether12-slave-local
set [ find default-name=ether13 ] master-port=ether2-master-local name=ether13-slave-local
set [ find default-name=ether14 ] master-port=ether2-master-local name=ether14-slave-local
set [ find default-name=ether15 ] master-port=ether2-master-local name=ether15-slave-local
set [ find default-name=ether16 ] master-port=ether2-master-local name=ether16-slave-local
set [ find default-name=ether17 ] master-port=ether2-master-local name=ether17-slave-local
set [ find default-name=ether18 ] master-port=ether2-master-local name=ether18-slave-local
set [ find default-name=ether19 ] master-port=ether2-master-local name=ether19-slave-local
set [ find default-name=ether20 ] master-port=ether2-master-local name=ether20-slave-local
set [ find default-name=ether21 ] master-port=ether2-master-local name=ether21-slave-local
set [ find default-name=ether22 ] master-port=ether2-master-local name=ether22-slave-local
set [ find default-name=ether23 ] master-port=ether2-master-local name=ether23-slave-local
set [ find default-name=ether24 ] name=ether24-slave-local
set [ find default-name=sfp1 ] master-port=ether2-master-local name=sfp1-slave-local
/ip neighbor discovery
set ether1-gateway discover=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys wpa-pre-shared-key= wpa2-pre-shared-key=
/ip pool
add name=dhcp ranges=192.168.50.4-192.168.50.240
add name=PublicWiFi ranges=192.168.100.100-192.168.100.225
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge-local name=default
add address-pool=PublicWiFi disabled=no interface=ether24-slave-local name=PublicWiFi
/port
set 0 name=serial0
/queue simple
add burst-time=10s/10s disabled=yes max-limit=1M/2M name=InternalWiFi target=wlan1
add disabled=yes max-limit=512k/2M name=PublicWiFi target=192.168.100.0/24 time=0s-1d,sun,mon,tue,wed,thu,fri,sat
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.50.1/24 comment="default configuration" interface=ether2-master-local network=192.168.50.0
add address=192.168.100.1/24 interface=ether2-master-local network=192.168.100.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
/ip dhcp-server lease
add address=192.168.50.26 client-id=1:70:71:bc:ac:f6:73 mac-address=70:71:BC:AC:F6:73 server=default
add address=192.168.50.4 client-id=1:34:17:eb:cb:30:a3 mac-address=34:17:EB:CB:30:A3 server=default
add address=192.168.50.15 client-id=1:34:17:eb:ce:5a:3f mac-address=34:17:EB:CE:5A:3F server=default
add address=192.168.50.7 client-id=1:d0:50:99:25:50:1f mac-address=D0:50:99:25:50:1F server=default
add address=192.168.50.5 client-id=1:0:23:ae:9f:84:3 mac-address=00:23:AE:9F:84:03 server=default
add address=192.168.50.17 client-id=1:34:17:eb:c9:f6:11 mac-address=34:17:EB:C9:F6:11 server=default
add address=192.168.50.13 client-id=1:f4:b7:e2:c1:9d:1b mac-address=F4:B7:E2:C1:9D:1B server=default
/ip dhcp-server network
add address=192.168.50.0/24 comment="default configuration" dns-server=192.168.50.1 gateway=192.168.50.1
add address=192.168.100.0/24 dns-server=192.168.100.1 gateway=192.168.100.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.50.1 name=router
/ip firewall filter
add action=drop chain=input comment="Public WiFi block everything coming into the Mikrotik's .50.1" dst-address=192.168.50.1 src-address=192.168.100.0/24
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established,related
add action=drop chain=input comment="default configuration" in-interface=ether1-gateway
add chain=forward comment="default configuration" connection-state=established,related
add action=drop chain=forward comment="default configuration" connection-state=invalid
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat connection-state=new in-interface=ether1-gateway
add action=drop chain=forward comment="Public WiFi block everything coming into the office 192.168.50.0/24 network." dst-address=192.168.50.0/24 src-address=\
    192.168.100.0/24
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" out-interface=ether1-gateway
/queue interface
set ether1-gateway queue=ethernet-default
set ether2-master-local queue=ethernet-default
/system clock
set time-zone-name=America/Puerto_Rico
/system routerboard settings
set protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=ether6-slave-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=ether11-slave-local
add interface=ether12-slave-local
add interface=ether13-slave-local
add interface=ether14-slave-local
add interface=ether15-slave-local
add interface=ether16-slave-local
add interface=ether17-slave-local
add interface=ether18-slave-local
add interface=ether19-slave-local
add interface=ether20-slave-local
add interface=ether21-slave-local
add interface=ether22-slave-local
add interface=ether23-slave-local
add interface=ether24-slave-local
add interface=sfp1-slave-local
add interface=wlan1
add interface=bridge-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2-master-local
add interface=ether3-slave-local
add interface=ether4-slave-local
add interface=ether5-slave-local
add interface=ether6-slave-local
add interface=ether7-slave-local
add interface=ether8-slave-local
add interface=ether9-slave-local
add interface=ether10-slave-local
add interface=ether11-slave-local
add interface=ether12-slave-local
add interface=ether13-slave-local
add interface=ether14-slave-local
add interface=ether15-slave-local
add interface=ether16-slave-local
add interface=ether17-slave-local
add interface=ether18-slave-local
add interface=ether19-slave-local
add interface=ether20-slave-local
add interface=ether21-slave-local
add interface=ether22-slave-local
add interface=ether23-slave-local
add interface=ether24-slave-local
add interface=sfp1-slave-local
add interface=wlan1
add interface=bridge-local
[admin@MikroTik] > 
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 5:45 pm

And I have the Mikrotik CRS125 connected to the Arris modem via eth1:
Image
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Wed Mar 16, 2016 5:51 pm

Try testing without the bridge.
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 5:56 pm

Try testing without the bridge.
Ok,
I just went into Bridge --> selected the bridge, and Disabled it.

Re-tested, yet I am still getting 17.5 Mbps download 4.2 Mbps upload.

Thank your for the suggestion Vortex!
I am going to have to come back later today, as I have to leave on-site.
Yet I will bring with me a RB951, and test it with the Arris modem.
Lets see if there is any difference in performance!
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 7:10 pm

Just realized that the CRS125 is running version 6.27
So when I go back today I will update it to 6.34.3

Hoping that helps the situation somehow.
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: Slow speeds from CRS125

Wed Mar 16, 2016 9:39 pm

Lot of things going on,

I see some weird DHCP errors, almost looks like there is some interconnect somehow between the 50.x and 0.x network.

Sure, upgrades to latest stable is no bad idea, don't forget to upgrade the Routerboar firmware as well.

Keep us updated :D
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:12 pm

Update to Bugfix first, not to Current.
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:18 pm

Ok!
I'm going to upgrade to 6.32.4 (Bugfix) first, and then 6.34.3.

Yet... something interesting:
I connected my laptop to the CRS125 via WiFi.
I did the upload of the 6.32.4 package via drag-n-drop...
And the speeds (4 feet away from the CRS125) are super slow.

Uploading those 10 MBs took about a minute...
And the CRS125's processor was not high/moving... it was idling.

Image

Isn't this odd?
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:21 pm

If everything is ok with Bugfix, there's no need to move further.
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:25 pm

If everything is ok with Bugfix, there's no need to move further.
Ahh ok... I will leave it there then.
Right now, I just finished the upgrade to 6.32.4, then ran a speed test (just after the router came backup after its upgrade), and the download speed is:
52.6 Mbps... which is pretty good!
Not 89 Mbps... yet good progress.

Image
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:34 pm

Now add fasttrack
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:34 pm

Ok... and now it's downloading at 26.2 Mbps.
I don't understand what is going on.

Next test, I am going to setup a small switch I got as mennowz suggested.
I am placing the small Netgear 10/100 switch between the Arris and the CRS125.
Will report back the speed tests shortly...

-=----
And now I'm getting 17.7 Mbps download.
And got 28.2 Mbps download in a 2nd test.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:36 pm

Are you testing against a server in the ISP network?
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:38 pm

Are you testing against a server in the ISP network?
I don't think so.
I am using the testmy.net website.

I will now remove the Netgear switch in between the CRS125 and the Arris modem...
And add Fasttrack.

Will report back shortly.

===
Update:
Ok, I added fasttrack as follows:
IP --> Firewall --> New Rule
Chain: Forward
Advanced Tab --> Destination Address List: 0.0.0.0/0
Action: Fasttrack connection
Last edited by creativeliquid on Wed Mar 16, 2016 11:43 pm, edited 1 time in total.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:43 pm

Try ookla
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:46 pm

Try ookla
Well, with Ookla it definitely runs as it should!
Image

What do you guys think?
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:49 pm

Thin pipe, overloaded server, prime time.
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:52 pm

Thin pipe, overloaded server, prime time.
Although the package this office pays for is 90Mbps download... so I will take 87 Mbps happily.

Yet still don't understand why testmy.net was so slow.

Yet happy the CRS125 is performing as it should now.

I wonder if I can break all this by putting the Arris modem in Bridge mode...
And as any good geek, I can't leave good-enough alone.

Let me see what happens when I switch the Arris to bridge mode.
... brb
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:55 pm

I was mentioning what was probably happening with your other test.

A wild guess would be that the server is not even on the island.
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Wed Mar 16, 2016 11:59 pm

I was mentioning what was probably happening with your other test.

A wild guess would be that the server is not even on the island.
Awesome awesome!

Thank you!
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Thu Mar 17, 2016 12:00 am

You can pick servers all around the world with ookla. Automatically, it tries to choose a good one close to you.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Thu Mar 17, 2016 12:31 am

Maybe the other website sometimes connected you to servers onshore and other times offshore.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Thu Mar 17, 2016 12:34 am

You fasttracked only established connections right?
 
creativeliquid
newbie
Topic Author
Posts: 49
Joined: Fri Sep 25, 2015 2:23 am

Re: Slow speeds from CRS125

Thu Mar 17, 2016 12:44 am

You fasttracked only established connections right?
Yes.
Established and related (??).
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: Slow speeds from CRS125

Thu Mar 17, 2016 1:01 am

OK.

Bridge will probably be fine.
 
cybfox
just joined
Posts: 1
Joined: Fri Jun 08, 2018 11:16 pm

Re: Slow speeds from CRS125

Fri Jun 08, 2018 11:19 pm

Hi,
Was anxiously following this thread to find solution to similar problem... what happened ?
cheers. (hi Menno!)

Who is online

Users browsing this forum: MSN [Bot] and 111 guests