Community discussions

MikroTik App
 
diegopiazza
just joined
Topic Author
Posts: 1
Joined: Thu Mar 24, 2016 8:44 am

Huawei ME909s-120 not recognized

Thu Mar 24, 2016 8:50 am

Hi,
I have 2 Huawei ME909s-120 and I tried both with a RB411U and a RB912UAG but the modem is not recognized in /ports or /usb. It works with the Huawei ME909u-521 works without any problem.
ROS version is 6.28 or greater.
Any solution?
Thanks
Diego
 
servizioaudiovideo
just joined
Posts: 3
Joined: Tue Jul 16, 2013 12:30 pm

Re: Huawei ME909s-120 not recognized

Thu Apr 28, 2016 5:09 pm

I have the same problem on RB912 ROS version 6.35.1
The lte interface is recognized, but don't see any USB port.
If I activate the log "async" I see that I have no reponse on command AT+CPIN?
15:28:16 lte,async lte1: sent AT+CFUN=1 
15:28:16 lte,async lte1: rcvd OK 
15:28:16 lte,async lte1: sent AT+CPIN? 
15:28:26 lte,async lte1: no response 
15:28:26 lte,async lte1: sent AT+CFUN=0 
15:28:26 lte,async lte1: rcvd OK 
15:28:30 lte,async lte1: sent AT+CFUN=1 
15:28:30 lte,async lte1: rcvd OK 
15:28:30 lte,async lte1: sent AT+CPIN? 
15:28:40 lte,async lte1: no response 
15:28:40 lte,async lte1: sent AT+CFUN=0 
15:28:41 lte,async lte1: rcvd OK 

And /interface lte info
         pin-status: 
      functionality: 
       manufacturer: Huawei Technologies Co., Ltd.
              model: ME909s-120
           revision: 11.617.01.00.00
               imei: xxxxxxxxxxxxxxxxxxxxxx
               imsi: xxxxxxxxxxxxxxxxxxxxxx
  subscriber-number: +CNUM: "My Number","xxxxxxxxxx",129

The board work perfectly with me909u.

Any ideas?
 
buzzdee
newbie
Posts: 35
Joined: Mon Apr 22, 2013 1:22 pm

Re: Huawei ME909s-120 not recognized

Mon May 02, 2016 10:43 pm

I just configured a 912UAG-2HPnD (Basebox 2) running RouterOS 6.35.1 with a me909s-120 (Firmware Revision 11.613.03.00.00) and its working.
At first I didn't get an entry in Interface->LTE, but after switching the USB Mode as described here I could configure an APN (Interface->LTE->APN), added a dhcp-client for the lte interface and was online. After installing ROS 6.35.1 I also upgraded the Routerboard firmware (System->Routerboard->Upgrade) - don't know if that helped.
 
unterums
newbie
Posts: 32
Joined: Mon May 17, 2010 10:36 am

Re: Huawei ME909s-120 not recognized

Sat May 14, 2016 10:40 am

Hi,

i have the same Problem.

Did you fixed ist ?

BR
 
onefx
just joined
Posts: 1
Joined: Sat Apr 09, 2016 3:06 pm

Re: Huawei ME909s-120 not recognized

Thu May 19, 2016 5:02 pm

Finally got it working (without lte interface reset looping)
and without making usb power-reset on each boot
For me the working config is:
ME909s-120
fw:11.617.01.00.00
usb mode miniPCI
ROS 6.36rc13 - here just works)
ROS 6.35.1(lte not working at all,ignoring direct-ip can make ppp work)
ROS 6.35.2(thought here it is working ONCE power resetting modem for 5 secs right after boot. if lte interface goes down or signal level falls critically it hags in configuration stage and you have to reboot then power reset for at least 5 secs)
 
buzzdee
newbie
Posts: 35
Joined: Mon Apr 22, 2013 1:22 pm

Re: Huawei ME909s-120 not recognized

Thu Jun 16, 2016 1:21 pm

After a few weeks of operation, I had one of the Huawei 909s-120 go down and not reliably come up again. First updated the Huawei LTE-Card firmware  - no satisfactory result. The upgraded RouterOS to 6.38rc28. Now the LTE-Interface comes up reliably, but stops working after a few megabytes traffic (~50MB), just as reported in this thread here
RB912UAG with LTE Card Huawei ME909s-120 stop working after 50MB Traffic
 
User avatar
sergeyklenov
just joined
Posts: 9
Joined: Mon May 05, 2014 7:04 pm
Contact:

Re: Huawei ME909s-120 not recognized

Fri Jul 29, 2016 9:13 am

I have also Huawei ME909s-120 and NetMetal 5
So it didnt work, also with latests software.

I test it on 6.36r and 6.37rc5

I see only lte1 interface witch not connected.
Afrer restart lte1 interface became invisible, need repower board.
 
kristaps
Member Candidate
Member Candidate
Posts: 272
Joined: Mon Jan 27, 2014 1:37 pm

Re: Huawei ME909s-120 not recognized

Fri Jul 29, 2016 1:36 pm

@buzzdee and @ergeyklenov 

Please try final 6.36 add dhcp-client to lte1 interface 
in terminal add 

/sy log add topics=lte
and send supout.rif 


Locally we have 2 diffrent ME909s cards and we cannot replicate issue, 
 
Shaeto
just joined
Posts: 10
Joined: Sat Sep 27, 2014 11:36 pm

Re: Huawei ME909s-120 not recognized

Sun Aug 07, 2016 1:49 am

Hi, sorry i didn't manage to make supout.rif, attaching screenshot with list of resources,

me909s-120 (11.617.01.00.00) perfectly works under win10, 912UAG-2PhD does not recognize it as lte interface but seems can see it as usb device :(

router os is 6.36, firmware is 3.24
You do not have the required permissions to view the files attached to this post.
 
Shaeto
just joined
Posts: 10
Joined: Sat Sep 27, 2014 11:36 pm

Re: Huawei ME909s-120 not recognized

Sat Sep 10, 2016 7:39 pm

still not working on 6.37rc32 :( see it in usb resource but nothing in ports, can provide remote access if required for the solution, thanks!

lte module firmware is 11.617.01.00.00, mb your two test modules are running one of previous versions ?
 
hedele
Member
Member
Posts: 338
Joined: Tue Feb 24, 2009 11:23 pm

Re: Huawei ME909s-120 not recognized

Mon Sep 12, 2016 1:59 pm

I have a similar problem with the ME909s-120 on my RB912Gs - it hangs after a short period of high throughput. The lte1 interface stays up, but I don't get any more input packets. A usb power-reset fixes the problem. The issue is more pronounced when I'm using WLAN, leading me to believe that there's some sort of power consumption issue. I can usually transfer huge amounts of data through the ethernet port, but WLAN locks the LTE interface up relatively quickly and reliably.
 
newlord
just joined
Posts: 7
Joined: Sat Sep 10, 2016 12:04 am

Re: Huawei ME909s-120 not recognized

Mon Sep 12, 2016 5:47 pm

I have a similar problem with the ME909s-120 on my RB912Gs - it hangs after a short period of high throughput. The lte1 interface stays up, but I don't get any more input packets. A usb power-reset fixes the problem. The issue is more pronounced when I'm using WLAN, leading me to believe that there's some sort of power consumption issue. I can usually transfer huge amounts of data through the ethernet port, but WLAN locks the LTE interface up relatively quickly and reliably.
What version firmware your module's ME909s-120?
on my the ME909s-120 FW 11.617.01.00.00 interface lte1 does not even appear.
 
hursta
just joined
Posts: 3
Joined: Mon Sep 12, 2016 5:42 pm

Re: Huawei ME909s-120 not recognized

Mon Sep 12, 2016 5:50 pm

Same issue with HUAWEI ME909s-120 11.617.01.00.00 and RB922UAGS-5HPacD, RB953GW-5Hnt-RP boards, LTE modem not recognized (direct-ip).
I think it is time to get a fix for that, since a long time this is an open case.
 
hedele
Member
Member
Posts: 338
Joined: Tue Feb 24, 2009 11:23 pm

Re: Huawei ME909s-120 not recognized

Mon Sep 12, 2016 5:55 pm

Same. ME909s-120 on 11.617.01.00.00. Routerboard RB912UAG-2HPnD, ROS 6.32.3, Firmware 3.24
 
newlord
just joined
Posts: 7
Joined: Sat Sep 10, 2016 12:04 am

Re: Huawei ME909s-120 not recognized

Mon Sep 12, 2016 6:13 pm

Routerboard RB953GS-5HnT-RP + LTE HUAWEI ME909s-120 on 11.617.01.00.00 My topic http://forum.mikrotik.com/viewtopic.php?f=2&t=112052
If I use PCIE MINI Converted to USB the card LTE HUAWEI ME909s-120 then everything works
I have a firmware 11.611.99.12.00. I can downgrade one of my boards, If someone will give the current version to be able to refuse.
I'm sorry for my english is not my native language
 
newlord
just joined
Posts: 7
Joined: Sat Sep 10, 2016 12:04 am

Re: Huawei ME909s-120 not recognized

Mon Sep 12, 2016 7:38 pm

A friend sent me a firmware 11.617.01.00.00.
And I as promised to downgrade the firmware to version 11.611.99.12.00
She, too, does not work.
And it does not work even across use PCIE MINI Converted to USB the card
Update firmware back to version 11.617.01.00.00
At whom works this board? send exact version of the firmware.
 
kristaps
Member Candidate
Member Candidate
Posts: 272
Joined: Mon Jan 27, 2014 1:37 pm

Re: Huawei ME909s-120 not recognized

Tue Sep 13, 2016 5:44 pm

If you are experiencing issues with ME909s card in RouterOS or in RouterBoard please send us email support@mikroptik.com

Also you can try to set this setting.
/system routerboard settings set init-delay=5
 
Shaeto
just joined
Posts: 10
Joined: Sat Sep 27, 2014 11:36 pm

Re: Huawei ME909s-120 not recognized

Thu Sep 22, 2016 8:52 pm

i see 6.37rc42 is available, me909s-120 finally gets recognized and works pretty good on 912UAG (but with disabled wireless module, it seems me909s-120 need more power)
 
vacool
just joined
Posts: 9
Joined: Sat Sep 24, 2016 5:35 pm

Re: Huawei ME909s-120 not recognized

Thu Oct 06, 2016 10:50 am

Has anyone succeeded in running stable Huawei ME909s-120 with RB411U or RB912UAG?
 
Shaeto
just joined
Posts: 10
Joined: Sat Sep 27, 2014 11:36 pm

Re: Huawei ME909s-120 not recognized

Fri Oct 07, 2016 10:46 pm

yes it works really stable and fast in my 912UAG BUT only with disabled wireless (wifi) module, if i enable it me909s-120 will down every XX Mb of lte traffic
 
Debr
just joined
Posts: 1
Joined: Mon Dec 19, 2016 8:46 am

Re: Huawei ME909s-120 not recognized

Mon Dec 19, 2016 9:17 am

I have the similar problem with huawei ME909s-120 in RB411U - there is nothing in LTE interfaces. I testing several RB411U with different firmware including latest version v6.37.3. Firmware of ME909s-120 is 11.617.01.00.00.

In the same time in all tested RB411 working fine Sierra MC7710 and all tested ME909s-120 working fine in RB912UAG-2HPnD. So not working only pair RB411U + ME909s-120.

Who faced with a similar situation?
 
opkky
just joined
Posts: 4
Joined: Mon Jan 02, 2017 8:19 am

Re: Huawei ME909s-120 not recognized

Mon Jan 02, 2017 8:39 am

Colleagues,

I spent few days with Basebox2 + Huawei ME 909s-120 and found the only working solution.
I use latest ROS 6.37.3 and 11.617.01.00.00 for Huawei

I tried preconfigured LTE configuration for my setup but LTE modem was not able to register to mobile network, signal was too low.
For me the only working config is WISP AP in BRIDGE mode. In Router mode again Huawei could not register in mobile network.

Of course, I enabled mini-PCIe in System --> Routerboard --> USB.
If after restart LTE interface is not visible USB Power reset for 5 sec and system restart solves the issue.

Now when LTE interface is up and rinning I enabled
- DHCP client for LTE intterface
- DHCP server on default bridge interface
- added default route to LTE interface
- changed firewall to enable incoming traffic from LTE interface and masquerade outgoing traffic from LTE interface

After that I am able to use Basebox2 with Huawei PCI modem as wireless basestation in my house (inside and outside).

Still to be investigated how to send SMS or USSD requests in Mikrotik with Huawei modem. Need to know balance of SIM card and traffic usage.

Hope this will help somebody :-) All the best in new year.
 
ningbeheer
just joined
Posts: 6
Joined: Tue Jun 13, 2017 12:55 pm

Re: Huawei ME909s-120 not recognized

Thu Jun 15, 2017 10:21 am

Hi,

I have my RB912 running with Huawei ME909s-120. Data works great as long as i don't enable the Wlan interfaces on the same routerboard. However there is only a LTE interface and nothing shows up in ports. I am thus not able to send and receive SMS to upgrade the databundle of my provider. Anyone has an idea on how to use SMS function in combination with this Huawei LTE minipci-e device?

Thank you very much.
Last edited by ningbeheer on Thu Jun 15, 2017 10:38 am, edited 1 time in total.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3431
Joined: Mon May 31, 2004 2:55 pm

Re: Huawei ME909s-120 not recognized

Thu Jun 15, 2017 10:35 am

specify the lte1 interface in the tool sms menu. Then make sure you have lte interface in running state and then you can send and receive the messages.
 
ningbeheer
just joined
Posts: 6
Joined: Tue Jun 13, 2017 12:55 pm

Re: Huawei ME909s-120 not recognized

Thu Jun 15, 2017 10:39 am

As you can see in the screenprint there is no LTE1 interface in the SMS option. LTE and data is working fine.
Schermafbeelding 2017-06-15 om 09.38.32.PDF
You do not have the required permissions to view the files attached to this post.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3431
Joined: Mon May 31, 2004 2:55 pm

Re: Huawei ME909s-120 not recognized

Thu Jun 15, 2017 10:45 am

it is a Winbox bug, we will try to fix it. Try using console for setting that interface now.
 
ningbeheer
just joined
Posts: 6
Joined: Tue Jun 13, 2017 12:55 pm

Re: Huawei ME909s-120 not recognized

Thu Jun 15, 2017 10:57 am

it is a Winbox bug, we will try to fix it. Try using console for setting that interface now.
Indeed. Thru console it is working great. Thanks!
 
leon84
Member Candidate
Member Candidate
Posts: 186
Joined: Wed Dec 02, 2009 12:15 pm

Re: Huawei ME909s-120 not recognized

Mon Dec 04, 2017 9:05 pm

Is there someone that solved this issue on RB411U? I tried to change capacitor as suggested by Mikrotik support but nothing. The Huawei ME909s-120 is always not recognized :-(

Who is online

Users browsing this forum: eworm, Kindis and 223 guests