Community discussions

 
User avatar
Splash
Member Candidate
Member Candidate
Topic Author
Posts: 151
Joined: Fri Oct 16, 2015 10:09 am
Location: Johannesburg, South Africa

IPIP Interface always UP (Running)

Thu Mar 31, 2016 4:50 pm

I have multiple LNS (CCR) devices around the country which I use to provide full HA to our IPIP Tunnel customers.

VRRP is used between sites to allow for a single IPIP Tunnel termination configuration
BGP is used to replicate the active routes to the various VRF's

The issue is that if one creates an IPIP interface on a standby device, it is marked as Running, even though the CPE has not connected to it. This presents a problem when routes are added to the device (LNS) as BGP will in turn replicates them. This would cause routing issues on the network as all routes will be seen as active, but pointing to devices with no customers. (No failure of any devices).

Is there a way to stop the interface from being active until the CPE connects and establishes the IPIP Tunnel, or at least the routes need to remain inactive until the IPIP tunnel is actually up.
MTCNA, MTCRE, MTCINE, MTCTCE, MTCIPv6E, MTCUME
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: IPIP Interface always UP (Running)

Thu Mar 31, 2016 6:27 pm

If you enable keepalive on tunnel it will be up only if remote router is reachable.
 
User avatar
Splash
Member Candidate
Member Candidate
Topic Author
Posts: 151
Joined: Fri Oct 16, 2015 10:09 am
Location: Johannesburg, South Africa

Re: IPIP Interface always UP (Running)

Thu Mar 31, 2016 8:19 pm

Ah, I thought it was enabled by default, thanks let me give that a try!

... Looking good!

Do you have any recommendations for the Keepalive settings or will the defaults do?
MTCNA, MTCRE, MTCINE, MTCTCE, MTCIPv6E, MTCUME
 
User avatar
Splash
Member Candidate
Member Candidate
Topic Author
Posts: 151
Joined: Fri Oct 16, 2015 10:09 am
Location: Johannesburg, South Africa

Re: IPIP Interface always UP (Running)

Thu Mar 31, 2016 8:29 pm

Looking at the configuration: (without any changes between the 2 commands)
/interface ipip
add !keepalive local-address=y.y.y.y name=ipip-1 remote-address=x.x.x.x
/interface ipip
add clamp-tcp-mss=yes disabled=no dont-fragment=no dscp=inherit !ipsec-secret keepalive=10s,10 local-address=y.y.y.y mtu=auto name=ipip-1 remote-address=x.x.x.x
Interestingly, the normal export shows the keepalive as disabled, where the verbose shows it enabled?

This is why I got confused when replicating the configuration?
MTCNA, MTCRE, MTCINE, MTCTCE, MTCIPv6E, MTCUME
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: IPIP Interface always UP (Running)

Fri Apr 01, 2016 1:18 pm

Yes it is a known problem in compact export. We will try to fix this in the future.
 
User avatar
Splash
Member Candidate
Member Candidate
Topic Author
Posts: 151
Joined: Fri Oct 16, 2015 10:09 am
Location: Johannesburg, South Africa

Re: IPIP Interface always UP (Running)

Fri Apr 01, 2016 2:27 pm

Perfect! Thanks!

Good to know.
MTCNA, MTCRE, MTCINE, MTCTCE, MTCIPv6E, MTCUME

Who is online

Users browsing this forum: No registered users and 76 guests