Community discussions

MikroTik App
 
sporkman
newbie
Topic Author
Posts: 26
Joined: Thu May 02, 2013 4:37 am

Lag/jitter on OpenVPN connection

Thu Apr 07, 2016 3:49 am

We run an AWS instance and all of our routers tunnel back to this for management access and monitoring. I've been getting more and more random nagios alerts that latency to some sites (via vpn) is spiking. Results generally look like this:
35 packets transmitted, 35 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 13.560/24.161/57.467/13.832 ms
Pinging the same device directly (avoiding the VPN) at the exact same time, the ping times look more like this:
36 packets transmitted, 36 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 12.596/12.909/13.957/0.343 ms
We have 100Mb/s fiber to the Mikrotik location and we rarely use more than 20-30Mb/s. Looking at the Mikrotik profiler tool, I don't see any huge CPU usage. Additionally this seems to be pretty consistent. Even if there's no traffic in the middle of the night, that jitter and extra latency via the VPN remains.

Router is an RB2011UiAS running 6.30.2.

Anything obvious to look at?
 
R1CH
Forum Veteran
Forum Veteran
Posts: 936
Joined: Sun Oct 01, 2006 11:44 pm

Re: Lag/jitter on OpenVPN connection

Thu Apr 07, 2016 4:06 am

As far as I'm aware, OpenVPN on Mikrotik is only able to use TCP, so it's prone to latency spikes and poor performance in general as TCP is not very good as an encapsulation protocol.

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 86 guests