Community discussions

MUM Europe 2020
 
rastod
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Jun 04, 2005 11:35 pm
Location: Slovakia

How to configure OSPF routing?

Fri Sep 08, 2006 2:13 pm

Hi all, I need to configure a tool that enable keep my network working even some links are dropped. I have routed netowork with 6 main routers that are connected in a circle. There is /28 network between each two routers in order. 1-2 2-3 3-4 4-5 5-6 6-1
I suppose that OSPF is the tool.
I have read the mikrotik manual but when I configure OSFP network nothing happen, only one new route is in the routing table, it is red with flag "DI O".

Can anyone help me?
 
User avatar
Equis
Forum Veteran
Forum Veteran
Posts: 888
Joined: Mon Jun 06, 2005 6:48 am

Fri Sep 08, 2006 3:36 pm

I use winbox

add interface
add networks of each router

so if ip address of router is 192.168.0.1 add network 192.168.0.0/24

Only add networks your router can directly see
 
rastod
Member Candidate
Member Candidate
Topic Author
Posts: 122
Joined: Sat Jun 04, 2005 11:35 pm
Location: Slovakia

Fri Sep 08, 2006 4:10 pm

my configuration is:

[admin@mikrotik_apnam] routing ospf> print
router-id: xx.xx.208.22
distribute-default: never
redistribute-connected: as-type-1
redistribute-static: as-type-1
redistribute-rip: no
redistribute-bgp: no
metric-default: 1
metric-connected: 20
metric-static: 20
metric-rip: 20
metric-bgp: 20
[admin@mikrotik_apnam] routing ospf> network print
Flags: X - disabled, I - invalid
# NETWORK AREA
0 xx.xx.208.192/28 local_1
1 xx.xx.208.16/28 local_1
[admin@mikrotik_apnam] routing ospf> area print
Flags: X - disabled, I - invalid
# NAME AREA-ID STUB DEFAULT-COST AUTHENTICATION
0 backbone 0.0.0.0 none
1 local_1 0.0.0.1 no 1 none
[admin@mikrotik_apnam] routing ospf> neighbor print
router-id=xx.xx.208.22 address=xx.xx.208.22 priority=1 state="2-Way" state-changes=0 ls-retransmits=0 ls-requests=0 db-summaries=0 dr-id=xx.xx.208.22
backup-dr-id=0.0.0.0

Who is online

Users browsing this forum: No registered users and 64 guests