Community discussions

 
GuJack20
Trainer
Trainer
Topic Author
Posts: 322
Joined: Sat Jun 12, 2004 9:44 pm
Location: Tirana
Contact:

IP on a Vmware ESXi dedi

Sat Apr 23, 2016 10:52 pm

Hello

I installed RouterOS in a virtual machine in a Vmware ESXi.
I have the ip 62.x.x.x for the virtual machine. The ISP tech says that i must configure this ip 62.x.x.x with subnet mask /32 and to give as a gateway the main ip of the server but ending with 1. i.e. My server's main ip is 178.x.x.100, than the gateway of mikrotik RouterOS would be 178.x.x.1.

Such config works ok in windows hosts, but with MikroTik i get "No route to host", since the 178.x.x.1 is outside of the 62.x.x.x subnet.

How can i solve this?

Thanks guys
--Do you remember that guy who gave up? Neither does anybody else!
 
Sob
Forum Guru
Forum Guru
Posts: 4812
Joined: Mon Apr 20, 2009 9:11 pm

Re: IP on a Vmware ESXi dedi

Sat Apr 23, 2016 11:46 pm

RouterOS does it like this:
/ip address
add address=62.x.x.x network=178.x.x.1 interface=<interface>
Edit: That was just point to point addresses, second step is the actual route:
/ip route
add distance=1 gateway=178.x.x.1
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
GuJack20
Trainer
Trainer
Topic Author
Posts: 322
Joined: Sat Jun 12, 2004 9:44 pm
Location: Tirana
Contact:

Re: IP on a Vmware ESXi dedi

Sun Apr 24, 2016 12:03 am

Yeah, right. I didn't know that.

It works

Thanks bro
--Do you remember that guy who gave up? Neither does anybody else!
 
GuJack20
Trainer
Trainer
Topic Author
Posts: 322
Joined: Sat Jun 12, 2004 9:44 pm
Location: Tirana
Contact:

Re: IP on a Vmware ESXi dedi

Sun Apr 24, 2016 12:03 am

Yeah, right. I didn't know that.

It works

Thanks bro
--Do you remember that guy who gave up? Neither does anybody else!

Who is online

Users browsing this forum: No registered users and 62 guests