Community discussions

 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Strange behaviour from the RouterOS SSH server

Wed Jun 22, 2016 12:13 pm

Recently I discovered that I have the following strange behaviour on one of mine RB951 routers. When I tried to connect via SSH, I've got the following output:
Trying XXX.XXX.XX.X...
Connected to XXX.XXX.XX.X.
Escape character is '^]'.
SSH-2.0-ROSSSH
Connection closed by foreign host.

Welcome back!

Connecting via SSL works just fine. The issue was there in version 6.35.2, I upgraded to 6.35.4 and the situation is still the same. Has anyone experienced this? How can I restore the previous behaviour of the SSH server in Router OS?


Regards,
Boyan
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Strange behaviour from the RouterOS SSH server

Wed Jun 22, 2016 12:21 pm

Connecting from what kind of OS ? 
No answer to your question? How to write posts
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: Strange behaviour from the RouterOS SSH server

Wed Jun 22, 2016 12:29 pm

Connecting from what kind of OS ?
I connect from RouterOS version 6.35.2
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: Strange behaviour from the RouterOS SSH server

Wed Jun 22, 2016 12:36 pm

Normis,
I've just checked it from my Linux machine...
bsotirov@NUC-desktop:~$ uname -r
3.13.0-88-generic

It woks fine. So it's definitely dependent on the source where the SSH is initiated from...
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 908
Joined: Tue Oct 11, 2005 4:53 pm

Re: Strange behaviour from the RouterOS SSH server

Wed Jun 22, 2016 12:46 pm

Trying XXX.XXX.XX.X...
Connected to XXX.XXX.XX.X.
Escape character is '^]'.
SSH-2.0-ROSSSH
Connection closed by foreign host.

Welcome back!
What command did you run exactly?

This output is from the telnet client, not from the ssh client.
Trying to connect to SSH using telnet won't work obviously!
[cha0s@rtr-awmn-core.cha0s.awmn] > /system telnet 10.26.36.26
Trying 10.26.36.26...
Connected to 10.26.36.26.
Escape character is '^]'.
SSH-2.0-ROSSSH
Connection closed by foreign host.

Welcome back!
While using the proper command it asks for a password:
[cha0s@rtr-awmn-core.cha0s.awmn] > /system ssh address=10.26.36.26
password:
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: Strange behaviour from the RouterOS SSH server

Wed Jun 22, 2016 12:58 pm

Cha0s that's a spot on!
I mistakenly used telnet (which is disabled on the device) but I've put the correct port that is used for the SSH service. So normally this is what I get, that the port is opened.
So that's it, problem solved. Thank you so much!
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: Strange behaviour from the RouterOS SSH server

Wed Jun 22, 2016 1:00 pm

Is there a way to mark this thread as closed? The interface has changed recently...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Strange behaviour from the RouterOS SSH server

Wed Jun 22, 2016 1:30 pm

There is no special button, but you can edit the original post tile with adding [SOLVED] to it
No answer to your question? How to write posts

Who is online

Users browsing this forum: MSN [Bot] and 78 guests