Community discussions

MikroTik App
 
iGz
just joined
Topic Author
Posts: 4
Joined: Sat Jan 16, 2016 2:54 pm

Policy based routing on LAN

Sat Jun 25, 2016 11:32 pm

Hi,

I am not network guru, so please excuse me, if this is something obvious and easy to solve :)
I have configured PR based on destination IP addresses (defined address list). When user tries to access this definded IPs, he will be routed to different gateway.
I used this guide : http://wiki.mikrotik.com/wiki/Policy_Base_Routing . It works fine only when I connect to my LAN from remote location using VPN (configured on same mikrotik) and then try to access some of the defined IPs. When I am connected directly to my LAN (at home), PBR doesn't work, specificaly works only partialy when some IPs are correctly routed and some are not.
Firewall should not be blocking any connection, because I am using same segment for VPN and for LAN (just different range of /24 segment).
Am I missing something, or doing something wrong ?
Thank you.
 
andriys
Forum Guru
Forum Guru
Posts: 1395
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: Policy based routing on LAN

Sun Jun 26, 2016 12:42 pm

Why do you use policy routing at all, if your routing criteria is a destination address? Regular routing is specifically designed to solve this exact problem!
 
iGz
just joined
Topic Author
Posts: 4
Joined: Sat Jan 16, 2016 2:54 pm

Re: Policy based routing on LAN

Sun Jun 26, 2016 2:33 pm

Thank you for your reply,
I tried that, but it didn't work. I have had exactly the same result as with policy routing :(

Who is online

Users browsing this forum: attilas, DanMos79, eworm, Halfeez92 and 155 guests