Community discussions

MikroTik App
 
lynx649
newbie
Topic Author
Posts: 25
Joined: Tue May 27, 2014 5:22 am

Radius + Hotspot + MAC Cookie Problem

Fri Jul 15, 2016 2:54 am

Hello,

I am having a problem getting Mikrotik hotspot to work properly with a radius authentication server.  In short, the main problem I am having is that even when I set the MAC cookie to 5 days, if I reboot the server, I get the login page again.  I have other Mikrotiks in the field (not using radius) where if I reboot the server, the cookies are still there and noone has to log in.  Does anyone have any experience with Hotspot + Radius?  Below are some config details that might help, if you need more info or clarification, please let me know.

Thanks!

Using Radius server with:

HTTP PAP enabled
Mac Cookie enabled

MAC Cookie Timeout set to 5 days.

     
USER PROFILE:

 1   name="test" address-pool=pool10 status-autorefresh=1m shared-users=200 add-mac-cookie=yes mac-cookie-timeout=5d 
     address-list=“" transparent-proxy=no 

HOTSPOT PROFILE:
 
 0 * name="default" hotspot-address=10.0.0.2 dns-name=“local" html-directory=hotspot 
     html-directory-override="" rate-limit="2M/10M" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=http-pap,mac-cookie 
     split-user-domain=no use-radius=yes radius-accounting=yes radius-interim-update=received nas-port-type=ethernet 
     radius-default-domain="" radius-location-id="" radius-location-name="" radius-mac-format=XX:XX:XX:XX:XX:XX 

Derek
Last edited by lynx649 on Thu Jul 21, 2016 2:17 am, edited 1 time in total.
 
lynx649
newbie
Topic Author
Posts: 25
Joined: Tue May 27, 2014 5:22 am

Re: Radius + Hotspot + MAC Cookie Problem

Thu Jul 21, 2016 2:15 am

Bump
 
ropbo
just joined
Posts: 6
Joined: Mon Oct 31, 2011 4:24 am

Re: Radius + Hotspot + MAC Cookie Problem

Fri Jul 22, 2016 8:43 pm

Hi, have you found a solution? I'm having exactly the same issue, every time I reboot the server or simply restart the hotspot service, all MAC cookies disappear and people get the login page again. I set the "login by" (under Server Profile) to HTTP-PAP and MAC COOKIE. Also checked "Add Mac Cookie" (under User Profile).
 
User avatar
KeamKym
just joined
Posts: 1
Joined: Fri Jun 07, 2019 8:08 am
Location: Kenya

Re: Radius + Hotspot + MAC Cookie Problem

Sun Jul 14, 2019 2:43 pm

Hi, I got the same problem. I'm using http cookie instead, though, Im still getting 'local user not found' at least it is able to log me in.
Anyone with a better solution to help.

Who is online

Users browsing this forum: No registered users and 82 guests