Community discussions

MUM Europe 2020
 
BobcatGuy
Member Candidate
Member Candidate
Topic Author
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Fast Bandwidth Test, But Slow Real Throughput

Thu Aug 04, 2016 12:35 pm

So I have a funny problem. I have a couple wireless hops, and a flat network. I do a speed test across both wireless hops and get nice speeds. I test with 10Mbit UL and unlimited download, and get around 70 mbit. to the far location. I Like this!

However, the actual throughput I get is around 7-10 mbit, sometimes a bit higher. So I am confused as to why the speed difference is so drastic? I understand that when using a RB to do the test that uses the CPU, but this one I cannot figure out.

at the mid point between the two wireless hops I get full speed as expected in test and real throughput. Below is the se tup

CRS125 - SXT5AC ~ SXT5AC - RB2011 - DynaDish ~ RB921 Netmetal - RB2011 Tested to wired or wireless device. Internet speeds from ISP are 120 mbit

I upgraded the hardware to get a better link, and the weird part is the bandwidth test on router OS says nice high speeds but real data is horribly slow.

The network is flat, and there is no QoS rules, just NAT on the CRS 125.

Thanks!
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: Fast Bandwidth Test, But Slow Real Throughput

Thu Aug 04, 2016 12:44 pm

Are you talking about tcp or udp traffic? You should test part by part and find the bottleneck.
 
BobcatGuy
Member Candidate
Member Candidate
Topic Author
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: Fast Bandwidth Test, But Slow Real Throughput

Thu Aug 04, 2016 12:47 pm

udp traffic

The problem is when I test each segment of the ling, I get the 70mbit, while using bandwidth test in ROS, either to the mid point, or to the far end. I get the similar speeds of real data to the mid point, but not to the far end.
So as to why bandwidth test is reporting the higher speeds 70+ mbit to the far end and the real speeds are like 7 or 8 mbit I don't know. that's my problem though
 
User avatar
nickshore
Member
Member
Posts: 473
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Re: Fast Bandwidth Test, But Slow Real Throughput

Thu Aug 04, 2016 12:53 pm

Have you checked that the links are not causing interference to each other ?
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
BobcatGuy
Member Candidate
Member Candidate
Topic Author
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: Fast Bandwidth Test, But Slow Real Throughput

Thu Aug 04, 2016 12:57 pm

Yes, I have the channels as far apart as they can be, ie, 5180, and 5825. The test when done across BOTH links at the same time, ie end to end, while using routerOS bandwidthtest yield ~70mbit, across one link it is also the same, from either side to the mid point. again, even across the entire two links and that entire set up it still attains ~70mbit. ONLY in bandwidth test. Real data drops to around 7 mbit.

I also tested with a wired laptop at the far end, and using btest application, can only get around 20-23mbit udp in one direction.
 
Babek
just joined
Posts: 21
Joined: Sun Apr 03, 2011 10:02 am

Re: Fast Bandwidth Test, But Slow Real Throughput

Fri Aug 05, 2016 7:25 pm

try Btest one TCP connection (not 20 neither udp) - it works for me usually - if i get 30 Mbit in 1 TCP download - at least the same it shows on network speedtests

Who is online

Users browsing this forum: Google [Bot] and 68 guests