Community discussions

 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

PS4 One Public IP for all?

Fri Aug 05, 2016 5:43 pm

Hi all,

I have been reading through the forum, still dont find the answer...
I manage a network of about 500 clients. I have 1 public IP for the Router and some public IPs for those who requested access to the PSN. The thing is that I ran out of Public IPs, so im wondering if there is any work around to this mapping. Those the UPnP function achieve this goal?

Thanks in advance!!
Best regards,
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: PS4 One Public IP for all?

Fri Aug 05, 2016 11:26 pm

ideally would be increase pressure on Sony to speed up implementation(as 1st grade, major level) of IPv6 support for PSN and devices(not only "gaming"-labeled), made by them.
they did it(albeit very slow)for "industrial" gear they offer, but not for PS4, yet, sadly :/
 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

Re: PS4 One Public IP for all?

Mon Aug 08, 2016 2:37 am

Any suggestions??
 
diablothebest
newbie
Posts: 27
Joined: Fri May 20, 2016 11:07 pm

Re: PS4 One Public IP for all?

Mon Aug 08, 2016 11:20 pm

Please tell me - your clients talks about errors in Destiny last time?
I have same network - over 30-40 PS4 over NAT.
 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

Re: PS4 One Public IP for all?

Tue Aug 09, 2016 5:45 pm

This is my NAT, still cant join the PSN:
What's wrong?
EDIT: Its disabled, I know... It didnt work anyway so I disabled it.


61 X ;;; Mannini - DST-TCP
chain=dstnat action=dst-nat to-addresses=62.62.62.106 to-ports=0-65535
protocol=tcp dst-address=190.104.246.XXX (Routers WAN Port NOT GW IP)

62 X ;;; Mannini - DST-UDP
chain=dstnat action=dst-nat to-addresses=62.62.62.106 to-ports=0-65535
protocol=udp dst-address=190.104.246.XXX

63 X ;;; Mannini - SRC-TCP
chain=srcnat action=src-nat to-addresses=190.104.246.XXX to-ports=0-6553
protocol=tcp src-address=62.62.62.106

64 X ;;; Mannini - SRC-UDP
chain=srcnat action=src-nat to-addresses=190.104.246.XXX to-ports=0-6553
protocol=udp src-address=62.62.62.106
 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

Re: PS4 One Public IP for all?

Tue Aug 09, 2016 6:06 pm

Please tell me - your clients talks about errors in Destiny last time?
I have same network - over 30-40 PS4 over NAT.

diablothebest, not sure about the exact msg as I didnt ask. I guess its the generical Could not access network message.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: PS4 One Public IP for all?

Tue Aug 09, 2016 6:24 pm

Enable UPNP, it should solve the problem.
 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

Re: PS4 One Public IP for all?

Tue Aug 09, 2016 6:38 pm

Enable UPNP, it should solve the problem.
MRZ, its enabled:

ROUTER_CENTRAL] /ip upnp> print
enabled: yes
allow-disable-external-interface: no
show-dummy-rule: no


Should I enable the dummy-rule?
 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

Re: PS4 One Public IP for all?

Tue Aug 09, 2016 6:40 pm

Also, it looks like when it was enabled one of the admin guys couldnt access the Winbox. ??
EDIT: Afirmative, I cant access the Winbox if the nat above is enabled.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: PS4 One Public IP for all?

Tue Aug 09, 2016 7:12 pm

Write to support with attached supout file.
 
diablothebest
newbie
Posts: 27
Joined: Fri May 20, 2016 11:07 pm

Re: PS4 One Public IP for all?

Tue Aug 09, 2016 8:42 pm

I solve my problem - just changed DNS server.
 
diablothebest
newbie
Posts: 27
Joined: Fri May 20, 2016 11:07 pm

Re: PS4 One Public IP for all?

Tue Aug 09, 2016 8:46 pm

Why you make 4 rules?
Need just one rule for NAT:
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out (or ethernet-out)
 
diablothebest
newbie
Posts: 27
Joined: Fri May 20, 2016 11:07 pm

Re: PS4 One Public IP for all?

Wed Aug 10, 2016 12:52 pm

Nothing changed with Destiny!
This is game bug!
 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

Re: PS4 One Public IP for all?

Sun Aug 14, 2016 3:36 am

Why you make 4 rules?
Need just one rule for NAT:
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out (or ethernet-out)
At first I created only the masquerade then one rule, the two and then all of them but no luck.
 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

Re: PS4 One Public IP for all?

Mon Aug 22, 2016 3:21 pm

Hi all,

Any update on this?
Still cant make it work.
Does anyone have this rule set?
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: PS4 One Public IP for all?

Wed Aug 24, 2016 12:32 am

as long as game didn't support "slightly different" port (in some range) choice(to override manually in config files of it)instead of default - nope, there isn't any.
using UPNP only make issues instant, instead of ~ activity-based(even more for static port forwarding).not sure about PMP or PCP(both not not implemented yet not only in ROS, but most other brands).
 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

Re: PS4 One Public IP for all?

Mon Aug 29, 2016 1:28 am

So we all agree this is a bug on MT but no action were taken from MT at all?
Im expecting MT to jump in, please!
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: PS4 One Public IP for all?

Mon Aug 29, 2016 8:17 am

How it could be a bug if you are running out of the ip addresses?
 
d3tonador
just joined
Topic Author
Posts: 20
Joined: Sat Jun 25, 2016 4:07 pm

Re: PS4 One Public IP for all?

Tue Aug 30, 2016 4:51 am

How it could be a bug if you are running out of the ip addresses?
Because I tried all the configuration possible but no luck, I cant get it to work.
I have asked many times, I posted the command lines I used but no answer. and I see some other people have the same issue.
How can I get it to work? is it possible at all, one public I for all the PS3/4?

Thanks in advance!
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: PS4 One Public IP for all?

Tue Aug 30, 2016 8:21 am

It's about general principle how ipv4 works. You should use ipv6 if the game supports it or ask a game developers to issue an update that enables using multiple port mapping by upnp /nat. Its not mikrotik's fault that the Playstation has such limitation.

Who is online

Users browsing this forum: No registered users and 135 guests