Page 1 of 1

PS4 One Public IP for all?

Posted: Fri Aug 05, 2016 5:43 pm
by d3tonador
Hi all,

I have been reading through the forum, still dont find the answer...
I manage a network of about 500 clients. I have 1 public IP for the Router and some public IPs for those who requested access to the PSN. The thing is that I ran out of Public IPs, so im wondering if there is any work around to this mapping. Those the UPnP function achieve this goal?

Thanks in advance!!
Best regards,

Re: PS4 One Public IP for all?

Posted: Fri Aug 05, 2016 11:26 pm
by Zorro
ideally would be increase pressure on Sony to speed up implementation(as 1st grade, major level) of IPv6 support for PSN and devices(not only "gaming"-labeled), made by them.
they did it(albeit very slow)for "industrial" gear they offer, but not for PS4, yet, sadly :/

Re: PS4 One Public IP for all?

Posted: Mon Aug 08, 2016 2:37 am
by d3tonador
Any suggestions??

Re: PS4 One Public IP for all?

Posted: Mon Aug 08, 2016 11:20 pm
by diablothebest
Please tell me - your clients talks about errors in Destiny last time?
I have same network - over 30-40 PS4 over NAT.

Re: PS4 One Public IP for all?

Posted: Tue Aug 09, 2016 5:45 pm
by d3tonador
This is my NAT, still cant join the PSN:
What's wrong?
EDIT: Its disabled, I know... It didnt work anyway so I disabled it.


61 X ;;; Mannini - DST-TCP
chain=dstnat action=dst-nat to-addresses=62.62.62.106 to-ports=0-65535
protocol=tcp dst-address=190.104.246.XXX (Routers WAN Port NOT GW IP)

62 X ;;; Mannini - DST-UDP
chain=dstnat action=dst-nat to-addresses=62.62.62.106 to-ports=0-65535
protocol=udp dst-address=190.104.246.XXX

63 X ;;; Mannini - SRC-TCP
chain=srcnat action=src-nat to-addresses=190.104.246.XXX to-ports=0-6553
protocol=tcp src-address=62.62.62.106

64 X ;;; Mannini - SRC-UDP
chain=srcnat action=src-nat to-addresses=190.104.246.XXX to-ports=0-6553
protocol=udp src-address=62.62.62.106

Re: PS4 One Public IP for all?

Posted: Tue Aug 09, 2016 6:06 pm
by d3tonador
Please tell me - your clients talks about errors in Destiny last time?
I have same network - over 30-40 PS4 over NAT.

diablothebest, not sure about the exact msg as I didnt ask. I guess its the generical Could not access network message.

Re: PS4 One Public IP for all?

Posted: Tue Aug 09, 2016 6:24 pm
by mrz
Enable UPNP, it should solve the problem.

Re: PS4 One Public IP for all?

Posted: Tue Aug 09, 2016 6:38 pm
by d3tonador
Enable UPNP, it should solve the problem.
MRZ, its enabled:

ROUTER_CENTRAL] /ip upnp> print
enabled: yes
allow-disable-external-interface: no
show-dummy-rule: no


Should I enable the dummy-rule?

Re: PS4 One Public IP for all?

Posted: Tue Aug 09, 2016 6:40 pm
by d3tonador
Also, it looks like when it was enabled one of the admin guys couldnt access the Winbox. ??
EDIT: Afirmative, I cant access the Winbox if the nat above is enabled.

Re: PS4 One Public IP for all?

Posted: Tue Aug 09, 2016 7:12 pm
by mrz
Write to support with attached supout file.

Re: PS4 One Public IP for all?

Posted: Tue Aug 09, 2016 8:42 pm
by diablothebest
I solve my problem - just changed DNS server.

Re: PS4 One Public IP for all?

Posted: Tue Aug 09, 2016 8:46 pm
by diablothebest
Why you make 4 rules?
Need just one rule for NAT:
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out (or ethernet-out)

Re: PS4 One Public IP for all?

Posted: Wed Aug 10, 2016 12:52 pm
by diablothebest
Nothing changed with Destiny!
This is game bug!

Re: PS4 One Public IP for all?

Posted: Sun Aug 14, 2016 3:36 am
by d3tonador
Why you make 4 rules?
Need just one rule for NAT:
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out (or ethernet-out)
At first I created only the masquerade then one rule, the two and then all of them but no luck.

Re: PS4 One Public IP for all?

Posted: Mon Aug 22, 2016 3:21 pm
by d3tonador
Hi all,

Any update on this?
Still cant make it work.
Does anyone have this rule set?

Re: PS4 One Public IP for all?

Posted: Wed Aug 24, 2016 12:32 am
by Zorro
as long as game didn't support "slightly different" port (in some range) choice(to override manually in config files of it)instead of default - nope, there isn't any.
using UPNP only make issues instant, instead of ~ activity-based(even more for static port forwarding).not sure about PMP or PCP(both not not implemented yet not only in ROS, but most other brands).

Re: PS4 One Public IP for all?

Posted: Mon Aug 29, 2016 1:28 am
by d3tonador
So we all agree this is a bug on MT but no action were taken from MT at all?
Im expecting MT to jump in, please!

Re: PS4 One Public IP for all?

Posted: Mon Aug 29, 2016 8:17 am
by jarda
How it could be a bug if you are running out of the ip addresses?

Re: PS4 One Public IP for all?

Posted: Tue Aug 30, 2016 4:51 am
by d3tonador
How it could be a bug if you are running out of the ip addresses?
Because I tried all the configuration possible but no luck, I cant get it to work.
I have asked many times, I posted the command lines I used but no answer. and I see some other people have the same issue.
How can I get it to work? is it possible at all, one public I for all the PS3/4?

Thanks in advance!

Re: PS4 One Public IP for all?

Posted: Tue Aug 30, 2016 8:21 am
by jarda
It's about general principle how ipv4 works. You should use ipv6 if the game supports it or ask a game developers to issue an update that enables using multiple port mapping by upnp /nat. Its not mikrotik's fault that the Playstation has such limitation.