Community discussions

 
phtan
just joined
Topic Author
Posts: 3
Joined: Sat Aug 20, 2016 1:03 pm

VPN PPTP ANDROID

Tue Aug 23, 2016 5:43 pm

hi


Scenario 1;
Refer to the http://forum.mikrotik.com/viewtopic.php?t=52479
My case is almost similar with it.
My Samsung (android OS) cant connect to the VPN pptp as created. But all my pc/notebook and iphone work wells.


including
/ppp profile add local-address=PPTP-pool name=pptp-test remote-address=PPTP-pool use-encryption=required /ppp secret set phtan profile=pptp-test

If that does not help, then test after this:
/interface pptp-server server set mtu=1400 mru=1400


please help,
i had done alot of configuration, yet it still not working.
 
dboreham
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Sat May 03, 2008 4:17 pm

Re: VPN PPTP ANDROID

Wed Aug 24, 2016 4:40 am

I think you will need to investigate the log output on the server, and/or packet sniff the traffic to figure out why it isn't working, but Samsung Android in general does interoperate with the RouterOS pptp implementation. I have it working with my Samsung devices.
 
peterbuttler
just joined
Posts: 1
Joined: Thu Sep 01, 2016 2:21 pm

Re: VPN PPTP ANDROID

Thu Sep 01, 2016 2:46 pm

Setting Up a PPTP VPN on Android device has a different way from ios. Android has already introduced a built-in VPN connection tool which allows you to connect PPTP VPNS, L2TP VPNs, L2TP/IPSec PSK VPNs, and L2TP/IPSec CRT VPNs.

Jack Wallen wrote an article on TechRepublic Setup Guide of PPTP VPN on Android

http://www.techrepublic.com/blog/smartp ... oid-phone/
http://www.vpnlogics.com/best-vpn-for-android/

Following are the main steps to setup PPTP VPN for Android devices.

Notes about this tutorial
  • Microsoft supports PPTP VPN and it is very common. The set up for each type of VPN will change.
    Please note this process will change on different phones.
Necessary information

For the PPTP connection, you'll need to find the following information before starting the setup process:
  • VPN IP address
    VPN account login details
    Find out if your VPN requires encryption.
    Once you complete the information, you can begin the setup.
 
idlemind
Forum Guru
Forum Guru
Posts: 1067
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: VPN PPTP ANDROID

Sat Feb 09, 2019 7:27 pm

PPTP is insecure STOP USING IT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
User avatar
vecernik87
Member
Member
Posts: 432
Joined: Fri Nov 10, 2017 8:19 am

Re: VPN PPTP ANDROID

Mon Feb 11, 2019 7:21 am

Despite the fact PPTP is not recommended due to security reasons, sometime it is useful due to its simplicity.

I tried to configure it and it works with my android phone (Xiaomi running Miui 9.5 which is based on Android 6.0.1) without any issue:
/ip pool add name=pool-pptp ranges=192.168.101.10-192.168.101.250
/ppp profile add dns-server=1.1.1.1 local-address=192.168.101.1 name=profile-pptp remote-address=pool-pptp use-encryption=yes
/ppp secret add name=launtel password=fastly profile=profile-pptp service=pptp

/interface pptp-server server set authentication=pap,chap,mschap1,mschap2 default-profile=profile-pptp enabled=yes
/ip firewall filter
   add action=accept chain=input comment="Allow PPTP VPN" dst-port=1723 protocol=tcp
   add action=accept chain=input comment="Allow PPTP VPN" protocol=gre

On my phone, I didn't set anything special - just type of VPN, username and password. Only caveat might be the encryption: With
use-encryption=yes
I can either enable or disable the PPP encryption in android. With
use-encryption=yes
I can use VPN only with disabled PPP encryption in android. With
use-encryption=required
I can use VPN only with enabled PPP encryption in android.

Since we don't know what setting you use, neither what does your log say, this is the best I can do. As said earlier, it would be good to have some log info. For example like this:
/system logging action add name=vpnlog target=memory
/system logging add action=vpnlog topics=pptp

Who is online

Users browsing this forum: krafg, mozerd and 32 guests