Community discussions

 
n1els
just joined
Topic Author
Posts: 4
Joined: Tue Dec 08, 2015 6:20 am

Managing 700Mbps queue limit on sfp interface on CCR1072-1G-8S+

Sat Sep 03, 2016 5:55 pm

On my 1072 I have an incoming connection on sfp7 which I want to limit to 700Mbps.

The queue is now configured as follows:
/queue type
set 0 kind=pfifo name=default pfifo-limit=50
set 1 kind=pfifo name=ethernet-default pfifo-limit=50
set 2 kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
set 3 kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10
set 4 kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
set 5 kind=pcq name=pcq-upload-default pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address \
    pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50KiB pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=128 \
    pcq-total-limit=2000KiB
set 6 kind=pcq name=pcq-download-default pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address \
    pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50KiB pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=128 \
    pcq-total-limit=2000KiB
set 7 bfifo-limit=150000 kind=bfifo name=only-hardware-queue
set 8 kind=mq-pfifo mq-pfifo-limit=50 name=multi-queue-ethernet-default
set 9 kind=pfifo name=default-small pfifo-limit=10
/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s disabled=yes limit-at=0/0 max-limit=710M/710M name=NL packet-marks="" parent=\
    none priority=8/8 queue=only-hardware-queue/only-hardware-queue target=sfp-sfpplus7 !time
/queue interface
set sfp-sfpplus1 queue=only-hardware-queue
set sfp-sfpplus2 queue=only-hardware-queue
set sfp-sfpplus3 queue=only-hardware-queue
set sfp-sfpplus4 queue=only-hardware-queue
set sfp-sfpplus5 queue=only-hardware-queue
set sfp-sfpplus6 queue=only-hardware-queue
set sfp-sfpplus7 queue=only-hardware-queue
set sfp-sfpplus8 queue=only-hardware-queue
set ether1 queue=only-hardware-queue
The problem is that if I enable this queue, the cpu usage immediately spikes to 100% across all cores. What is the best way (most economical with regards to cpu usage) to configure this queue?
 
Jeanluck
Member Candidate
Member Candidate
Posts: 272
Joined: Tue Apr 19, 2011 7:07 pm

Re: Managing 700Mbps queue limit on sfp interface on CCR1072-1G-8S+

Mon Mar 27, 2017 1:05 pm

Hi,
Do you find solution for your problem?
I have similar issue.

Regards

Who is online

Users browsing this forum: No registered users and 20 guests